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Download & Install

Right PDF is an all-around PDF multitool that can create, convert, edit,

comment, annotate PDF and more. Feature-rich and affordable, Right PDF is

your go-to choice when it comes to handling PDF documents.

This manual provides essential how-tos and instructions. You can also learn

more about installation, activation and other Right PDF products/services.

System Requirements

 Intel processor/Apple M1

 Mac OS X 10.14 and above

 1GB RAM

 3GB disk space

Download & Install

There are two ways you can access Right PDF: 1. download installer from Right

PDF website and buy a license, or 2. Subscribe to Right PDF on App Store.

If you choose 1, run the installer and follow the guide. You may need to

remove other Right PDF products before installing a new one.

Feel free to contact support if you run into any download or installation issues.

Activation

If you get Right PDF macOS from our website, you get 14 days of free trial

period. Most features will become locked when the trail period comes to an

end unless you activate it with a valid license, which is usually found in your

order confirmation email. ZEON does not collect or transfer any personal

information during activation.
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Online Activation

If your computer has internet connection, follow the steps below to activate

online:

1. Run the app. Go to Menu Bar and choose “Right PDF” > “License

Information”.

2. In " License Information," click "Activate".

3. Choose “Online,” enter the license code, and click “Activate”. Your

license code can be found in your order confirmation email, and it

should look like this: AA11-BB22-CC33-DD44-EE55-FF66-GG77-HH88

4. Online activation complete.

Offline activation

This is the only way to activate Right PDF If your computer does not have

internet connection. First you need to export an activation data file, move it to

a computer with network connection, and upload it to our activation server.

Here are the steps:

1. Run the app. Go to Menu Bar and choose “Right PDF” > “License

Information”.

2. In " License Information," click "Activate".

3. Choose "Offline".

4. Enter the 32 digit License Code, then click "Activate". You will receive a

confirmation e-mail that includes the license code after purchase.

5. Click "Next" to save the .htm file.

6. Copy the saved activation data file to any computer with internet access,

and use a browser to open file.

7. Click "Upload".

8. Click to download "License File" with .zna extension.

9. Copy the .zna license file back to the computer installed with Right PDF.

Click the icon at the center of the window to open the license file (.zna).

10. Offline activation complete.
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Deactivation

One copy of license can only activate Right PDF on one computer. You should

always remember to deactivate the software if you want to use it on a new

computer, and use the newly released copy to activate on the new one.

Online Deactivation

If your computer has internet connection, follow the steps below to deactivate

online:

1. Run the app. Go to Menu Bar and choose “Right PDF” > “License

Information”.

2. In "License Information" window, click "Deactivate".

3. Choose "Online".

4. Deactivation complete.

Offline Deactivation

Without internet connection, your only option is to export an deactivation

data file, move it to a computer with internet connection, and upload it to our

activation server.

See the steps below:

1. Run the app. Go to Menu Bar and choose “Right PDF” > “License

Information”.

2. In "License Information" window, click "Deactivate".

3. Click "Offline" to save the .htm file.

4. Click "Next" and copy "Deactivation Data.htm" to any computer with

internet access. Open it with a browser.

5. Click "Upload".

6. Deactivation complete.
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Updates, upgrades and maintenance

Updates

Users of full-function versions of Right PDF products are able to update within

the same "Major" number version (e.g. v1.0 to v1.1). Updates are free and

license code remains unchanged.

Upgrades

Users of full-function versions of Right PDF products can upgrade to a higher

"Major" version (e.g. v1.0 to v2.0) by purchasing an upgrade from ZEON.

Upgrade discount may be available at Right PDF Online Store for registered

Right PDF users.

Maintenance

Software Maintenance Services (SMS) entitles you to the following:

 New Product Release Versions - Keep up to date with free software

upgrades. If you are planning on upgrading, it is more cost-effective to do

so through SMS instead of purchasing a new version.

 Same License Code - Keep your original License Code for simple control

and management.

 Preferred Technical Support - subscribers receive prioritized technical

support.

Please visit Right PDF Online Store for more information about SMS.
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Chapter 2: Workspace

 Workspace basics

 Start page

 Menu Bar

 Ribbon Tabs

 File Tabs

 Document message bar

 Format sidebar

 Sidebar Navigation Pane
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Workspace basics

The Right PDF Editor workspace contains 8 key areas, which are Home View,

Apple Menu Bar, Ribbon tabs, File tabs, Document message bar, Document

pane, Sidebar Style pane, and Sidebar Navigation pane.

A. Home View

B. Apple Menu Bar

C. Ribbon tabs
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D. File tabs

E. Document message bar (this bar appears only when the document is signed

or includes form fields)

F. Sidebar Style pane

G. Document pane

H. Sidebar Navigation pane

Start page

Start page shows when you click the Start tab or launch Right PDF without

opening any document. This page provides quick access to recent files,

commonly used tools and 3rd party cloud storage services.

Menu Bar

Providing commonly used functions and commands, Menu Bar is located in

the top-left of Right PDF window.

File:
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 Open …. Browse to open a PDF.

 Open Recent. Choose and open a recent file. You can decide the

number of items on the list in Preferences > General > Recent files.

 New….You can create a blank PDF or a portfolio, or create PDF from

file, scanner, clipboard or webpage.

 Save…. Save the document.

 Save as….Save the document to a different location.

 Save Revision, Revert to Last Save, Open Revision. These enable you to

manage versions.

 Reduce File Size. Reduce the size of the current file or multiple files by

adjusting image quality.

 Export. Export current PDF to text, Word, Excel, PowerPoint or image

formats.

 Share. Share current PDF by email, message, AirDrop, or note.

 Print.... Print current file.

 Properties. View document properties.

Ribbon Tabs

Right PDF adopts ribbon design which provides sets of tools grouped

together based on the purpose they serve. For example, if you wish to

highlight a paragraph on a page, select Highlight on the Comment tab.

For a better reading experience, you can click the current tab to hide the

toolbar and enlarge the document pane.

File Tabs

View multiple files as tabs

The tab bar displays currently open files as tabs below the ribbon area. You

can open several files in the same window and use the left/right arrows at the

far right of the tab bar to navigate, or reorder files by simply dragging and
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dropping a tab within the same group. If you want to open one of the files in

new window, drag the tab away from the bar and release.

A. Grouped open files B. Left and right arrows for navigating all open files C. A list

of open files

The right-click menu of a Right PDF file tab provides the following actions:

 New a Blank PDF. Create a file that opens in a new tab.

 Open File in New Tab. Select a file and open it in a new tab.

 Save Current/Save All. Save the file you are currently viewing or save all

open files in this window.

 Combine All. Combine all open files in the current window into one PDF

document. This will launch the Combine Files dialog box where all open

files (of the current window) are listed. Click the Convert button to start

merging them into one.

 Close Current Tab/Close All. Close the file you are currently viewing or

all open files in this window.

 Print Current Tab/Print All Tabs. Print the file you are currently viewing

or all open files in this window.

 Open in New Instance. Open the current file in an new window. The file

will be removed from the tab bar of the previous window.

The tab bar feature is on by default. You can deselect the Open documents as

new tabs in the same window option at General > Startup panel of the

Preferences dialog box to always open a document in a new window.
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Document message bar

The document message bar at the top of the document pane appears only

when there are interactive form fields and when the document has been

signed. To locate where the form fields are within the file, click the Highlight

Fields button (A) enclosed within the message bar or choose Form >

Advanced > Highlight Form Fields to highlight all form fields, making it easier

for you to see where they are.

The document message bar also informs you the document is signed. To get

details of signature status, name of the signer, etc., click the Signature Panel

button (B) enclosed within the message bar to open the Signatures panel in

which all the details are listed.

As there might be signatures and form fields existing within the document at

the same time, you can click the Next Notification button (C) to go to the next

notification.

The Document message bar for form fields. Click the Highlight Fields button (A) to

locate where form fields are within the document.

The Document message bar for signed documents. Click the Signatures Panel

button (B) to open the Signature Panel where details of all signatures are listed. If

there are multiple notifications, they will be displayed side by side.
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Format sidebar

Format sidebar is located to the right of the work area and is hidden by

default. It expands when you select an annotation or click Advanced> Edit,

and shows the appropriate tools. Click the icon in the top right corner to

hide it.

Sidebar Navigation Pane

The Sidebar Navigation pane include 8 panels, Hand tool, Select tool,

Bookmarks, Thumbnails, Attachment, Comments, Stamps, and Security, which

are listed vertically on the left side of the work area. If it doesn’t show, click

the icon in the top right corner to expand it. With the exception of default

panels, others will become visible in the sidebar only when an associated

function is performed in a document. You can also customize the pane.

Right-click anywhere on the pane to show custom options, like hide, show or

restore default settings.
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1. Hide panel: deselect an item to hide it.

2. Show panel: select an item to show it.

3. Reset: click reset to restore default settings.
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Chapter 3: Viewing PDFs

 Adjust PDF views

 View and snap to grid

 Create ruler guides

 Switching between open windows

 Display PDFs in the line weights view

 View a document in multiple windows

 Reading PDFs
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Adjust PDF view

Change the page view

Right PDF provides page layout, view modes, view rotation options and other

features to let you decide how you are going to read the document.

Change the page display options

On View tab, in Scroll Options drop-down menu, select one of the following

page display options. You can use the left and right arrow keys to navigate

within a PDF file if files are opened in Single Page, Continuous, or Document

Assembly page display mode.

Page display options in the Scroll Options drop-down menu

 Single Page: display just one page at a time without any portion of the

previous and next page.

 Continuous: display pages in one long column so that you can

smoothly scroll through the document without sudden transitions.

 Continuous Facing: display two pages facing each other and placed

side-by-side with continuous scrolling enabled.

 Facing: display two pages placed side-by-side at a time.

 Document Assembly: display all pages at a time in the Document pane.
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Read in Full Screen Mode

Click Full Screen Mode in the View drop-down menu in Menu Bar, or press

Command + L on the keyboard to start Full Screen mode, meaning the

document occupies the entire screen without showing the application frame.

The pointer still works in full screen mode so that you can click links and open

notes.

In Full Screen mode, a toolbar will show when you move the cursor to the

bottom right, and you can:

 To go back to the previous page, click Previous , scroll up, or press

the upward arrow key; to go to the next page, click Next , scroll

down, or press the downward arrow key.

 Click Exit , press ESC, or use Command + L to exit Full Screen

Mode.

 To adjust page view size, click Single Page to show one page at a

time; or click Continuous to fit the window size and scroll pages

continuously.

The basic reading controls on the page navigation toolbar: A. To Previous Page B. To Next

Page C. Single page D. Continuous Page E. Exit Full Screen Mode

Resize page view

You can resize page view by using the value menu button (A) to the left of

ribbon, or click View > Resize (B) in Menu Bar to do the same.
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 Actual Size: view the document in its normal size.

 Fit Page: make the width and height of the document exactly fit within

the Document pane.

 Fit Width: make the width of the document fit within the width of the

Document pane.

 Fit Visible: to view a document without any portion of page margin in

the screen, select it to make the width of the document fit within the

width of the Document pane.

 Fit Height: make the height of the document fit within the height of the

Document pane.

Rotate page view

To view a PDF document in a desired orientation, use view rotation features to

view it properly. You can rotate the view clockwise and counterclockwise in

Right PDF. View Rotation features on the Page Viewing controls bar: A. Rotate

View Clockwise B. Rotate View Counterclockwise

 Rotate View Clockwise: click to temporarily rotate the view of all pages

by 90 degrees clockwise. The original page orientation is restored the

next time you open the PDF.

 Rotate View Counterclockwise: click to temporarily rotate the view of all

pages by 90 degrees counterclockwise. The original page orientation is

restored the next time you open the PDF.
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Note: Rotate View changes the way that a PDF file is displayed in the

Document pane. It temporarily changes the view for viewing purposes

only, but no changes to page orientation are saved to the PDF file.

Rotate Pages, however, permanently rotates the pages within the PDF

file.

Choose any way to rotate page view:

 Choose View tab > Rotate View Clockwise or Rotate View

Counterclockwise.

 In Menu Bar, click “View” > “Rotate View Clockwise” or “Rotate View

Counterclockwise”.

 Press Shift + Command + = or Shift + Command + - on the keyboard.

Adjust page zoom level

You can use Zoom tools or the Zoom level controls on the top of window to

view a page or an image with different magnification.

Use the Zoom tools

Go to the View tab and select Zoom tools to zoom in, zoom out, or just view a

particular area at high magnification.

 Zoom in/out. Select Zoom in/out to change the document

magnification by preset levels. You can click or drag a rectangle on the

page.

 Dynamic Zoom. Click Dynamic Zoom and a magnifying glass will

appear. Drag up/down a page with the magnifying glass to smoothly

zoom in/out pages without sudden transitions. Or, roll up/down a

mouse wheel to zoom in/out pages in preset levels.

 Loupe View. Click Loupe View and click again anywhere on the page to

call out the magnifying window. You can drag the loupe rectangle

around to change its loupe view. Changing the color for the loupe

rectangle is also available in the Loupe View Tool window.

1. Choose View > Loupe View.
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2. Click an area where you want to view in closer detail. A rectangle

appears in the document, corresponding to the area shown in

the Loupe View Tool window. You can also drag the rectangle to

change the view.

3. (Optional) To change the zoom level of the Loupe tool, you can

do any of the following:

 Drag the slider.

 Click the plus or minus buttons.

 Enter a zoom value in the zoom value text box.

Adjust Zoom level with the Zoom level controls

Adjust Zoom level with the Zoom level controls:

 Zoom in/out button: click the Plus (+) or Minus (-) button to change

zoom level.

 Zoom value text box: enter any number between 6.25 and 6400 into

the percentage field and press Enter.

 Zoom value menu button: click the arrow right next to the zoom text

box and select a preset percentage, ranging between 12.5% and

6400%.

Use split-window view

Using the Split commands, you can view a document with the document pane

divided into two panes (Horizontal Split and Vertical Split) . While viewing a

document with split windows, you can scroll though pages, adjust zoom level,

or jump to a specific page in one of the panes independently.
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Create a type of split view

1. Open a PDF file and go to the View tab.

2. Select a Split command as needed:

 Select Horizontal Split to horizontally split the view into two.

Alternatively, drag the small, grey rectangle box just over the top

of the vertical scroll bar down.

 Select Vertical Split to vertically split the view into two.

3. Click and drag the splitter bars up, down, left, or right to adjust the size

of the panes.

To adjust zoom level of each pane

 In Horizontal Split view, click a pane to make it active and change zoom

level for the active pane only.

 In Vertical Split view, change zoom level for both panes.

To scroll a document

 In Horizontal Split view, click a pane to make it active and then scroll

the document in the active pane only.

 In Vertical Split view, scroll the document in both panes simultaneously.

View and snap to grid

You can use grids to line up text and objects in a document. The grid becomes

visible once it is turned on. The Snap to Grid option helps you align an object

(can be selected text or images) to the nearest grid while moving the object.

View grids

1. Open a PDF file and choose View > Grid.



24 / 226

2. To hide the grid, click Grid again to turn it off.

Snap to grids

1. (Optional) To better align objects, turn on Grid in advance.

2. Choose View > Snap to Grid.

3. Move an object and it will automatically align with the nearest grids.

Change the grid appearance

You can change grid settings in the Preferences dialog box, such as page

units, grid line color, and more.

1. Do any of the following to open the Preferences dialog box:

 Choose Right PDF > Preferences….

 Press Command + K on your keyboard.

2. In the Preferences dialog box, choose General > Units & Grids and follow

the on-screen instructions to change grid settings:

 Width between lines/Height between lines. Both define the

spacing between grids.

 Grid offset from left edge/Grid offset from top edge. Both define

the origin of the grid.

 Grid line color/Grid line minor color. Choose a new color for the

grid lines from the color palette.

Height between grids increased
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Width between grids increased

Note: after Snap to Grid is activated, objects will be aligning with the "grids"

even if Grid is not turned on. Please remember to disable Snap to Grid to

make sure objects are placed as intended.

Create ruler guides

The horizontal and vertical rulers let you check the size (length and width) of

an object. Once turned on, the rulers will be displayed on the top and to the

left of the Document Pane. For aligning objects, you can also create guides in

your document.

View rulers

1. Choose View > View Rulers.

2. To hide the rulers, click View Rulers again to turn it off.

Create new ruler guides

1. Choose View > View Rulers.

2. Do either of the following to create new ruler guides:

 Click the horizontal ruler and drag down to create a horizontal

guide, or click and drag to the right of the vertical ruler to create

a vertical guide.

 Double-click a location on the horizontal ruler to create a vertical

guide, or double-click a location on the vertical ruler to create a

horizontal guide.
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3. To hide guides, choose View > View Guides. You can click it again to

show guides.

A. Horizontal ruler guides and B. Vertical ruler guides appear on a page where View

Guides is on.

Change guide colors

You can change guide colors in the Preferences dialog box.

1. Do any of the following to open the Preferences dialog box:

 On Menu Bar, Choose Right PDF > Preferences.

 Press Command + K on your keyboard.

2. In the Preferences dialog box, choose General > Units & Grids.

3. Click the Guide Color square and choose a predefined color from the

color palette or define a custom color.
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Switching between open windows

Using Switch Windows, you can switch between documents you have already

opened. It is especially useful if you have opened a large number of PDF

documents and want to quickly switch between them.

 Open multiple files and choose View > Switch Windows. Click the

down-pointing arrow next to Switch Windows and select the document

you want to view from the menu.

 On Menu Bar, click Window and choose a file from the bottom file list

to switch.

Display PDFs in the line weights view

By default, the Line Weights view is off. It displays lines with the weights

defined in the PDF. When Line Weights is on, it applies a constant stroke width

(1 pixel) to lines. When you print the document, the stroke prints at the true

width.

View a document with the Line Weights view on

1. Choose View > Line Weights to turn it on.

2. To turn off the Line Weights view, choose View > Line Weights again.
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Line Weights off

Line Weights on turning lines into a constant stroke width 1 pixel
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View a document in multiple windows

You can create multiple windows for the same document using the New

Window feature. The current document is then copied to a new window that

retains the same page layout and magnification level.

When you create a new window, the file name of the original window is given

a suffix":1" and the new window suffix":2". If you close one window, the

remaining windows are renumbered sequentially. For example, as

demonstrated below, there are four windows from the same document. If you

close the second window PDF Learning Guide: 2, the remaining three windows

are automatically renumbered in order. You can close multiple windows

without affecting the original window as long as there is more than one

window open.

To open a new window

1. Open a PDF file and choose View > New Window.

2. A new window displaying the same page pops up on top of the original

window, with the suffix:2 added to its file name. Repeat clicking New

Window to create more windows for the document.

3. You can click the close box to close the window. It does not close the

original window as long as more than one window is open.

Reading PDFs

This function reads text within a document and allows those who have visually

or mobility impairment to read and view files easily.

1. Open a PDF document and choose Basic tab.

2. In the Read Out Loud group, choose an appropriate option for reading:

 Read This Page. It only reads the current page. Click to start

reading, and click again to stop and start over from the

beginning.
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 Read To End. It reads the entire document. Click again to stop

reading.

 Pause. This button is available only when the reading is in

progress. When paused, the button changes to Resume.

 Rate Up. It increases the reading speed.

 Rate down. It decreases the reading speed.
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Chapter 4: Creating PDFs

 Creating PDFs within Right PDF

 Creating PDF Portfolios

 Create a PDF from web page
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Creating PDFs within Right PDF

There are various ways to create a PDF file with Right PDF. You can generate a

PDF quickly by using menu commands, scanning paper-based documents,

converting clipboard content, or simply creating a blank PDF.

Create a blank PDF

You can directly create a blank PDF without having to retype a file, copy

contents from the clipboard, or scan to a new document.

 Open a PDF in Right PDF and on Menu Bar, choose File > New > Blank

File. Click Blank PDF to open a blank page in Write mode.

 Choose File > Save or File > Save as, and then give it a name and

specify a location to save.

Create a PDF from scanner

Right PDF lets you create a PDF file directly from a paper document with ease.

You can choose to scan to a new document or to an existing file or portfolio in

scan settings.

1. On Menu Bar, choose File > New > From Scanner and select Quick

Scan.

2. In the Scan Settings dialog box, select a scanner from the Scanner

drop-down menu. In the Output section, if you are going to create new

PDF files, select New PDF Document; to create multiple files, click More

Options... and define the naming method for the output PDF files; to

append the scanned content to an existing file or portfolio, select

Append to existing file or portfolio.

3. In the Document Settings section, decide whether to reduce file size,

run OCR, and make PDF/A-1b compliant.

4. Click Scan.
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Convert file(s) to PDF using menu commands

It is possible to create PDFs from different file types within Right PDF, without

having to open them in their native applications.

You are able to select one or multiple files and directly open all of them as

PDF documents in Right PDF. All the selected files are converted separately

and opened in respective PDF documents.

1. Choose File > New > From File.

2. In the Open dialog box, select the file to convert. You can browse all file

types or select a type from the drop-down menu.

3. Click Open to convert the file to a PDF.

4. When the new PDF opens, choose File > Save or File > Save as, and

then give it a name and specify a location to save.

To create a PDF from clipboard

Create a PDF from the Clipboard lets you quickly create a PDF file from what

you recently saved to the clipboard, making it easier to share screenshots and

images with other users.

1. Copy or cut the text, image, or part of the screen, etc., to be converted

to a PDF document.

2. Choose File > New > From Clipboard and click From Clipboard.

3. The generated PDF document is opened directly in Right PDF.

Creating PDF Portfolios

PDF Portfolio overview

A PDF Portfolio is a collection of files packaged into an integrated PDF unit.

You can add any files to a PDF Portfolio, such as Excel spreadsheets, Word
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files, PDF documents, images, email messages, or even U3D files. However,

PDF is the only format that can be opened and viewed in a PDF Portfolio. See

the following for more about Right PDF Portfolio workspace.

A. PDF Portfolio workspace comprises cards representing component files

and folders.

B. PDF Portfolio toolbar allows navigating through files in a list view,

adding files or folders, making changes to portfolio settings, and

sorting component files.

C. PDF Portfolio document pane.

The PDF Portfolio toolbar

 Go home to navigate through files visually (A) lets you get back to view

components in a grid view that displays cards representing component

files.
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 Go to list view to navigate through files using file details (B) displays

components in a list view with details of file properties.

 Add files (C). Select and add individual files.

 Add Existing Folder (D). Add selected folders.

 Create New Folder (E). Create a new folder.

 Option (F). You can sort components files and folders by description,

compressed size, etc., select all files/folders, hide/show the cover sheet,

and edit portfolio properties.

Scroll through component files

You can scroll through component files using the Previous (A) and Next (B)

buttons, which are located at two different places depending on the current

view. The Previous button lets you go back to the previous file and the Next

button move forward to the next file.

 If you are visually viewing a PDF Portfolio in a grid view, the buttons

appear at the bottom of the component file pane to the left, as shown

below.
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 In a list view, they appear in the upper part of the document pane with

an adjustable border, as shown below.
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Note: the previous and next buttons switch between PDF files placed in

the same path level in your PDF Portfolio. For example, if there are a

bunch of files and a folder placed under Home/ and you open one of

the files, the buttons switch through only those files, and contents in

the folder are not included (Home/folder).

Create PDF Portfolios

Portfolio generally refers to an organized presentation of an individual's

experiences, work samples, etc., allowing users to quickly view an entire

collection of related files. It is easy to create a PDF Portfolio, add files and edit

Portfolio properties. You can create folders within your PDF Portfolio, move

and delete component files, and search for words or phrases within selected

documents or an entire PDF Portfolio. You can create a basic PDF Portfolio in

a few steps:

1. Start Right PDF and choose File > New … > PDF Portfolio.

2. You can start adding contents to an existing PDF Portfolio. Click Add

files/Add Existing Folder and select a file or folder to add to the PDF

Portfolio. You can select one or more files/folders.

3. Save the PDF Portfolio by doing one of the following: On the Quick

Access Toolbar, click Save. Or choose File >Save.

Add files and folders to a PDF Portfolio

You can add contents to an existing PDF Portfolio by doing any of the

following:

 Click Add files or Add Existing Folder to add individual files or a folder.

 To create a folder, click Create New Folder and name it. Click OK.

 To move files and/or folders to a different folder, click and drag them

to the new folder.
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To remove files and folders from a PDF Portfolio

You can delete a file/folder or multiple files/folders. If you delete a folder, all

files within are deleted from the PDF Portfolio along with the folder.

 To delete a file/folder, right-click on it and select Delete. Click Yes.

 To delete multiple files/folders, hold down Command on your keyboard

and select the files/folders to be removed from the Portfolio. Right-

click any of the selected files/folders and select Delete. Click Yes to

delete all selected items.

Note: you can hold down Command to select multiple files or folders.

To select all files and folders within the PDF Portfolio, right-click on

anywhere and select Select All.

Working with component files in a PDF Portfolio

Right PDF provides portfolio viewing options that enable users to present

content in an optimal layout. There are two ways to navigate through

files/folders: View files in a grid and View files in a list. You can then sort and

change the order of displayed columns and files or folders under certain

columns, as well as edit component file names and descriptions in a PDF

Portfolio.

Navigate through files in a list/grid

You can choose to view component files in a list or a grid view. By default, files

are placed in grid but you can switch to a list view by clicking the Go to list

view to navigate through files using file details button on the PDF Portfolio

toolbar.

 View files in a grid All component files/folders are presented in Grid

view by default, which are used mainly for presentations or brochures.

In a Grid view, each card represents a file or a folder and also shows

thumbnail and information about the document, including file name

and description.
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To switch from list view to a grid view, on the PDF Portfolio toolbar,

click Go home to navigate through files visually to restore grid viewing.

 View files in a list You can choose to view files/folders in a list that

shows the details of component files. By default, the columns contain

properties including name, description, size, date created and modified,

and compressed size. You can also change the order and edit file

properties of the displayed columns by using the Portfolio Properties

dialog box.

Set an initial view when opening Portfolio

You can decide the way all files/folders are arranged and whether to show

cover sheet when a PDF Portfolio document is first opened. Right PDF

provides the following three ways, Top (list view), Left (gird view) and

Minimized (files hidden) to customize your PDF Portfolio workspace.

 Where to show the files/folders list in Portfolio

1. On the PDF Portfolio toolbar, click Option and select Portfolio

Properties... from the options.

2. In the Portfolio Properties dialog box, choose from Top, Left or

Minimized in the Initial view drop-down menu to decide how to

display the files and folders list when you first open the PDF

Portfolio.

3. Click OK.

 Whether to show cover sheet

1. On the PDF Portfolio toolbar, click Option and select Portfolio

Properties... from the options.

2. In the Portfolio Properties dialog box, check the Show cover

sheet when opening portfolio option to display the default cover

sheet when you first open the Portfolio.
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Edit file details in a list

You can decide which details are on display when you navigate through files

in a list view.

1. On the PDF Portfolio toolbar, click the Option button and select

Portfolio Properties... from the options.

2. In the Portfolio Properties dialog box, do either of the following to

select the fields to be displayed in the list:

o Check the checkbox of the field you want to display in the Fields

settings box. Or select to highlight the field and click the

Show/Hide button to make it visible/invisible.

o To rearrange the field order in the file list, use the Up/ Down

buttons to move the selected field forward or backward.
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Alternatively, close the Portfolio Properties dialog box and click-

drag the column name of the field to a different position within

the list.

o To add a new field to the list, click the Add button and then type

a name in the Enter new field name field box. Click OK.

o To delete existing fields, click on the item in the Fields box and

then click the Delete button to remove it from the list. Default

fields, such as name and description, cannot be removed from

the file list, but you can hide them by unchecking their

checkboxes if needed.

Sort and change the order of files or folders

By default, component files are placed following alphabetical order, but you

can change the order by sorting files or folders by values and by ascending

(A-Z) or descending (Z-A) order.

1. On the PDF Portfolio toolbar, click the Go to list view to navigate

through files using file details button to view all component

files/folders in a list view.

2. On the PDF Portfolio toolbar, click the Option button and select

Portfolio Properties... from the options. In the Portfolio Properties

dialog box, do the following to change the order in which component

file/folders are displayed in the file list:

o Choose the type of field to be sorted alphabetically from the

Sort by drop-down menu.

o Choose to sort files/folders in the selected column by ascending

or descending order from the Sort order drop-down menu.

Edit component file names and descriptions in a PDF Portfolio

You can edit the file name and description of a component file in either a list

view or a grid view.

 To edit the file name of a component file, do either of the following:

o In a grid view, select a file and click the file name text box (A) to

show the insertion point. Then type text in it and press Enter.
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o In a list view, select a file and double-click the text box under the

Name column to show the insertion point. Then, type text in it

and press Enter.

Note: if you change the file extension, a message shows up to

inform you the file may not be opened or displayed correctly.

 To edit the description of a component file, do either of the following:

o In a grid view, select a file, click the area below file name, and

type in the text box.

o In a list view, double-click the text box under the Description

column to show the insertion point and then type text in it.

In a grid view, double-click the file name (A) text box to edit the file name and the

Add Description (B) text box to edit the description of the selected component file.

Search a PDF Portfolio

You can search through all PDF documents within the PDF Portfolio, Selected

Portfolio Documents, or the current document for specific words, phrases, or

patterns such as phone numbers. The default Search window provides basic

search options to help you narrow down the results.

On Menu Bar, click Edit > Search, or Basic tab > Search to open the Search

window.
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Search For

By default, the Search window displays basic search options that can help you

narrow down results.

 To search the current document: It searches through the document you

are currently viewing instead of the entire PDF Portfolio.

 To search selected content within a PDF Portfolio: You can search for

specific words or phrases in the selected PDF documents.

 To search all PDF documents within a PDF Portfolio: You can search for

specific words, phrases, or patterns in the entire PDF Portfolio.

 To search selected content within a selected folder: You can search for

specific words or phrases in the selected folder.

 If you choose to search an external folder or indexes, click on Advanced

and specify the Additional Criteria that follows.

 If you choose to search Currently Selected Indexes, you must have

selected indexes files in Index Manager. Otherwise, you have to select

Select Index... to add Index files (*.zpi).

What word or phrase would you like to search for.

Enter the text or phrase to search for.

 Single word or phrase. Enter the word or phrase you would like to

search for and define its searching options:

 Multiple words or phrase. You can search for more than one words or

phrases. Click Select Words... and add new words or phrases.

 Patterns. Select a type of information you would like to search for from

the drop-down menu. Click Search.

 Arbitrary mask. It changes the format category to custom and makes

another text field available, in which you can type a custom format.

In addition, other options like Match Case, Match whole word only, Include

Comments, Include Bookmarks, Include Subfolders and Stemming are also

available.

Notes: searches do not apply to non-PDF files inside PDF Portfolios.



44 / 226

Create a PDF from web page

You can directly turn web pages to PDF with Right PDF. While links and

images will show and function just like the original web page, animated files

will appear as still images of last frame of the animation in the result PDF.

1. Open Right PDF and select File > New > From Web Page.

2. In the Create PDF from Web Page dialog box, enter URL in the field

box, or click Browse and locate a HTML file.

3. Click Settings... and change the selected options in the Web Page

Conversion Settings as needed. Click OK.

4. Click Create.
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Chapter 5: Editing PDFs

 To edit or format text in a PDF

 To move or resize an image
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To edit or format text in a PDF

You can use the Edit tool to modify text and object directly without having to

open the original document in another application. The features let you edit

your PDF file on a small scale, for example correcting typos, changing font

size, and adjusting paragraph layout.

An object is selected using Edit tool. The Format sidebar to the right shows Edit

Text section (A) and Edit Object section (B).

To add text to PDF

1. Select Advanced > Add Text.

2. Click anywhere on the page to create a bounding box.

3. Enter text when the cursor blinks.

4. Click-drag the handles to resize bounding box.

5. To move text box, move the cursor over the frame of the bounding

box, and drag it to a new location when the cursor changes into a four-

headed Move pointer.
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To edit or format text in a PDF

Using the Edit tool, you are able to edit the text on PDF, and adjust fonts or

paragraphs.

1. Choose Advanced > Edit.

2. With Edit tool, you can edit or format text, or move or rotate bounding

box.

o Edit: Click the part of text you want to edit. When the cursor

blinks, type in new text, paste or delete text. Using the Edit Text

section (A) in the Format sidebar to the right, you can select a

font, font size, a fill color, or another font in the Font section, as

well as adjust text alignment, line spacing, character spacing and

horizontal scaling.

o Move: move your cursor over the frame of a bounding box and

you will see a four-headed Move pointer. Drag the box to the

desired location.

o Rotate: place the cursor over the rotate handle. When the cursor

changes into the Rotation pointer, drag in the direction you

want it to rotate.

Note: text editing might not be perfectly executed due to font embedding

issues.

To move or resize an image

Choose Advanced > Edit, and select an image. After the Format sidebar

expands, go to the Edit Object section (B) to rotate, flip, crop, etc.
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An object is selected using Edit tool. The Format sidebar to the right shows Edit

Text section (A) and Edit Object section (B).

To add an image

1. Choose Advanced > Add Image.

2. In the ensuing dialog box, select an image file and click Open.

3. Use the selection handles around the bounding box to resize the

image. You can further rotate, crop, flip, or move the image using the

Edit tool.

Move an object in front or behind other elements

1. Open the PDF, and then choose Advanced > Edit.

2. Select an object and go to Edit Object > Arrange section, and use the

functions to arrange it: Bring Forward, Bring to Top, Send Backward, or

Send to back.

To move or resize an object

1. Choose Advanced > Edit.
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2. Do either of the following to move or resize:

o To move the object, click on the object to show the bounding

box with selection handles. Then use the four-headed Move

pointer to drag the image to the desired location.

o To resize the object, click on the object to show the bounding

box with selection handles. Then drag a selection handle. The

cursor changes when you move it over the handles on the frame.

To rotate, flip, or crop an image

1. Choose Advanced > Edit.

2. Select an image to show the Format sidebar, and find the Edit Object

section, which has the following functions. Alternatively, right-click on

the object and select functions from the menu. Do the following as

needed:

o Rotate: select Rotate Clockwise to rotate the selected image 90

degrees in a clockwise direction, or Rotate Counterclockwise to

rotate the selected image 90 degrees in a counterclockwise

direction. Another way is that you can place the cursor over the

rotate handle. When the cursor changes into the Rotation

pointer , drag in the direction you want it to rotate.

o Flip: select Flip Horizontal to flip the image horizontally, on the

vertical axis. Or, select Flip Vertical to flip the image vertically, on

the horizontal axis.
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Chapter 6: Commenting and Sharing

PDFs

 Commenting in PDFs

 Managing comments

 Measure Distance, Perimeter, and Area
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Commenting in PDFs

Commenting preferences

Commenting preferences affect the default appearance of and how you view

annotations and markups in a PDF. To open the Preferences dialog box, do

any of the following and select Comment from the options listed in the panel

to the left:

 On Menu Bar, choose Right PDF > Preferences….

 Press Command + K on your keyboard.

Comment

Under Comment, you can determine the default font and text alignment

settings of text for pop-up notes.

 Reset Comment Defaults. Click to restore all comment default

appearance settings to factory values. Restart is required.

 Text Box Default Font. Determine font name, font size, underline, and

font color for Basic tools such as Typewriter, Text Box, and Callout.

Changes to these settings apply to new comments only.

 Text Box Default Align. Specify the text aligning position for Basic tools

such as Typewriter, Text box, and Callout text boxes. Changes to these

settings apply to new comments only.

Commenting

You determine the behaviors of pop-up notes and comments that appear

therein. The checkboxes within the Making Comments area are explained

below:

 Always use Log-in Name for Author name. If you select this box, the

Login name (Right PDF > Preferences… > General > Identity > Login

Name) becomes the author name in the pop-up notes.
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 Create new pop-ups aligned to the edge of the document. Align new

pop-up notes to the edge of the document pane. If deselected, pop-up

notes appear right next to the annotation you make.

Aligning pop-up notes to the right edge of the document pane (Left). With the

option deselected, the note appears right next to the note icon (Right).

 Copy encircled text into Drawing comment pop-ups. The text within the

area created by Draw Tools such as Oval, Rectangle, Polygon, or Cloud,

is automatically copied to the associated pop-up notes. This does not

apply to tools that cannot create an area, such as pencil, line, or arrow.

 Copy selected text into Highlight, Cross-out, and Underline comment

pop-ups: the text selected by Highlight, Cross-out, or Underline tool, is

automatically copied to their pop-up notes.

The text within the area created by Draw Tools is copied and pasted into the

pop-up notes (Left). The text highlighted with text markup tool is copied and

pasted into the pop-up note (Right).

 Automatically open comment pop-ups: Pop-up notes appear

immediately when comments are created with draw tools or text

markup tools; otherwise, you need to double-click to open them.
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Notes

Add notes as annotations

The most common type of comment is Note, which lets you direct the

attention of readers to a specific area of page. For instance, you can add a

note anywhere on the page and type text in the associated pop-up note for

other reviewers to see.

1. Open a PDF and choose Comment > Basic Tools > Note .

2. Click on the page where you want to place the sticky note and then a

pop-up note appears. You can also format the text in the Popup tab

which appears when you type in it.

3. To show or hide the pop-up note:

o To hide a pop-up note: Click on the exit icon in the top-right corner

of the pop-up note to hide it. Or right-click on the note and choose

Minimize Pop-Up Note from the options.

o To show a pop-up note: Double-click the sticky note to show it. Or

right-click on the sticky note and choose Open Pop-Up Note from

the options.

Note: right-click on any of the existing comments and select Open All Pop-

Ups/Minimize All Pop-Ups from the options to show or hide pop-up notes of

all comments instantly.

To edit note properties

1. Right-click on the sticky note and select Properties....

2. On the Display tab of the Note Properties dialog box, edit the visual

characteristics of the note, such as Icon, Color, and Opacity.

3. On the Author and Subject tab, you can edit the Author and Subject

details for the note.

4. On the History tab, you can view all changes made to the comment.

Note: you are able to click-drag the sticky note icon and move it anywhere on

the page of the document.
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To reply to a note

1. If the pop-up note is hidden, double-click the note icon to make it appear.

2. Right-click on the pop-up note and select Reply from the menu options.

3. An additional pop-up note appears inside the original one. You can then

write your response in it.

Comment with basic commenting tools

Typewriter, Text Box and Callout tools let you add text comments anywhere

on the page.

 You can use the Text Box tool to type text in a box that is movable and

resizable. Unlike a pop-up note, it always remains visible on the

document.

 You can use the Typewriter tool to add additional text directly on the

page. Different from Text Box, the Typewriter box is hidden after you

finish typing.

 The Callout tool serves to create a callout box with an arrow pointing to

a particular spot on the page. The callout box expands vertically as you

type so that all text remains visible. It can be useful especially when you

want to associate a comment with a related section of text or image.
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To comment with typewriter, text box or callout

1. Open a PDF and choose Comment > Typewriter, Text Box, or Callout.

2. Click on the page where you want the box to appear. Then you can

type text in it.

Examples of adding notes with Typewriter (A) Text Box (B) and Callout (C)

To edit properties

1. Right-click on the box with the Select tool and select Properties....

2. In the Display/Text Box/Callout Properties dialog box, do the following

if needed:

o On the Display tab, edit the appearance of the box, such as

Color, Opacity, Thickness and more.

o On the Author and Subject tab, you can edit Author and Subject

details.

o On the History tab, you can view all changes made to the box.

To move or resize a text box

 To move: click inside a text box and drag to move it anywhere on the

page.

 To resize: click-drag its selection handles to resize it.

Add a stamp to a PDF

Stamps work much like applying a static rubber stamp to a paper document.

The extra merit is that you can use Dynamic stamps to indicate the name,
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date, and time information on the stamp without having to create multiple

static stamps for your purposes. You can choose one from a list of predefined

stamps on the Stamps panel or create your own stamps from an image or a

template.

Open the Stamps panel

1. Do either of the following:

o Choose Comment > Stamp.

o On the Sidebar Navigation pane, click on the Stamps icon to

open the Stamps panel.

2. The Stamps panel displays all preset stamps. Click Collapse All to

display only the names of categories. To show all stamps, click Expand

All.

To apply a stamp to a PDF

By default, predefined Stamps are categorized into three groups - Dynamic,

Legal, and Standard.

1. In the Stamps panel, choose a stamp category and then select a stamp.

2. To place the stamp on the page: Click anywhere on the document page

where you want to place the stamp. Or click-drag a rectangle to define

the size and placement of the stamp.

3. If you have not set up your identity information yet (Right PDF >

Preferences… > General > Identity), the Identity Setup dialog box will

prompt you to enter the identity information that will appear on your

digital identity stamps. Click Complete.

To edit Stamp properties

1. Right-click on the stamp using the Hand tool or Select tool, and select

Properties.

2. In the Stamp Properties dialog box, do any of the following as needed:

o On the Display tab, determine the Color of stamp pop-up notes

and Opacity of stamps.
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o On the Author and Subject tab, you can edit the Author and

Subject details.

o On the History tab, you can view all changes made to the stamp.

To move, resize and rotate a stamp

 Using the Hand tool or Select tool, click-drag to move it anywhere on

the page.

 Using the Hand tool or Select tool, click on it and drag selection

handles to resize.

 Using the Hand tool or Select tool, click on it and a blue box appears

around the shape. Hover your cursor over the rotate icon and drag it in

clockwise or counterclockwise direction.

To create a custom stamp

You can create two types of custom stamps, from an image or a template.

1. Choose Comment > Stamps.

2. Click the Create button at the top of the Stamps panel.

3. There are two ways to create a stamp:

o Select Create From an Image.... Choose a file and determine its

Group by either choosing one from the Group options (Dynamic,

Legal, or Standard) or typing in a name to create a new group.

Then decide its Stamp Name and click OK. To remove

background of the selected image, click Apply Transparency and

click on the image.

o Select Create Custom Dynamic Stamp.... Select a Stamp

Template and specify its Group, Stamp Name, text to display,

and Color. Click OK.

4. The newly-created custom stamp appears in the specified group in the

Stamps panel.

5. Select the stamp and click on the page or drag a rectangle at where

you want to place it.
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Set up a dynamic stamp in the Dynamic Stamp dialog box (Left). Insert types of

stamps in a page for various purposes (Right): A. Dynamic stamp B. Legal stamp C.

Standard stamp D. Custom Dynamic stamp

Annotate with text markup tools

Text markup tools let you indicate the text that needs more attention without

changing the actual text in PDF. You can use Text markup tools to mark up the

text that you want to delete, insert, replace, or highlight during document

collaboration.

To mark up text

1. Open a PDF and choose Comment, and then select one of the text

markup tools.

2. Alternatively, select the text to mark up using the Select tool, right-click

on the text, and choose a text markup tool from the options.

3. Double-click the text markup to call out its pop-up note in which you

can type a message as feedback or comment. Pop-up notes of the

markups created by Insert Text or Replace Text will show automatically

without requiring a click.
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To delete text markup

Do one of the following:

 Right-click on the marked text with Hand tool and select Delete.

 Right-click on the marked text with Select tool and select Edit > Delete.

 Click with either the Hand tool or the Select tool and press Delete on

the keyboard.

To edit text markup properties

1. Select either the Hand tool or the Select tool. Click on the markup to

have it highlighted with a blue frame. Right-click on the markup and

select Properties....

2. In the text markup Properties dialog box, do any of the following as

needed:

o On the Display tab, edit visual characteristics of the selected text

markup.

o On the Author and Subject tab, you can edit the Author and

Subject details.

o On the History tab, you can view all changes made to the text

markup.

Note: you can apply more than one markup on the same text, meaning

the text can also be underlined and highlighted.

Highlighted text (Left); Text that is both highlighted and underlined (Right)

Mark up with draw tools
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Draw Tools (Line, Arrow, Oval, Rectangle, Polygon, Cloud, Polygon Line, Pencil,

Eraser, and Hammer) can be used to provide feedback or comments during

document review. Similar to editing visual characteristics of basic comment

tools, it is easy to change the appearance of the drawings, such as Note,

Typewriter, Text Box, Callout, and Stamps.

To add a drawing markup

 Add a line or arrow

1. Open a PDF file and choose Comment > Draw Tool >

Line/Arrow.

2. Click on the page and drag to define its length and placement.

 Add an oval or rectangle

1. Open a PDF file and choose Comment > Draw Tool >

Oval/Rectangle.

2. Do either of the following:

 Click on the page where you want to place the drawing

markup.

 Click and drag to define the size and placement of the

oval/a rectangle.

 Add other shapes

1. Open a PDF file and choose Comment > Draw Tool >

Polygon/Cloud/Polygon Line.

2. Click on a page, move the cursor and click again to create a line.

Repeat it to create an open shape that comprises line segments.

3. To complete drawing, double-click or right-click and choose

Complete.

 Add a free-form drawing

1. Open a PDF file and choose Comment > Draw Tool > Pencil.

2. Click-drag the pointer on the page to draw.

3. To remove marks created by the Pencil tool, please select Eraser

and move the cursor back and forth to erase them.

4. Double-click on the free-form drawing using Hand tool to call

out its pop-up note.
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Note:

o The Erase tool can only be used to erase pencil drawings. Other

drawing markups cannot be wiped out by the Erase tool.

o The Hammer tool "hammers" only polygons and polygon lines,

making curves and zigzags straight. It can also add a vertex to a

straight line that you can drag to determine its angle.

Using the Hammer tool to break off a line (Right)

To move a drawing markup

 Using either Hand tool or Select tool:

 Click anywhere inside the drawing markup you want to move and drag it

to anywhere on the page.

To edit properties of a drawing markup

1. Using either the Hand tool or the Select tool, right-click on a drawing

markup and select Properties....

2. In the drawing tool Properties dialog box, do any of the following as

needed:

o On the Display tab, edit visual characteristics of the selected

drawing markup.

o On the Author and Subject tab, you can edit Author and Subject

details.
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o On the History tab, you can view all changes made to the

drawing markup.

Edit the appearance of a Line drawing markup

You can convert a straight line drawing into an arrow by editing Line

properties.

1. Using either the Hand tool or the Select tool, right-click on a straight

line drawing and select Properties....

2. On the Display tab of the Line Properties dialog box, do any of the

following: Click the Start drop-down menu. If you select Open, the

straight line changes into an arrow drawing. There are more options

available listed in the Start menu to choose from. Or click the End drop-

down menu. You can decide the look of the end point of the selected

line.

Various Line drawing markups by editing Line properties: A. Single arrow line markup B.

Double arrow line markup C. Straight line markup
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To delete a drawing markup

Do one of the following:

 Right-click on it with the Hand tool and select Delete.

 Right-click on it with the Select tool and select Edit > Delete.

 Click with the Hand tool or the Select tool and press Delete on the

keyboard.

Attach files as annotations

The Attach a File tool lets you place reference files or lengthy text that doesn't

cope well with pop-up notes into your PDF documents. Reviewers can double-

click the attachment icon to open the file.

To attach a file

1. Open a PDF in which you want to add a file attachment and choose

Comment > Attach a File.

2. Click on the page where you want to attach a file.

3. In the Open dialog box, choose a file you want to attach, select it, and

click Open.

4. The file attachment icon appears on the page. Do either of the

following to open the file:

5. Double-click on it to open; or right-click on it and select Open.

Note:

1. To view an attachment file, you must have the application installed on your

computer that can open the file.

2. Files attached via Document > Attachments will not be shown in the

Comments panel.
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To edit properties of a file attachment

1. Using either the Hand tool or the Select tool, right-click on the file

attachment icon and select Properties....

2. In the File Attachment Properties dialog box, do any of the following as

needed:

o On the Display tab, set up the appearance of the file attachment

icon.

o On the Author and Subject tab, you can edit the Author and

Subject details and add description to the attachment. The

description is displayed on the corresponding File Attachment

column in the Comment panel.

o On the History tab, you can view all changes made to the file

attachment.

To open and save a file attachment

 To open a file attachment, directly double-click the file attachment icon

to open it. Or, right-click on the file attachment icon and select Open

from the options.

 To save a file attachment, choose File > Save As and specify a location

to save it. The embedded file attachment is saved along with the PDF

file. Note: the attached files are embedded in the PDF and always saved

with the PDF they are attached to.

Add an audio comment

Using Attach a Sound, you can add a prerecorded WAV file or record one

yourself. The audio attachment appears in the Comments panel and you can

further edit properties of the sound attachment icon and view the history of

changes.
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To add a prerecorded audio comment

1. Choose Comment > Attach a Sound.

2. Click on the page where you want to place an audio comment.

3. In the Attach Sound dialog box, click the Browse... button and select the

audio file you want to add. Click Open.

4. The sound attachment icon appears on the page and you can then

right-click to edit its visual characteristics.

To record an audio comment and place it in a PDF

1. Choose Comment > Attach a Sound.

2. Click on the page where you want to place an audio comment and the

Attach Sound dialog box appears.

3. In the dialog box, click the Record button and speak into the

microphone. Note that this button appears only when your computer

has supported hardware for recording purpose.

4. When you are done with recording, click the Stop button to finish. Click

OK.

5. You can then click the Play button to play the file.

To edit properties of an audio attachment

1. Using either the Hand tool or the Select tool, right-click on the sound

attachment icon and select Properties....

2. In the Sound Attachment Properties dialog box, do any of the following

as needed:

o On the Display tab, set up the appearance of the sound

attachment icon.

o On the Author and Subject tab, you can edit the Author and

Subject details and add description to the attachment. The

description appears on the corresponding Sound Attachment

column in the Comments panel.

o On the History tab, you can view all changes made to the sound

attachment.
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Managing comments

View comments

You can view all the comments added to the PDF document in the Comments

panel that provides a toolbar with commonly used options, such as searching,

sorting, filtering, and more.

To open the Comment panel

1. On the Sidebar Navigation pane, click on the Comment icon.

2. You can then use the options at the top of the Comment panel to work

with comments, such as adjusting comment viewings, deleting, filtering,

sorting, searching, and more.

To expand or collapse comments

1. On the Sidebar Navigation pane, click on the Comment icon.

2. In the Comment panel, do any of the following to expand or collapse

comments in panel:

o To expand or collapse all comments, click the Expand all elements

in panel (A) or the Collapse all elements in panel (B) button.

o To expand or collapse individual comments, click the plus or minus

button to the left of comment.
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Comments are collapsed already (Left). Click the Expand all elements in panel

button (A) to expand the comments. Comments are expanded already (Right). Click

the Collapse all elements in panel button (B) to collapse the comments.

Sort comments

You can sort comments in the Comments panel by type, page, author, date,

color, or checkmark status.

1. On the Sidebar Navigation pane, click on the Comment icon.

2. In the Comment toolbar, click the Change how comments are sorted

button and choose an option from the drop-down menu.

Filter the displayed comments

Filter the displayed comments lets you hide or show comments based on type,

reviewer, status, or checked state. Filtering affects both the comments in the

document window and in the comment panel. For example, if you select Hide
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all comment, all the comments in the document and Comment panel will be

hidden.

1. On the Sidebar Navigation pane, click on the Comment icon.

2. In the Comment toolbar, click the Filter the displayed comments button

and choose an option from the list:

o To hide all comments, select Hide all Comments. All comments are

invisible both in the document pane and in the Comment panel.

o To show all hidden comments, select Show all Comments to have

all comments visible in the document pane and in the Comment

panel.

o Choose a category from the drop-down menu to filter comments

accordingly. For example, if you only want to see drawing markups

that have been checked, choose Show by Types > Drawing

Markups and then choose Show by Checked > Checked so that

only checked drawing markups appear in the panel and document

pane.

Reply to comments

Reply is especially useful in shared reviews, enabling participants to read each

other's comments. Upon creation, replies appear directly in the pop-up notes

and in the Comment panel. Replies are shown below the original comments.

You can hover the cursor over a comment on the document page to see all

replies under it. However, if you create any sub-reply (replying to an existing

reply), the pop-up notes will only show the number of sub-replies under the

parent reply, meaning you need to open the Comment Panel to see them all.

Sub-replies also cannot be edited directly within the pop-up notes.

Reply in the comment list

1. On the Sidebar Navigation pane, click on the Comment icon.

2. Select a comment in the Comment panel. Right-click on it and select

Reply from the pop-up menu.

3. Type you reply in the box (A) that appears below the comment.
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Reply in the pop-up note

1. Open a PDF and double-click a comment to open its pop-up note.

2. Right-click on the pop-up note and select Reply from the pop-up

menu.

3. Type your reply in the box that appears below the comment.

Replies appear right below the comment, both in the pop-up note (Right) and in the

Comment panel (Left).
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Set a status or check mark

Statuses and checked marks indicate whether the comment has been read and

whether it requires further action. By setting the review status, you can let

other reviewers know how their purposed changes are being implemented.

Once the review status is set, it is always visible in the Comment panel and

cannot be removed from the Comment list even if you change the status to

None. Note that Checked marks are "private"; they are invisible to others

viewing the PDF document unless you change the comment statuses.

Open a PDF and do either of the following to set review status for a comment:

 In the document pane, right-click on a comment and choose Set Status

> Review. Choose an option from the Review menu. For example, if you

choose Set Status > Review > Accepted, the review state, Accepted, will

appear below the comment along with the name of who set the review

status and date.

 In the Comment panel, right-click on the comment and choose Set

Status > Review. Choose an option from the Review menu.

Find a comment

The Search comments tool helps you locate a comment by searching for

specific words or phrases in the Comments panel.

Search for single word or phrase

1. On the Sidebar Navigation pane, click on the Comment icon.

2. In the Comment toolbar, click Search comments and the Search dialog box

appears.

3. In the Search For section, select Single word or phrase. Enter the word or

phrase you want to search for in the What word or phrase would you like

to search for text field and define search criteria by checking Match Case

and/or Match whole word only.

4. Click Search Comments. The results show the comments that match the

search criteria and the word or phrase you search for. The results are
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sorted by page. You can click on the result to go to the comment in the

Comment panel.

Search for multiple words or phrases

1. On the Sidebar Navigation pane, click on the Comment icon.

2. In the Comment toolbar, click Search comments and the Search dialog box

appears.

3. In the Search For section, select Multiple words or phrase and then click

Select Words....

4. In the Words and Phrases to Search dialog box, type the word or phrase to

search for in the New word or phrase text field and then click Add to add it

to the Word and phrase list box below. You can repeat the step to add

more. At the bottom there are checkboxes you can select to refine search

results. Click OK to finish.

5. The results show the comments that match the search criteria and the

words or phrases you search for. You can click on the result to go to the

comment in the Comments panel.

Delete comments

You can delete any comments but those that are protected. To delete all

comments in a PDF, use Inspect Document to remove all comments

permanently.

Delete a comment

Open a PDF in Right PDF and do one of the following:

 In a document, select the comment using either Hand or Select tool and

press Delete on your keyboard or right-click on it and select Delete.

 In the Comments Panel, select the comments you want to delete and click

Delete the selected comment or directly press Delete on your keyboard.

You can also right-click on the comment in the document pane and select

Delete.
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Protect a comment

1. Open a PDF that contains comments or use comment tools to create one.

2. Right-click on the box with the Select tool and select Properties....

3. Select a comment, right-click on it and choose Properties... from the

options. In the Properties dialog box, click the Display tab and check

Protected. Click Close.

4. A lock icon then appears beside the icon of the protected comment in the

Comment panel. To unlock a protected comment, right-click on the

comment and choose Properties... from the options. Uncheck Protected

and click Close.

Spell-check all text in comments

Check Spelling helps you spell-check the text you add in note comments and

form fields.

1. Open a PDF file with comments or text fields.

2. Double-click a comment to show its pop-up note.

3. Right-click on a pop-up note/text field and select Check Spelling from

the options.

4. In the Check Spelling dialog box, click the Start button.

5. The first misspelled word is highlighted and underlined in red. Do any

of the following as needed:

o Click Ignore to skip the mistake.

o In the Suggestions box, choose a suggested correction and click

Change to replace.

o Click Change All to replace every instance in the note box/text field

with the suggested correction.

Migrate comments
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Using Migrate Comments, you can move comments from one file to another.

It is especially useful when you want to compare a revised document to the

original. Considered new to the target file, all migrated comments are

automatically set as Not Confirmed.

To migrate comments

1. Open a PDF file you want comments to be migrated to.

2. On the Sidebar Navigation pane, choose Options > Migrate Comments.

3. In the Migrate Comments dialog box, select the source file with

comments from the From drop-down menu. You can choose to

migrate from a currently open PDF document or select Open a File to

Migrate and choose another file.

4. Click OK.

To set migration status for a comment

1. You can set migration status for a comment.

2. Do either of the following to set migration status:

o Directly select a comment in the document. Right-click on it and

choose Set Status > Migration > None/Confirmed/Not

Confirmed.

o In the Comment panel, select a comment from the Comment list.

Right-click on it and choose Set Status > Migration >

None/Confirmed/Not Confirmed.

Exporting and importing comments

By exporting and importing comments, you can merge comments from

multiple files into a single PDF file for easier review. You can export all

comments from a PDF file and then import them into a different file or

another version of the same document.
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To export comments

You may want to export comments and send them to someone, or need to

import comments you receive. As you export comments, you create a XFDF

file that contains comments. Then you can import those comments from the

XFDF file into the original PDF file.

1. In the Comment panel, click Options and choose Export Comments... from

the options.

2. In the Export Comments dialog box, name the XFDF file (.xfdf), decide a

place to save it, and click Save.

3. You can then import the comments from the XFDF file to another version

of the PDF file.

To import comments

1. In the Comment panel, click Options and choose Import Comments... from

the options.

2. In the Import Comments dialog box, select a XFDF file and click Open.

3. The comment positioning is the same as that of the file they are imported

from. If comments appear to be out of place, the source and recipient PDF

file might be different. For instance, if you import comments from a ten-

page document into a two-page document, only comments from the first

two pages will appear.

Create a comment summary

Create Comment Summary generates a synopsis of all the comments

associated with a PDF. You can choose to directly print the comment summary

or create a PDF version of it.

1. Open a PDF file with comments.

2. On the Sidebar Navigation pane, choose Options > Create Comment

Summary.

3. In the Summarize Comments dialog box, do the following:

o Choose a layout for the document and comments.
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o Choose a page size and font size.

o Specify a comment type.

o Choose how to sort the comments.

o Specify a page range and decide whether to include pages with

no comments.

o Specify whether to include all comments in the summary or just

the comments currently shown in the Comment panel.

4. Click OK. Or, click Print Comment Summary to print.

Page layout options for comment summary

A. Document and comments with connector lines on separate pages

B. Document and comments with connector lines on single page

C. Comments only
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D. Document and comments with sequence numbers on separate pages

Measure Distance, Perimeter, and Area

To use the measure tool

The Measure Tools help you easily figure out the distance, perimeter, and area

of objects in the document, based on the scale you define.

To measure distance

1. Open a PDF file and choose Comment > Distance Tool.

2. Click where you want to begin measuring. You can press Esc on your

keyboard to restart.

3. Move the cursor to the second point and click again to finalize the

measurement. The measured distance is displayed on the PDF file.
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To measure perimeter

1. Open a PDF file and choose Comment > Perimeter Tool.

2. Click anywhere on the page to set a start-point. You can press Esc on

your keyboard to restart.

3. Move the cursor to the next segment of the perimeter and click to set a

midpoint. You can set as many midpoints as needed.

4. Click the first point or double-click the last point to finish measuring.

To measure area

1. Open a PDF file and choose Comment > Area Tool.

2. Click anywhere on the page to set a start-point. You can press Esc on

your keyboard to restart.

3. Move the cursor to the next segment of the area and click to set a

midpoint. You can set as many midpoints as you need.

4. Double-click the last point or right-click the last point and select

Complete Measurement to finish measuring.

To edit properties of the measure tool

The view tab

 The Measurement section lets you know the distance between the

start-point and the end-point and the angle. The perimeter and area

measurement are active only when you are using Perimeter or Area

tool.

 The Cursor Location section shows the X and Y coordinates of your

cursor in relation to the start-point. Your start-point is set as X=0, Y=0.
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The settings tab

 Perpendicular Measurement. Check to set measurement lines always at

right angles.

 Caption Style (Distance tool only). Specify whether the distance

measurement caption is placed Inside or on Top of the measurement

line.

 Units Settings. Set to change the scaling ratio and unit of measurement

on the drawing areas. Enter the scale ratio in the Ratio text field.

 Snap Settings. Check Snap to 2D to have the measurement points snap

to points, edges, or arcs in the document.

o Check Snap to Path to enable snapping the measurement to the

end of a line.

o Check Snap to Path Endpoints to snap the measurement to the

endpoint of a line.

o Change Snap color to decide the color of the square that

appears when you move the pointer to a line.

o Set Sensitivity to define how close the pointer must be to the

items being snapped to.

The markup tab

 Use Markup. It turns measurements into comments. The text you enter

in the Use Markup text field will become note comments in the

Measurement pop-up notes and also in the Comment panel.

 Measuring Color. Set the color of the measurement lines.

 Set Length as Default (Distance Tool only). If selected, you don't have

to manually move the cursor to determine the leader length each time

you make a distance measurement.

 Length (Distance Tool only). It specifies the length of the line leader

that appears on one side of the measurement points.

 Extension (Distance Tool only). It specifies the length of the leader

extension that appears above the measurement line.

 Offset (Distance Tool only). It specifies the amount of blank space that

appears between the measurement points and the leader.
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Chapter 7: Document Assembly

 Manipulating, splitting and renumbering PDF pages

 Page Thumbnails

 Combine all PDF files

 Navigate a PDF using bookmarks

 PDF tags

 PDF layers

 Insert headers and footers, and Bates numbering to PDFs

 Add watermarks to PDFs

 Links in PDFs

 Destinations
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Manipulating, splitting and

renumbering PDF pages

Rotate a page

Manipulating pages in a PDF shares the same permission as editing

document. If it's a protected PDF (identifiable by a lock icon next to the file

name), go to Document Properties under the Security tab, and check the

permissions listed in the Summary of Permitted Actions area. Make sure that

you are allowed to make changes to the PDF document.

Rotate a page

You can rotate all pages, the current page, or selected pages of a PDF

clockwise 90 degrees, counterclockwise 90 degrees, or 180 degrees. The

Rotate tool can be found on the Ribbon toolbar or in the Page Thumbnails

panel.

1. Open a PDF file and do either of the following to use the Rotate tool:

o Choose Document > Rotate.

o On the Sidebar Navigation pane, click the Page thumbnails icon to

open the panel. In the Page Thumbnails toolbar, click Pages Panel

Option and select Rotate....

2. In the Rotate Pages dialog box, follow the steps to set Rotate Pages

properties:

o For rotation angle, select the increment and direction of the

rotations from the Rotate Angle drop-down menu: Clockwise 90

Degrees, Counterclockwise 90 Degrees, or 180 Degrees.

o For Page Range, select to apply rotation on all pages, the current

page, a ranged of pages, or a selection of pages.

o From the Rotate drop-down menu, specify Odd pages, Even pages,

or both. You can also choose Landscape Pages, Portrait Pages or

Pages of Any Orientation as needed.
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Extract pages in a PDF

You can extract a range of pages or selected pages from a PDF file and create

a new document that contains not only the text content but also all form

fields, comments, and links to other files and websites. Depending on what

you need, you can choose to leave the extracted pages in the original

document or remove them during the extraction process. You can also make

extracted pages separate documents.

1. Open the PDF file and choose Document > Extract.

2. In the Extract Pages dialog box, specify the range of pages to extract.

o Check either or both of the following options:

o Delete After Extraction. Remove extracted pages from the original

document after extraction.

o Extract Pages As Separate Files. Create a single-page PDF for each

extracted page. To create a multipage PDF document with all

extracted pages in it, leave this option unchecked.

3. And click OK.

Replace pages

You can replace one or more pages in the document with a selection of pages

from another document. Text, images, links, and comments on the original

pages are all replaced, whereas bookmarks and interactive elements

associated with the original pages are not affected.

1. Open the PDF file that contains the pages you want to replace and

choose Document > Replace.

2. In the Open dialog, select the document containing the replacement

pages and click Open.

3. In the Original section of the Replace Page dialog box, enter the pages

to be replaced in the original document.

4. In the Select Source Pages section, specify the replacement page range.

Click OK.
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A. Enter the pages to be replaced in the original document. B. Specify the

replacement page range.

To delete pages

You can remove a selection of pages from a PDF document. The Delete

command cannot be undone, so make sure you want to delete the selected

pages before clicking OK.

Delete pages using the Delete command

1. Open a PDF file and choose Document > Delete.
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2. In the Delete Pages dialog box, define the page range to be deleted. Click

OK.

Delete pages using the Page Thumbnails

1. On the Sidebar Navigation pane, click the Page Thumbnails icon to

open the Page Thumbnails panel.

2. In the Page Thumbnails panel, select the page or Command-click to

select multiple pages to delete.

3. In the Page Thumbnails toolbar, click the Pages Panel Option button

and select Delete....

4. In the Delete Pages dialog box, the page range is already displayed in

the Selected field. Click OK.

5. Make sure you want to delete the selected pages. Click OK.

Note: you cannot delete all pages because at least one page must

remain in the document.

Duplicate pages

Move or copy a page within a PDF using Page Thumbnails

1. On the Sidebar Navigation pane, click the Page Thumbnails icon to

open the Page Thumbnails panel.

2. Do either of the following:

o On the Sidebar Navigation pane, click the Page Thumbnails icon

to open the Page Thumbnails panel.

 In the Page Range section of the Duplicate pages dialog

box, the page number of the selected page is

automatically entered in the Selected field. You can select

Range to specify the range of pages to copy, or select

Current Page to copy the current page.

 In the Destination section, decide where to place the

copied pages in the document.

 Then specify the number of copies.
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o Click the page thumbnail you want to copy, and Command-drag it

to a new location.

Copy a page between two PDFs using Page Thumbnails

1. Open both PDFs and display them side by side.

2. On the Sidebar Navigation pane, click the Page Thumbnails icon to

open the Page Thumbnails panel for both PDF documents.

3. Directly drag the page thumbnail into the Page Thumbnails panel of

the target document.

4. The page is copied into the document and the pages are renumbered.

Move a page & Swap two pages

Move a page

1. On the Sidebar Navigation pane, click the Page Thumbnails icon to

open the Page Thumbnails panel.

2. Drag the page thumbnail or the page number box of the

corresponding page thumbnail to the new location within the Page

Thumbnails panel. A red bar appears to show the new position.

Swap two pages

The Swap Pages feature swap two pages within a PDF document. You can also

directly drag and drop page thumbnails to reorganize them in the Page

thumbnail panel.

1. Open a PDF document and in the Page Thumbnails panel.

2. Right-click the page to swap and choose Swap Pages....

3. In the Swap Two Pages dialog box, type in the respective page number

in Swap and For.

4. Click OK.



85 / 226

Note: this feature does not work when the PDF document consists of

only one page.

Splitting a PDF into multiple files

Using Split Document, you can break one or more multipage documents into

a set of smaller ones according to the criteria you define. After splitting, the

source PDF remains unchanged in all cases.

1. Open a multipage PDF file you want to break into different parts.

2. Choose Document > Split and the Split Document dialog box appears.

o Under Source Document, specify a multipage document you

want to split:

o Split pages

 Split by file size: ___MB. It splits your PDF document into

parts with no more than a specified file size. The value

limit should be between 0.50 and 50 MB.

 Split by parity of pages. Split the source document by

odd and even pages. The two output files will be named

Odd segment of [source document name] and Even

segment of [source document name].

 Split by blank page. Splitting creates a new document

whenever a blank page is encountered. Every range of

pages between blank pages will be saved into an

individual PDF document.

 Split by pages: ___ pages as a document. Define how

many pages each resulting document contains. Each

output file contains an equal number of pages, except for

the last file that may contain fewer pages. For example, if

you enter 2 for a 5-page document, it will be split into 3

files with the first 2 file containing 2 pages and the last

file containing only 1 page.

 Split by pages containing text. Any page containing the

text (case sensitive) you specify will become the

beginning of a new PDF document. In other words, a new
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file begins whenever the next occurrence of the entered

text string is found. The first segment always starts with

Page 1 even if it does not contain any specified text or

word string. Comments and signatures are not checked

for text match.

 Split by pages. The document is split based on the page

numbers you specify (e.g. 2; 4; 6). The first segment

always starts with Page 1. For example, in the case of

splitting a 6-page PDF document, entering 2 and 4 will

split the document into three parts with the first segment

starting with Page 1, the second segment starting with

Page 2, and the last segment starting with Page 4. You

are warned if you enter invalid page numbers.

 Split by bookmark. Split the source document at the page

where the bookmark you specify is found. The first

segment always starts with Page 1.

 Split by bookmark level. Split the source document at the

page where the specified bookmark level is found. The

bookmark splitting is available only when the document

contains bookmarks.

 Extract by pages or page ranges. The parts of the

document are extracted based on user-defined pages or

ranges that cannot overlap. The output files will be

named "Segment 001 of [source document name]",

"Segment 002 of [source document name]", etc. The

warning message is given if the pages and ranges you

enter overlap.

 Extract pages containing text. Only the pages containing

the word or text string you specify (case sensitive) will be

extracted. Comments and signatures are not checked for

text match. The extracted pages are saved in a single file

named by the entered text pattern.

 Extract by bookmark. All pages associated with a certain

bookmark name will be extracted. This is case-sensitive.

The output files will be as follows, e.g. "[bookmark

name]_001", "[bookmark name]_002", etc.
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 Extract by bookmark level. All bookmark sections under

the specified bookmark level will be extracted into a PDF

document and named using the bookmark title. The

resulting files are placed in automatically created folders

that mirror the bookmark hierarchy. A generated HTML

index file provides you with links of the extracted pages

for easy file navigation. For example, you enter 2 to

extract sections organized under second-level bookmarks.

If there are two second-level bookmarks in the source

document, two subfolders will be created and contain the

files associated with the second-level bookmarks. The

main folder is named by the original file.

o Numbering options

The numbering options allow you to control how the output files

will be named. You can specify the numbering of the resulting

segments as needed. For example, if you would like to split a 6-

page document into a number equal to a multiple of 2, you

enter 2 in the [__ pages as a document] field. The source

document will be split into three output files with 2 pages per

file. Then click the Numbering Options button. In the Numbering

Options dialog box, define how the resulting documents will be

named and then click OK. For example, if you enter 1 in the Start

Number field and enter 2 in the Increment of Numbering field,

the resulting PDF files will be named "Segment 001 of [source

document name]", Segment 003 of [source document name],

and "Segment 005 of [source document name]".

3. Click OK.

4. Click Output Options for selecting a folder for the split result files and

filename preferences. Specify the options as needed, and then click OK.

Renumber pages

The page numbers on the document pages do not always match the page

numbers that appear below page thumbnails and in the Page viewing controls
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bar because some PDFs may contain preliminaries, e.g. a copyright page or

table of contents that may not comply with the numbering.

Using Number Pages command, you can number the pages in the document

in a variety of ways. You can specify a numbering style for a range of pages, or

customize the numbering by adding a prefix and a starting number. For

example, if you have two pages of table of contents in front and need to set

the third page as Page 1, select the first two pages, specify a numbering style,

such as i, ii, iii, and then set 1 as the starting number. As a result, you can see

the numbering of the document displaying i, ii, 1, 2, 3, and so on in the Page

Thumbnails panel.

1. Open a PDF file and do either of the following to open the Page

Thumbnails panel:

o Choose Document > Page Thumbnails.

o On the Sidebar Navigation pane, click on the Page Thumbnails icon

to open it.

2. On the Page Thumbnails toolbar, click Pages Panel Option and select

Number Pages....

3. In the Page Numbering dialog box,

o Under Pages, select All or specify a page range. The Selected refers

to the page thumbnails selected in the Page Thumbnails panel.

o Under Numbering, select one of the following and click OK. (1)

Begin new section. It starts a new sequence. Select a numbering

style from the Style drop-down menu. Then, define the starting

number of the section and enter a prefix as needed. (2) Extend

numbering used in preceding section to selected pages. It

continues the page numbering sequence from previous pages.

4. Click OK.
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Logical page numbering (Left) The first two pages renumbered. (Right)

Note: the Number Page command affects only the logical page numbering

shown in the Page Thumbnails panel and in the Page viewing controls bar.

The page numbers shown on the document pages remain intact.

Crop pages

If the PDF document consists of pages of different sizes, you can use the Crop

tool and the Crop Pages dialog box to keep the PDF consistent. You can

adjust the visible page area by hiding the area outside your selection. As

mentioned earlier, cropping page is simply hiding the information, not

removing it, and therefore the file size will not be affected.

1. Open a PDF file and choose Document > Crop.

2. Drag a rectangle on the page to crop. To adjust size, drag the corner

handles of the cropping rectangle.

3. Double-click inside the crop area to enter the Crop Pages dialog box or

right-click on the page thumbnail and select Crop....

4. In the Crop Pages dialog box, you can drag the blue frame to adjust

your selection and do the following:
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o In the Margin Controls section, view the margin measurements of

the cropping rectangle. You may make selections by editing the

values in the fields.

o Check Remove White Margins to crop the page to the boundary. It

may be useful when you need to trim presentation slides saved as

PDF.

o Click Set To Zero to restore the crop margins to zero.

o Click Revert To Selection to revert to the crop area selected with

the Crop tool.

o In the Page Range section, specify the pages to be cropped.

5. Click OK.

Crop a page with the Crop tool

Insert pages
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Insert lets you add blank pages, clipboard content, scanned content, or pages

from other PDFs into the current document. You can specify the range of

pages to insert and an insert location.

Insert pages from a file into a PDF

1. Open a PDF file and choose Document > Insert.

2. Select Insert from File from the list of insert options and choose a file in

the Open dialog. Click Open.

3. In the Insert Pages dialog box, do the following:

o Source Files. Files listed in the box will be inserted at the

specified location in the current document. You can click Add to

select more source files.

o Select Source Pages. Choose all pages or specify a range of

pages to insert.

o Location. Choose to insert the selected source pages Before or

After the specified location of the current document.

o Page. You can choose to place the inserted pages Before or

After (depending on the Location) the First Page, Last Page,

Current Page, or specified pages of the current document. See

the following examples:

 If you select After and First Page, the selected source

pages will be placed after the first page, with the first

page of the selected source pages set as page 2 in the

current document.

 If you select Before and Last Page, the selected source

pages will be placed before the last page, with the last

page of the selected source pages set as the second-last

page of the current document.

 If you select After and Current Page, the selected source

pages will be placed after the current page.

 If you select Before and Page Number X, the selected

source pages will be placed before Page X.

4. Click OK.
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Insert blank pages into a PDF

1. Open a PDF file and choose Document > Insert.

2. Select Insert Blank Page from the list of insert options.

3. In the New Pages dialog box, define the number of blank pages to

insert and specify where the blank pages are placed as needed.

4. Click OK.

Insert clipboard content into a PDF

1. Open a PDF file and choose Document > Insert.

2. Select Insert from Clipboard from the list of insert options. Note that

you can insert content copied from any application.

3. In the Insert Pages from Clipboard dialog box, specify where the

inserted clipboard content is placed.

4. Click OK.

Note: you will not be able to use this option given insufficient amount

of data in Clipboard.

Insert scanned content into a PDF

1. Open a PDF file and choose Document > Insert.

2. Select Insert from Scanner from the list of insert options. Choose either

Quick Scan or Custom Scan.

3. In the Custom Scan / Quick Scan dialog box, select a scanner and edit

Document settings. You can run OCR to make scanned pages

searchable.

4. Click Scan.

5. The scanned content is inserted after the last page by default.
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Page Thumbnails

Page Thumbnails basics

Page thumbnails act as miniature previews of the pages in a PDF document.

With Page Thumbnails, you can get an overview of the document and

navigate through pages with ease. Everything you do to the page thumbnails

is applied to their corresponding pages, such as moving, rotating, or deleting.

The red frame in a thumbnail indicates the area currently displayed in the

Document Pane. You may move the red frame to change the area to be

viewed or drag it to adjust its magnification.

To view page thumbnails

Open a PDF file and do either of the following to open the Page Thumbnails

panel:

 Choose Document > Page Thumbnails.

 On the Sidebar Navigation pane, click the Page Thumbnails icon.

To zoom in thumbnails

 In the Page Thumbnails toolbar, click Pages Panel Option and select

Enlarge Page Thumbnails.

 In the Page Thumbnails toolbar, click Enlarge Page Thumbnails.

To zoom out page thumbnails

 In the Page Thumbnails toolbar, click Pages Panel Option and select

Reduce Page Thumbnails.

 In the Page Thumbnails toolbar, click Reduce Page Thumbnails.
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Reduce Page Thumbnails. (Left) Enlarge Page Thumbnails. (Right)

Define the tabbing order

You can set the order in which a user tabs through form fields, links and

comments for each page.

1. Set the tabbing order using a preset option

o On the Sidebar Navigation pane, click the Page Thumbnails icon.

o Choose Document > Page Thumbnails.

2. Do any of the following to open the Page Properties dialog box:

o Select a page thumbnail, right-click on it, and select Page

Properties... from the options.

o In the Page Thumbnails toolbar, click Pages Panel Option and select

Page Properties... from the options.

In the Page Properties dialog box, click Tab Order and do the following to set

the tabbing order:
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Set the tabbing order

 Use Row Order. Press the tab key to move through each row down the

page horizontally.

 Use Column Order. Press the tab key to vertically move down each

column across the page.

 Use Document Structure. Tab in the order specified by the application

the document was created in.

 Unspecified. Tab by rows, first through form fields, then through links

and lastly through comments.

o In the Page Properties dialog box, click Tab Order and select

Unspecified from the tab order options. Click Close.

o Choose Form > Set Tab Order Tool. Click OK.

o A number appears in the upper-left corner of each form field,

indicating the tabbing order you set. Click the form fields in the

desired order.

o Click anywhere on the page other than the form fields to finish.

Set tab order. The tabbing moves in the order you created the form fields.
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To define page actions

 Select Trigger. Define how to initiate a page action. From the Select

Trigger drop-down menu, choose Page Open to set an action when the

page is opened, or choose Page Close to set an action when the page

is closed.

 Select Action. Specify the action the page performs when triggered and

click Add...:

 Do Action. It displays the list of triggers and actions you defined for the

page. To perform multiple actions, select another action from the menu

and click Add... to add it to the list.

o Click Delete to remove the selected action from the Do Action list.

o Click Edit to change settings for the selected action.

o Use Up/Down buttons to arrange the actions in the order you want

them to occur. The buttons are available only when there are

multiple actions under the same trigger.

Combine all PDF files

The Combine All feature lets you combine all open files in all Right PDF

windows, not just those in the current window. It creates a Binder file that

includes all open files (including other Binder files) in the window in which you

use the Combine All feature.

1. In Right PDF, select Advanced > Combine All. If there are digital

signatures in the open files, you'll see a message stating digital

signatures will not be retained in the result document. Click OK.

2. In the Combine Files dialog box, all open files are listed and you can

use the Add, Delete, Up, Down and Clear buttons to modify the queue.

Check Add file names as Bookmarks if you would like to have

bookmarks automatically added to the result file and named after each

source file.

3. A Binder file is created and opened as a tab in the window where you

ran the Combine All feature. Even if the Open document as new tabs in
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the same window setting in Preferences is turned off, Binder files will be

opened in a new window.

4. In the Bookmarks panel of the result binder file, all source files are

added as bookmarks, including those nested under other binder files.

For example, given Binder 2* contains multiple files (including Binder

1*), all files including those under Binder 1* will be listed as bookmarks

as shown below.

A. Created binder files appear as tabs in the Right PDF window where the Combine

All feature was used. B. Files within a binder file are also listed as bookmarks in

the Bookmarks panel.

Note: digital signatures in the files to be combined will not retain in the

resulting Binder file. This doesn't affect those in the original files.

Navigate a PDF using bookmarks

Add a new bookmark

Bookmarks are a group of links enabling you to browse PDF document easily

and accurately, especially when you are reading a collection of documents. To

create bookmarks, you can directly select a title or short text and convert it

into a bookmark that is viewable in the Bookmarks panel. You can also convert

specified Word heading or styles from a Word file to bookmarks in the

resulting PDF document with a hierarchy of levels you set. You can let a

bookmark lead you to a specified destination, for example a page view. Also,
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by simply dragging bookmarks underneath another bookmark, you can create

a bookmark hierarchy which serves to show a relationship between topics.

Add a new bookmark

1. Open a PDF file and do either of the following to open the Bookmarks

panel:

o Choose Document > Bookmarks.

o On the Sidebar Navigation pane, click the Bookmarks icon.

2. Go to the page where you want the bookmark to link to and adjust the

view settings.

o In the Bookmarks toolbar, click the New Bookmark button and

name the new bookmark. The current view is set as its

destination.

o Open the Bookmarks panel and use the Select tool to highlight

the text to use as the name of the bookmark and do either of

the following: Click the New Bookmark button in the Bookmarks

panel. Or right-click on the selected text and select Add

Bookmark from the menu.

The selected text (A) will turn into bookmark (B)

Edit a bookmark
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Rename a bookmark label

1. Open a PDF file that contains bookmarks or create bookmarks by

yourself.

2. In the Bookmarks panel, select a bookmark and do either of the

following:

o Right-click on it and select Rename Bookmark from the options.

Then type the new bookmark name.

o Double-click on it and type the new bookmark name.

o Click on Bookmarks Panel Option and select Rename Bookmark.

Then type in the new bookmark name.

Customize bookmark appearances and behavior

 Change the text appearance

You can change the appearance of one or more selected bookmarks to

draw extra attention to them.

1. Open the Bookmarks panel and select one or more bookmarks.

To select multiple bookmarks, click on one and Command-click

to select more.

2. Right-click on any of the selected bookmarks and select

Properties....

3. In the Attributes tab of the Bookmark Properties dialog box:

 Style. Select a text style as desired from the drop-down

menu.

 Color. Click the colored square and choose a preset color

or define a custom color.

4. Click Close.

 Add an action to a bookmark

Bookmarks can be set to perform one or more actions in the order you

specify.

1. Open the Bookmarks panel and select one or more bookmarks.

2. Right-click on the selected bookmarks and select Properties....
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3. In the Actions tab of the Bookmark Properties dialog box, you

can see the default action is to go to a defined page in the

document. Select one action from the Select Action drop-down

menu and click Add...

4. Use the Up and Down buttons to set up the action order.

5. Click Close.

 Add the same actions to multiple bookmarks

1. Open the Bookmarks panel and Command-click to select

multiple bookmarks.

2. Right-click on the selected bookmarks and select Properties....

3. In the Bookmark Properties dialog box, assign an action by

selecting one from the Select Action drop-down menu and click

Add to add it to the Do Actions list. If you see Varies (A) in the

Do Actions list, delete it (B) to proceed.
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Set where a bookmark points to

When you create a new bookmark, the current view is set as the destination

the bookmark points to. You can set a new destination for a bookmark.

1. In the Bookmarks panel, select a bookmark.

2. Move to the target location in the current PDF document and change

the page zoom if necessary. When finished, click the Set Destination

button at the top of the Bookmarks panel.

3. When prompted, click OK to set the new destination of the selected

bookmark to the current location.

Delete a bookmark

In the Bookmarks panel, select one or more bookmarks and do any of the

following to delete:

 Right-click on a selection of bookmarks and select Delete Bookmark(s)

from the options.

 Press the Delete key on your key board.

 Click the Delete Bookmark button.

Note: if a bookmark is deleted within multi-level structure, you also

delete any bookmarks that are subordinate to it. However, text in the

document is not affected.

Build a bookmark hierarchy

To nest bookmarks

Do either of the following to nest bookmarks:

 In the Bookmarks panel, select one or more bookmarks and click-drag it

beneath the parent bookmark. A dotted line appears while you are

dragging the bookmark, indicating where the bookmark will be placed.
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 Right-click on a bookmark and select Add a Sub-bookmark. Then type a

name and set its destination.

To move bookmarks out of a nested position

Select the bookmark or range of bookmarks and do one of the following:

 Drag the selected bookmarks directly underneath the parent bookmark.

 Right-click on the selected bookmarks and select Cut from the options

menu. Then, right-click on the parent bookmark and select Paste after

the Selected Bookmark from the options menu.

PDF tags

PDF Tags provide information regarding the content of a document, such as

the type of text, object, and their reading order. This is helpful when

disadvantaged readers require assistive software to interpret and present a

document to them in a logical fashion. Without tags, the software may be

forced to guess the correct order and could lead to unpredictable results.

Additionally, pictures or other visual aids require tagging as well, so they can

be described in audio form.

The Tag panel allows you to view and edit tags in the logical structure tree.

The tags in the Tag panel are displayed in a hierarchical order which indicates

the reading sequence of the document. The very first item in the panel is

always the Tags root, and all other items are its children. Note that changes

made to tag tabs cannot be undone by the undo command, so please make

sure that you save a backup copy of the document before editing tags.

Add a new tag

1. To open the Tag panel, choose Document > Tag, or on the sidebar

navigation pane, click the Tag panel icon.
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2. Select a tag which you want to add a tag to, and either right-click on it

or click PDF Tags Options and choose New Tag....

3. In the New Tag dialog box, select a type from the Type drop-down

menu and enter a Title. Click OK.

4. The new tag becomes a child of the selected tag.

Create a new tag from selection

In the Tag panel, decide where you would like to place the new tag, and then

select the text with the Select tool. Click PDF Tags Options and choose Create

Tag from Selection.

Edit tags with the Tag panel

You can edit a tag title, change a tag location, or change the tag type.

To change a tag type

Select the tag and choose Properties... from the PDF Tags Options menu,

or right-click the tag and choose Properties.... Select a new type from the

menu and click Close.

To edit a tag title

Select the tag and choose Properties... from the PDF Tags Options menu,

or right-click the tag and choose Properties.... Enter text in the Title box

and click Close.

To move a tag

In the Tag panel, expand the Tags root to view all tags. Select the tag

icon of the element you want to move and do one of the following:

 Directly drag the tag to the location you want. As you drag, a line

appears at viable locations.

 Choose Cut from the PDF Tags Options menu, and select the tag

that appears above the location where you want to paste the cut
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tag. Then from the PDF Tags Options menu, choose Paste to

move the tag to the same level as the selected tag.

PDF layers

Import layers

Layers let you separate different elements of a PDF page, which can be

especially useful when you are working with architectural plans that involve

layers of elements. In Right PDF, not only can you control the display of layer

using the default and initial state settings, but also rename, merge and flatten

layers, and change the properties of layers.

Import layers

You can import layers from a PDF or image file into another PDF. Right PDF

supports image files in the following formats: BMP, GIF, SHP, JPEG, JPEG 2000,

PCX, PNG, and TIFF.

1. Open a PDF file and choose Document > Layers.

2. In the Layers panel, click the Options Help button and select Import as

Layer... from the options.

3. In the Import as Layer dialog box, click Browse and locate a file to

import. If the source file is a multipage document, use the up and down

arrows or enter the value to set the page number you want to import in

Page Number.

4. In the Import Options section, select one of the following import

options:

o Create new layer. Create a single, separate layer from the source

file. Click and enter a name for the new layer.

o Add to group. Add the imported layer to the existing layer

group. Click the drop-down arrow and specify a layer group. This
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option is available only when there are one or more existing

layer groups in the target PDF document and when the Create

new layer option is selected.

o Add to existing layer. Specify an existing layer to add the content

from the source document. The imported content will have the

same layer properties as the layer in the target document. This

option is available only when the target document already

contains layers.

o Copy layers from source. Import layers from the source

document to the target PDF document. This option is available

only when there are layers in the source document.

5. In the Position section, adjust the scale, position, and rotation settings

as needed.

6. In the Appearance section, set a transparency level for the new layer,

and whether it is placed in front of the page or behind it.

7. In the Preview section, specify the Target page number if the target file

is a multipage document.

8. Click OK.

Note: once placed, layers cannot be deleted or replaced, so please

double check before you proceed.

Show or hide layers

You can show or hide the content associated with each layer in the Layers

panel. Some layers may be organized into nested groups with a parent layer.

The lock icon to the right of each layer name acts like a switch which lets you

lock or unlock the layer, but you are not allowed to change the visibility of

locked layers. On the other hand, the eye icon next to each layer name

indicates the visibility of the layer. The layer is visible if the eye icon is present

and hidden if absent.

Note: you are not allowed to change the visibility of locked layers.
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A. An eye icon indicating a displayed layer B. Locked layer C. Hidden layer

1. Open a PDF file and choose Document > Layers.

2. To hide or show a layer:

o To hide a displayed layer, click the eye icon next to left of the

layer name.

o To show a hidden layer, click the empty box to restore visibility.

3. Click the Options Help button and select one of the following from the

options menu:

o List Layers for All Pages. Display every layer across all pages of

the document.

o List Layers for Visible Page. Show layers on the currently visible

pages only.

o Reset to Initial Visibility. Reset layers to their default state as

defined in the Default state in the Layer Properties dialog box.

o Apply Print Overrides. Display layers according to the Print

settings in the Layer Properties dialog box (print if visible, never,

or always).

o Apply Export Overrides. Display layers according to the Export

settings in the Layer Properties dialog box (export if visible,

never, or always).

o Apply Layer Overrides. Make all layers visible, even layers not

listed in the Layers panel or layers grouped under their parent

layers. You cannot change layer visibility using the eye icon until
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this command is deselected. To make changed layer properties

take effect, you can choose Reset to Initial Visibility in the

options menu, or save the file and reopen it. See Edit layer

properties for details.

o Select Expand All or Collapse All to expand or reduce the layer-

tree.

Edit layer properties

The Layer Properties allow you to rename a layer or adjust various settings,

such as default state, visibility, print and export initial state.

1. In the Layers panel, do one of the following to open the Layer

Properties dialog box:

o Select a layer and click the Show property icon to the right of

the layer.

o Click the Options Help button and select Layer Properties... from

the options.

2. In the Layer Properties dialog box, edit the name of the layer or any of

the following properties and then click OK.

o Intent. Select View to allow changing layer visibility state, which

means you can click the eye icon to turn it on or off. If Reference

is selected, however, the layer stays visible at all times and you

are not allowed to change the layer properties, except for the

layer name.

o Default state. This option lets you define the initial visibility state

of the layer when the document is first opened or when the

Reset to Initial Visibility command is used. Select On or Off to

make the layer visible or invisible when the document is first

opened, or when the initial visibility is reset.

o Initial State: under this you can set Visible, Print and Export

options.

o Visible lets you define the on-screen visibility of the selected

layer. If you select If on, the default state determines whether

this layer is shown or hidden when the document is opened. If
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you select Never, the layer is hidden when the document is

opened. If you select Always, the layer is shown when the

document is opened.

o Print lets you define under which condition a layer will print.

o Export lets you decide if the layer appears in the resulting

document when the PDF document is exported to an application

or file format that supports layers.

Merge or flatten layers

Using Merge Layers, you can combine layers with t layers. The merged layers

acquire the properties of the layer into which they are merged. Meanwhile,

Flatten Layers lets you merge all layers into the document, hiding any content

that is invisible.

Note that you cannot undo either action upon completion.

1. Open a PDF file that contains layers and choose Document > Layers.

2. In the Layers panel, click on the Options Help button and select Merge

Layers... or Flatten Layers.

o Merge Layers. In the Layers to be merged box to the left, select

one or more layers to be merged. In the Target layer to merge

into box to the right, select the target layer into which the

selected layers will be merged. Click OK. The selected layers are

combined with the target layer and can no longer be present in

the Layers panel.

o Flatten layers. In the box that pops up, click OK to proceed the

operation.
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Using the Merge Layers dialog box (Left) The fifth layer is merged into the fourth

layer (Right)

The visibility state of the second layer is off. (Left) All layers are merged into the

document and the invisible content is hidden. (Right)

Insert headers and footers, and Bates

numbering to PDFs

Insert headers and footers, and Bates numbering to

PDFs

Right PDF lets you add headers and footers throughout a PDF document,

which can be textual information such as date and time, author, title, page
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number, Bates numbers and more, appearing along the top or bottom across

all PDF pages or a range of pages in one or more PDF documents.

The Bates number appears as a header or footer on specified pages and can

be combined with other header or footer texts. Using the Bates numbering

tool, you can identify each page in a set of documents by assigning a series of

unique, self-incrementing numbers.

Add Headers and Footers to a file or multiple files

Add Headers and Footers to a file or multiple files

1. Open a PDF file and choose Document > Header and Footer . Select

Add... from the drop-down menu.

2. In the Add Header and Footer dialog box:

o Set up the Font and Margin for the header and footer. The font

and margin properties apply to all header and footer entries,

meaning you are not allowed to apply a different setting to

individual header or footer.

o To prevent overlapping, click Appearance Options... and check

the Shrink document to avoid overwriting the document's text

and graphics option.

o To add textual information, do any of the following:

 Type text in any of the six boxes.

 Select a predefined item from the Macros drop-down

menu, click on any of the six boxes in which you want to

place the macro, and click Insert Macro.

 Click Page Range Options...to specify pages on which the

header and footer appear.

 In the Preview section, examine the results and use

Preview Page to view different pages of the PDF

document.
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A. The header appears in the top margin of the page. B. The footer appears in the

bottom margin of the page. C. Click the Page Range Options... to decide the

pages to display header and footer.

3. To apply the settings to multiple documents, click the Apply to Multiple

button. In the Add Header and Footer dialog box, click the Add Files...

button to select the files. Click Open. Click OK.

Note: if the file you are processing already contains headers or footers,

you are prompted to determine whether to replace the existing ones

with the one you are adding. Or, you can choose to add new headers or

footers. See Add extra headers and footers.

Remove all headers and footers

1. Open a PDF file that contains headers and footers.
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2. Choose Document > Header and Footer. Select Remove... from the

drop-down menu.

3. Click OK.

Add a Bates numbering to header or footer

Bates numbering is a way of indexing legal document for you to better

identify each page in a set of documents. Each page is assigned a unique

Bates number (normally starting from 000001 by default) that indicates its

relationship to other Bates-numbered documents, based on the order in

which the files are listed in the Bates Numbering dialog box. You are free to

change the order in which the Bates numbers are assigned using the Move

Up/Down buttons or by sorting the list.

Bates numbers are similar to headers or footers on the pages of each PDF

document in the batch. You can also include a prefix and/or a suffix as

supplementary information.

Add Bates numbering

1. Open a PDF and choose Document > Bates Numbering. Select Add...

from the drop-down menu.

2. In the Bates Numbering dialog box, click Add Files.../Add Folders and

locate the files or folders on which bates numbers will appear. If any

files are password-protected, there will be one or more messages

popping up where you have to enter the correct password to proceed

the operation.
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Files added to be Bates numbered in batch

3. As needed, do the following to change the order in which Bates

numbers are assigned:

o Move Up. Select a file and click the Move up button to move it

upward.

o Move Down. Select a file and click Move down to move it

downward.

o Remove. Select a file and click the Remove button.

o Preview. Click to preview the selected files in a pop-up Preview

dialog box.

4. Click Output Options to specify a target folder and a file naming

method for output files. Specify the options as needed and click OK.

5. Once the files are all set, click OK. Then the Add Header and Footer

dialog box appears. Click inside the box to place an insertion point.
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6. To edit text to display as Bates numbers, click the Settings... button and

do any of the following in the Bates Numbering Options dialog box.

Then click OK to go back to the Add Header and Footer dialog box:

o Click Number of Digits and specify how many digits make up the

Bates number, ranging from 1 through 15. The default digit is 6,

which forms Bates number such as 000001, 000002, and so on.

o Click Start Number and enter the number to appear on the first

PDF in a batch. The default number is 1, meaning the Bates

number on the first page of the first PDF will be 000001.

o Click Prefix and type any text to appear before the Bates

number.

o Click Suffix and type any text to appear after the Bates number.

7. Click on Insert Macro.

8. Adjust header and footer settings and check how the Bates numbers

will appear on pages in the Preview section below.

9. Click OK.

Note: Bates numbering is against documents that are secured or

contain digital signatures.

Remove Bates numbering

1. Open a PDF file that contains Bates numbers.

2. Choose Document > Bates Numbering. Select Remove... from the

drop-down menu.

3. Click OK.

Add watermarks to PDFs

The Watermarks tool lets you insert predefined or custom watermarks to all

pages or a selection of pages in the PDF document. Watermarks can be text

(e.g. page number, date and time, or information), an image (e.g. company

logo), or a composite (a combination of existing watermarks). You can also
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apply a page of an existing PDF document as a watermark to a PDF document.

The watermarks you create can be saved and reused. Not only can you import

and export watermarks to share them with others, but also specify whether

you want to place the watermark in the background of the PDF, underneath

the other page content, or on the top of the page content.

To add a new watermark into Watermark panel

1. Open a PDF file and do either of the following to open the Watermarks

panel:

o Choose Document > Watermarks.

o On the Sidebar Navigation pane, click the Watermarks icon.

2. To create a watermark, do any of the following:

o Click the Create... button at the top of the Watermarks panel.

o Click the Options button at the top of the Watermarks panel and

select New from the options.

o Right-click anywhere in the panel and select New from the

options.

3. In the Create Watermark dialog box, click the Title field and name the

watermark.

4. Select a type of watermark from the Type drop-down menu:

o Text. Type the watermark text and/or select preset items from

the Macros menu. Click the add button to the left of each

item to insert into the Text field. Adjust the text formatting

options as needed, such as font, size, angle and style.

o Image. A watermark can be an image or a specified page of a

PDF file. Click Browse... to locate an image or a PDF file. When a

multipage PDF file is chosen, specify one page to be used. Fix or

release the aspect ratio. Select Cover whole page to cover the

whole page with the image. If deselected, you can define the

size and the location for the image.

o Composite. You can build a new watermark using the existing

ones. Select the desired ones and click Add to place them in the

box. Click OK.
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5. Check Cross-pages watermark to make the watermark appear split

across 2 pages or the edges of all pages.

6. Click OK.

Cross-pages watermark deselected (Left). Cross-pages watermark selected: the

watermark appears split across two consecutive pages. (Right)

Edit a watermark

1. Open the Watermarks panel and do either of the following:

o Right-click on a watermark and select Edit from the options.

o Select a watermark you want to make changes to, click on the

Options button and select Edit from the options.

2. In the Edit Watermark dialog box, make changes to settings as needed

and Click OK.

Insert a watermark into a PDF document

1. In the Watermarks panel, do either of the following:

o Select a watermark from the list of watermarks. Right-click on it

and select Apply or click on Options and select Apply.

o Double-click the watermark.

o Directly drag the selected watermark to the document pane.

2. In the Apply Watermark dialog box, specify the pages on which the

watermark displays. Select Specify Page Range and enter a page range

in the field below. Then choose a Subset option from its drop-down

menu.
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Watermark settings and a preview of the result document with watermark added

3. In the Appearance section, adjust the opacity of the watermark and

select the following as needed:

o Check As background to place the watermark in the background

of the PDF file underneath other page content. If deselected, the

watermark is placed at the top of the page content.

o To specify when the watermark displays: check Show when

printing and Show on screen display.

4. Click OK.

Import or export a watermark

To export watermarks

1. Click the Options button and select Import from the options menu.

2. Locate a GWM watermark file and click Open.
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To export watermarks

1. Do either or the following to open the Watermarks panel:

o Choose Document > Watermarks.

o On the Sidebar Navigation pane, click the Watermarks icon.

2. Click the Options button and select Export from the options menu.

3. Select a path to save the exported watermarks as a single PDF file. Click

OK. All watermarks are exported and saved as a GWM file.

Remove all watermarks from a document

You can permanently remove all watermarks in the document.

1. Open a PDF file containing watermarks.

2. Choose Document > Remove Watermark.

3. Click OK.

Use the Remove Watermark feature to permanently remove all watermarks in the

document.

Links in PDFs

Create a link

Links take you to another location in the same document, another document,

or a website.
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Create a link

To add a link to a PDF document

1. Open a PDF file on which you want to create a link and choose

Document > Link.

2. Click and drag a rectangle to create a link.

3. In the Create Link dialog box, set the desired link appearance.

4. Select an action in the Action section:

o If you select Go to a page view, the link will lead you to a specific

page view within the same document or in another document

(such as a file attachment). (1) Click Next and the Create Go to

View dialog box appears, informing you to use the navigation

tools to set the view for the link. (2) Go to a page and set a

desired viewing magnification in the current document or in

another document. (3) Click Set Link to create the link

destination.

o If you select Open a file, clicking the link will open a specified

file. Click Next and locate a file to link to. Click Open.

o If you select Open a web link, it takes you to a specified URL.

Click Next and then enter a URL in the field. Click OK.

o Select Custom link and click Next to open the Link Properties

dialog box. The Actions tab offers you a list of available actions

you can set for the link, such as executing a menu item.

5. Optionally, you can adjust the position and size of it as you would

expect:

o To move the link rectangle, click-drag it with the Select tool or

Link tool.

o To resize the link rectangle, click-drag any corner or side point

with the Select tool or Link tool.

6. To test a link

o On the Sidebar Navigation pane, click the Hand tool or choose

Basic > Hand.

o Using the Hand tool, click on the link to see if the link can

perform the specified action.
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Edit a link

You can not only change link appearance and set the default link style for re-

use, but also specify its associated actions, reposition the link rectangle, or

edit the destination of the link.

To edit the appearance of links

1. Do either of the following to call out the Link Properties dialog box:

o Double-click on the link with the Select tool or Link tool.

o Right-click on the link using either the Select tool or Link tool

and select Properties... from the options menu.

2. In the Appearance tab, adjust the settings as needed.

o Appearance

a. Link Type:

 Choose Visible Rectangle to let users see the link in

the PDF.

 Choose Invisible Rectangle if you do not want

users to see the link in the PDF. It is especially

useful if the link is placed over an image.

b. Highlight Style determines what the link should do when

you click on it:

 Choose Invert to change the link's color to its

opposite.

 Choose Outline to change the link's outline color

to it opposite.

 Choose Inset to display an embossed rectangle.

c. Line Style: Choose the style of the link frame to be Solid,

Dashed or Underline.

d. Line Thickness: Set the thickness of the link frame to be

Thin, Medium or Thick.

e. Color: Choose a color for the link frame.

f. Check the Protected box if you want to prevent users

from accidentally changing your link settings.
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o To edit a link action

In the Actions tab, select the listed action you want to change

and click the Edit button.

To set the default link appearance

1. Set a desired link appearance.

2. Right-click on the link that uses the link appearance you want to set as

default and select Set as Default Properties. The current style of the link

will be set as default.

To align, resize, and reposition links

 To align links

1. Hold down Command and click on each link you want to

reposition using either the Link tool or Select tool.

2. Right-click on the link to which you want to align the other links.

If you select right, all the selected links will be aligned to the

right edge of the anchor link.

 To center a link

Right-click on the link and select Center. Then choose any of the

following:

1. Click Vertically to center the link between the top and bottom

margins.

2. Click Horizontally to center the link between the left and right

margins.

3. Click Both to place the link at the center of the page.

 To distribute links evenly

You can give a group of links the same spacing, measured from the

centers of adjacent links.
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1. You must select at least three links. Command-click to select

multiple links.

2. Right-click on any link in the selection and select Distribute:

 Click Vertically to evenly distribute links vertically.

 Click Horizontally to evenly distribute links horizontally.

 To resize links

The Width and Height of all selected links will be identical to the

anchor link.

1. Hold down Command and click on each link you want to resize.

2. Right-click on the anchor link and select Resize.

 Click Width to set the width identical to the width of the

anchor link.

 Click Height to set the height identical to the height of

the anchor link.

 Click Both to set both the width and height identical to

the anchor link.

Note: 1. To use Align and Size, you need to select at least two links. 2. To use

Distribute, you need to select at least three links.

Delete links

To delete one or multiple links

1. Click on the link you want to delete or hold down Command to select

multiple links.

2. Press the Delete key on your keyboard or select Basic > Delete to

delete them all.

To remove all web links

Using the Remove All Links command, you are able to remove all the web

links within the document.
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1. Choose Document > Remove All Links.

2. Click OK.

Note: Remove All Links removes only links that link to websites and will not

affect other links. The operation cannot be undone, so make sure you would

like to proceed it before clicking OK.

Create web links from URLs

Create Links from URLs lets you automatically turn all the URLs within a page

range into web links. If you want to make only certain URLs active, you can

specify on which pages to create web links.

1. Open the PDF document that contains URLs.

2. Choose Document > Create Links from URLs.

3. A message appears informing you this operation cannot be undone.

Click OK to proceed.

4. Specify on which pages you want to generate active web links from

URL and then click OK.

5. To test the link, click on the link using the Hand tool and then click OK

to go to the specified web page.
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Destinations

A destination is the end point of a link that enables you to set navigation

paths across a collection of PDFs.

To view destinations

1. Open the PDF in Right PDF Editor.

2. Do either of the following to open the Destinations panel:

o Choose Document > Destinations.

o On the Sidebar Navigation pane, click Destinations.

To set a destination

1. Find the place within the document where you want to create a

destination and then set the desired view.

2. In the Destinations panel, do either of the following:

o Click the Create New Destination button and name the

destination. The current page view is set as the destination.

o Click the Destinations Options button and select New

Destination. Name the new one and the current page view is set

as the destination.

3. To reset a destination, click on the name of the destination, scroll to a

page view and then click the Set Destination button. Or you can right-

click on the destination in the Destinations panel and select Set

Destination from the menu.

To go to a destination

Do either of the following to jump to the destination:

 Double-click on the text representing the destination.

 Right-click on the text representing the destination and then select Go

to Destination.



125 / 226

Link to a destination

You can create a link to a destination in the same or another PDF document.

1. Open the target document (destination) that contains a destination you

want to link to.

2. Choose Document > Link and then drag a rectangle to specify a

location and size of the link.

3. In the Create Link dialog box, set the appearance of the link and select

Go to a page view from the Link Action drop-down menu. Click Next.

4. Go to the target document (with the destination). In the Destinations

panel, click on the destination and click Set Link in the Create Go To

View dialog box.

5. Save the source document. To test the link, click on the link using the

Hand tool to open the target document view (your destination).
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Chapter 8: Forms

 Forms

 Form Preferences

 Creating PDF forms

 Types of Form Field

 Set tab order

 Convert static form to dynamic form

 Import and export form data

 Reset form fields

 Hide or show fields

 Calculate field data
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Forms

Right PDF includes several tools that can be used for creating interactive PDF

forms. Using form field tools, you can create interactive PDF forms so that

recipients can fill it out with ease. Interactive forms are designed to collect the

data you enter into the fields to perform other tasks, such as calculating field

values and exporting form data to a specified file format, and more. You can

also use Recognize Forms feature to transform static forms, non-interactive

forms created in Word or other applications, into dynamic forms containing

interactive form fields in which you can type text.

Form Preferences

On Menu Bar, choose Right PDF > Preferences…, or press Command + K on

your keyboard to show the Preferences dialog box. Choose Forms > Forms

from the options menu to the left. Set form preferences:

General

 Automatically calculate field values: check this box to enable automatic

calculations when data is entered. See Calculate field data for details.

 Show focus rectangle: highlight the form field with focus. If this option

is selected, a dotted square appears when your click a button, a check

box, a radio button, a list box, or a signature field with the Hand tool.

Show focus rectangle selected (Left) Show focus rectangle deselected (Right)
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Highlight Form Field

 Highlight form fields when document is opened. All form fields are

automatically highlighted when the document is opened.

 Check Show outline hover for fields when mouse enter to have form

fields outlined when a cursor hovers over them.

 Click Fields highlight color, specify a color, and then use the Highlight

Fields command to have form fields highlighted in the color you

specify. The Highlight Fields command is enclosed in the document

message bar or you can choose Form > Advanced > Highlight Form

Fields.

Set Fields highlight color in aqua (Left); Use Highlight Fields to highlight form

fields in aqua (Right)

Two ways to access Highlight Form Fields: A. Form > Highlight Form Fields B.

Document message bar > Highlight Fields

 Click Required fields highlight color and specify an outline color of

Required fields. Note that only radio buttons, combo boxes, text fields

and signature fields can be set as required fields. Follow the steps to

highlight a required item:

(1) Do either of the following to set a required field:
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o Create a form field and then its Properties dialog box appears.

Under the General tab, check Required to make it a required

item.

o Open a PDF file that contains form fields. Double-click a field to

show its Properties dialog box. Check Required to make it a

required item.

(2) Choose Right PDF > Preferences… > Forms. Under Highlight Form

Fields, click Required fields highlight color and in the color palette,

choose a predefined color or define a custom color.

o Choose Form > Highlight Form Fields.

o Click Highlight Fields in the Document message bar.

Auto-Complete

If this feature is on, the text field drop-down menu offers you relevant options

based on the entries you previously entered, helping you fill out the form

quickly. You may check Remember numerical data, which helps storing user

entered numeric values. If this option is not selected, then only text options

will be provided.

Edit Entry List.... Display current entries in the Auto-complete database. To

remove an entry from the list, click one of them and click Remove; to clear the

entire list, click Remove all.

Creating PDF forms

Creating PDF forms

Using form creation tools, you can not only create different types of form

fields, but also set a variety of attributes and actions for each field type

through the field properties dialog box.
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To add a form field

1. Open the PDF in which you want form fields to appear.

2. Choose the Form tab and select a form type to add.

3. On the page, drag a rectangle to define the size of the field and then

release the mouse button to finish field creation. You can edit its

attributes in the pop-up Properties dialog box.

To edit a form field

Do either of the following to enter the properties dialog box:

 The field properties dialog box appears as soon as you release the

mouse button to finish field creation.

 Double-click the field you want to edit using Select.

To move the fields

You are able to move the fields anywhere on the page in the document pane:

 After the form creation is over, hover the cursor over the newly-created

form field to show the four-headed Move pointer. Click-drag to move it

anywhere on the page.

 On the Sidebar Navigation pane or through the Basic tab, click Select.

Then click-drag to move it using the Select tool.

 To constrain the horizontal or vertical movement as you drag, press

and hold the Shift key while dragging the field.

 To move fields in small increments either horizontally or vertically, press

the arrow keys on your keyboard to move the selected form field to the

position you want.

Form field properties

How a form field behaves is determined by the form field properties you set in

the Properties dialog box for individual fields, depending on the type of form
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field. You can configure its general field attributes, such as line style, text font,

determine actions to be associated with the form fields, set data

formatting,and more. Take buttons as an example. You decide its appearance,

and how it reacts when triggered. For text fields, you can set up text

alignment, text display, actions, data formatting, validation, and calculation.

General

 Field Name. Give the form field a unique name.

 Hover Text. The text you enter displays when the pointer hovers over

the form field.

 Orientation. Rotate the form field by 0, 90, 180, or 270 degrees.

 Attributes. Specify the text color, line style, line thickness, font and the

color used to fill and outline the selected form filed.

 Visible. Check to make the selected form field always visible on screen.

 Print. Check to make the selected form field visible in print.

 Read Only. Check to prevent others from making any changes to the

form field content.

 Required. Require the users to fill in the selected form field. If the

required field is left blank when you attempt to submit the form, an

error message appears and the empty required field is highlighted.

Also, you can set a special color to highlight the required form fields in

the Preference dialog box.

Options

The Options tab appears for all type of form fields except digital signatures.

The options available within the tab vary depending on the type of form field

selected.

 Radio Button

o Radio Button Style. Specify the icon that appears when the radio

button field is selected. Choose a shape of marker from the list:

check, circle (default), cross, diamond, square, or star. The setting

does not affect the shape of the radio button form field itself.
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o Export Value. Define the value that represents the field if the

form data will be exported.

o Button is checked by default. Check to make the radio button

field selected when users first open the form.

o Buttons with the same name and value are selected in unison.

Enable one click to select multiple related radio buttons. For

instance, if you select a radio button which has the same field

name and selection state as others, all are selected.

 Check Box

o Check Box Style. Specify the icon that appears when the check

box field is selected. Choose a shape of marker from the list:

check (default), circle, cross, diamond, square, or star. The setting

does not affect the shape of the check box form field itself.

o Export Value. Define the value that represents the item if the

form will be exported. If the field is left blank, it uses the Field

Name under General tab as the export value.

o Check box is checked by default. If this option is selected, the

check box remains checked even if Reset Form Fields is used to

clean up all field entries. If this option is not selected, the check

box becomes unchecked when you use Reset For Fields to

remove field entries.

 Combo box and List box

o Item. Type text for options used to appear in the menu for the

field. Click to add the text to the item list on the right-

hand side.

o Export Value. The value you specify represents the item if the

data will be exported. If the field is left blank, it uses the Field

Name under General tab as the export value.

o Item List. This displays all the options available in the list. The

highlighted item in the list appears as the default selected item

in the list or combo box. You can change the default item by

highlighting another item from the item list.
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o Sort Items. Select to enable rearranging the listed items

numerically and alphabetically. If there are numbers, a numerical

sort is performed before an alphabetical sort.

o Multiple Selection (List boxes only). Select this to enable users to

select more than one option. Command-click to make multiple

selections.

o Allow user to enter custom text (Combo box only). Select to

enable users to enter a value besides the ones already available

in the list.

o Commit selected value immediately. Select to enable saving the

value right away after the item is selected. If deselected, the data

is saved only when you click on another form field or anywhere

out of the current field. This option is not available when

Multiple Selection is selected.

 Text Field

o Alignment. Align the text left, right or center within the selected

text field.

o Default Value. Specify the text which appears in the text field by

default until others make changes to it by typing in the field.

o Multi-line. Select to allow more than a single line in the text field.

o Scroll long text. Select to enable typing without length

restrictions. You can scroll to view everything typed in the text

field. This is not available if you select Auto from the Font Size

drop-down menu under the General tab.

o Limit of ____ characters. Define the maximum number of

characters to be entered into the text field.

o Password. Display all user-defined entries as a series of asterisks

(*). This option is available only when Multi-line is not selected.

o Comb of ____ characters. It evenly spreads all user-entered text

across the width of the text field. For example, if you enter 5, the

field is evenly divided into 5 boxes with only one character

allowed to be entered into each box. This option is available only

when no other checkbox is elected.
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Actions

You can specify any actions associated with the selected form field, such as go

to a page view, open a file, reset a form, or show/hide field(s). All types of

form fields include the Actions tab and the following options:

 Select Trigger. Specify the user action that launches the action

associated with the field: Mouse Up, Mouse Down, Mouse Enter, Mouse

Exit, On Focus, or On Blur.

 Select Action. Specify the event occurring when the user triggers the

action: Execute a menu item, Go to a 3D view, Go to a page view,

Import form data, Multimedia Operation, Open a file, Open a web link,

Play a sound, Play Media (PDF 1.4 Compatible), Play Media (PDF 1.5

and later Compatible), Reset a form, Run a JavaScript, Show/Hide

field(s), and Submit a form.

 Do Action. All triggers and actions are listed here.

 Add.... Click to open the widow where you configure settings for the

selected action.

 Delete. Click to remove the selected trigger-action pair from the Do

Action list.

 Edit. Make changes to the selected action. Select an action from the Do

Action list and click Edit to open a dialog box with specific options for

the selected action.

 Up and down buttons. Rearrange the actions listed under the same

trigger. The buttons are available only when there are multiple actions

for the same trigger.

Format

The Format tab in the properties dialog box only appears for combo box fields

or text fields.

 None. This means the input in a combo box or text field doesn't

require any specific formatting.

 Number

o Style. Specify the placement of periods and commas.

o Currency. Set the type of currency, such as Dollar, Pound, or Yen.
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o Decimal. Define the number of digits that appear to the right of

the decimal point.

o Symbol Location. Decide where to put the specified currency

symbol in relation to the number. This field is available only

when a currency symbol is selected.

o Negative. Decide how negative numbers are displayed. Choose

Show Red, Show Parentheses, Both, or Neither.

 Date. Decide how to display the date. The drop-down menu provides

variations you can choose from: m means month, d means day, and y

means year.

 Time. Decide how to display the time. H means the hour on a 24-hour

clock, MM means minutes, h means the hour on 12-hour clock, ss

means the seconds, and tt means am or pm.

 Special

o Zip Code. This option is for entering a five-digit U.S. postal code.

o Zip Code + 4. This option is for entering a nine-digit U.S. postal

code.

o Phone Number. This option is for entering a ten-digit telephone

number.

o Social Security Number. This option is for entering a nine-digit

U.S. Social Security Number. Hyphens are inserted automatically

after the third digit and the fifth digit.

 Arbitrary Mask It changes the format category to custom and makes

another text field available, in which you can type a custom format. Use

this option to specify which types of characters the user can enter in

any given position, and how the data displays in the field.

o A accepts only letters (A-Z. a-z).

o X accepts spaces and most printable characters, including all

characters available on a standard keyboard and ANSI characters

in the ranges of 32-126 and 128-255.

o The letter "O" accepts alphanumeric characters (A-Z. a-z, and 0-

9)

o 9 accepts only numeric characters (0-9). For example, a mask

setting of AAA--p#999 accepts the input BOE--p#767.

 Custom This is the section where you can enter custom JavaScript for

formatting and keystrokes.
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o Keystroke Script. The setting box displays custom JavaScript you

have added to validate keystrokes. You can click the Edit...

button to open the JavaScript Editor dialog box in which you can

edit or write new scripts.

o Format Script. The settings box displays custom JavaScript you

have added for formats. You can click Edit... to open the

JavaScript Editor dialog box in which you can edit or write new

scripts.

Validate

The Validate tab, available only for combo boxes and text fields, restricts

entries to specified ranges, characters, or values.

 Validate field value. Check to turn on validation.

 Field value is From ____ To _____. Set a numeric range for form fields.

This option is available only when you select Number in Format tab.

 Run custom validation script. Validate using the JavaScript you create

or provide. Click Edit... to create and edit JavaScript.

Calculate

The Calculate tab, available only for combo boxes and text fields, provides

options you can use to perform mathematical operations on existing form

field entries and report the result.

 Using simplified field notation. This uses JavaScript which contain field

names and arithmetic signs. Click the Edit... button to open the

JavaScript Editor dialog box in which you can edit or add new scripts.

 Using custom calculation script. This uses any custom JavaScript you

have added for calculations. Click the Edit... button to open the

JavaScript Editor dialog box in which you can edit or add new scripts.

 Value is not calculated. The value of the selected form field is not

involved in the calculation.

 As the sum/product/average/minimum/maximum of selected fields. It

calculates the sum/product/average/minimum/maximum of the

selected fields. Click Pick… to select the fields for calculation.
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Signatures

The Sign tab, available for digital signature fields only, lets you decide what

happens when a digital signature is applied to the form.

 Do nothing when signed. Nothing happens when the field is signed. All

fields are still available.

 Marked "All fields" as read-only. All fields in the current PDF document

become read-only (locked) after the digital signature field is signed.

 Marked "All fields except followings" as read-only. Only the selected

fields are available after the digital signature field is signed.

 Marked "Just these fields" as read-only. The selected fields will be

locked. You cannot make any changes to the selected fields after the

digital signature field is signed.

 Execute following script when signed. Activate a custom JavaScript

when the form is digitally signed. Click Edit... to edit or create a new

JavaScript action.

Value

The Value tab is available for barcode fields only.

 Encode using. Select a format, either Tab Delimited or XML, from the

drop-down menu. Then click Pick... and select the fields you wish to be

encoded in the barcode field.

 Include field names. Include the field names in the barcode data. If you

do not want to include the field names, uncheck it.

 Custom calculation script. This displays the default script. Click the

Edit... button to open the JavaScript Editor dialog box in which you can

edit or add your custom scripts for the barcode.

 Reference to published form. It shows the path to the PDF form. You

are allowed to edit this by typing in information in the field. The URL

reference is encoded into the barcode and displayed on the form

below the barcode if you choose to encode the barcode field using

XML values.
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Types of Form Field

Create a button field

Right PDF provides you with several form tools to create different types of

fields. To create a field, select the tool depending on the type of field you

want and then drag a rectangle where you want to add the field.

Create a button field

Button is the most broadly used field type of all the field types and can be

formatted to perform a variety of tasks, such as clearing form data, submitting

a form, opening a new link, playing a sound, and more. In addition, since

Image Field is just an extension of Button, this guide will not elaborate on it.

1. Open a PDF and choose Form > Button .

2. On the page, drag a rectangle where you want the field to appear. To

call out the Button Properties dialog box, do any of the following: The

dialog box appears automatically right after the field is created. Or on

the Sidebar Navigation pane or under the Basic tab, click Select and use

it to double-click the field.

3. In General, name the field and set its button attributes.

4. In Options, edit the following settings:

o Click Behavior and decide how the button behaves when it is

activated by the mouse action you specify in the State field.

o In the Icon and Label section, define an image or text to appear

in the button. You can have Label only (text only), Icon only

(image only), or both (text and icon) in a button. Choose an

appropriate option from the drop-down menu right next to the

Label field.
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Have both text and an icon displayed in the button: Place the text at the bottom

and the icon at the center, and adjust its size. (Left) The result (Right)

5. In Actions, specify options to determine what happens when the button

is clicked. The Action tab offers the following settings:

a. Select Trigger. Define how the user initiates an action, including

Mouse Up, Mouse Down, Mouse Enter, Mouse Exit, On Focus, and On

Blur. For example, if you select Mouse Up, the action occurs as soon as

you release the mouse.

b. Select Action. Specify the task the button performs when the user

triggers the action. Select an action from the Select Action drop-down

menu and click the Add... button to open a window for the selected

action.

c. The Do Action setting box displays the list of triggers and actions you

defined for the button.

o Click Delete to remove the selected action from the Do Action

list.

o Click Edit to change the settings for the selected action.

o Use Up/Down buttons to change the order of the selected

action listed under the same trigger. The buttons are available

only when there are multiple actions placed under the same

trigger.

Create a check box field
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Use Check Box if you want recipients to select one or more options at the

same time. In some cases, if you want to select a check box and make a group

of check boxes all checked, you can give the group the same field name to

have all of them perform the specified action.

1. Open the PDF file where you want form fields to appear. Choose Form

> Check Box.

2. On the page, drag a rectangle to specify the size and location of the

form. To call out the Check Box Properties dialog box, do any of the

following: The dialog box appears automatically right after the field is

created. Or on the Sidebar navigation pane or under the Basic tab, click

Select and then use it to double-click the field.

3. In General, name the field and set its box attributes as needed.

4. In Options, edit the following settings:

o In the Check Box Style section, select a desired field style for the

check box appearance.

o Click Export Value and specify a value that represents the item if

the form data will be exported. The defined export value appears

in the resulting data file if the check box field is selected. If

deselected, it shows Off indicating the item is not selected.

o Check Check box is checked by default to have the check box

selected unless the user deselects it.

Note: The appearance of the check mark inside the check box is determined

by the font size and the color you specify in General > Attributes > Text of the

Check Box Properties dialog box.

Create a radio button field

You use radio buttons when there can be only one choice. For example, you

can uncheck the check boxes by clicking them again; however, the only way to

uncheck radio buttons is to clear a form data either by using Reset Form Field

(Form > Recognize Forms) or clicking a then-created Reset form button.

See To create a Reset form button for details.
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You can create a group of radio buttons with the same field name if you want

the user to select only one choice among a set of choices. Though radio

buttons in the same group have the same field name, each button has a

different export value. To add a radio button field:

1. Open the PDF that you want to add form fields to. Choose Form >

Radio Button.

2. On the page, drag a rectangle to specify its size and location. To call

out the Radio Button Properties dialog box, do any of the following:

The dialog box appears automatically right after the field is created. Or

on the Sidebar Navigation pane or under the Basic tab, click Select and

then use the Select tool to double-click the field.

3. In General, name the field and set its button attributes. To make it a

required item, check Required at the bottom. You can then use

Highlight Fields to outline it with the color you specified at Required

fields highlight color in Forms Preferences to draw more attention to it.

See Form preferences.

4. In Options, edit the following settings:

o In the Radio Button Style section, specify the shape of the

marker that appears inside the radio button when it is selected.

Choose one from the style list: Check, Circle (the default), Cross,

Diamond, Square, or Star. Note that this property doesn't

change the shape of the selected radio button itself.

o Click Export Value and specify the value that represents the item

if the form data will be exported. The defined export value

appears in the resulting data file if the button field is selected. If

deselected, it shows Off, indicating the item is not selected.

o Check Button is checked by default to have the radio button

selected. You cannot use the Reset

o Check Buttons with the same name and value are selected in

unison to select a group of radio buttons with the same field

name and value. Note: To make radio buttons in a group able to

detect how each other behaves, they must be given the same

field.
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Create a combo box field

Combo Box provides recipients with list of options to choose from in the form

of drop-down menu and they can only select one option. You can add menu

items to the item list in Options of the Combo Box Properties dialog box. In

addition to the list of options to choose from, recipients are also allowed to

enter their own text if Allow user to enter custom text is selected. Combo box

can also calculate values of specified text fields and display the calculation

result. To add a combo box field:

1. Open a PDF file and choose Form > Combo Box .

2. On the page, drag a rectangle where you want the field to appear. To

call out the Combo Box Properties dialog box, do any of the following:

The dialog box appears automatically right after the field is created. Or

on the Sidebar Navigation pane or under the Basic tab, click Select and

use it to double-click the field.

3. In General, name the field and set its box attributes. To make it a

required item, check Required at the bottom. You can then use

Highlight Fields to outline the required item with the color specified at

Required fields highlight color in Forms Preferences to draw more

attention to it.

4. The Options tab offers the following settings:

o Item. Define the options to appear in the drop-down menu. Click

the Item field, enter a menu item, and click the button to add it

to the Item List to the right. Repeat this step to add more items.

o Item List. Display the items that will appear in the Combo Box.

Click the Item field, enter a list item, and click the button

to add it to the Item List to the right. Repeat this step to add

more items.

o Export Value. Specify the value the represents the chosen item if

the form data will be exported. Only the value of the selected

item from the Combo Box menu will be exported and appear in

the resulting data file.

o Allow user to enter custom text. Check to allow users to enter

their text in the combo box if there isn't a suitable option.
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o Commit selected value immediately. Select to save the selected

value as soon as you make a selection. If this option is

deselected, the selected value will be saved only when you tab

out of the current field or click another form field.

Crete a List Box field

List Box provides users with list of options in the form of scrollable menus.

You can define items to display in the List Box options menu, similar to how

you define responses in Combo Box. To add a list box field:

1. Open a PDF file and choose Form > List Box .

2. On the page, drag a rectangle where you want the List Box field to

appear. To call out the List Box Properties dialog box, do either of the

following: The dialog box appears automatically right after the field is

created. Or on the Sidebar Navigation pane or under the Basic tab, click

Select and use it to double-click the field.

3. In General, name the field and set its box attributes.

4. In Options, edit the following settings:

o Item. Define the options to appear in the list box. Click the

Item field, enter a list item, and click the button to add it

to the Item List to the right. Repeat this step to add more items.

o Item List. Display the items that will appear in the List Box.

o Export Value. Specify the value that represents the item if the

form data will be exported. Only the value of the selected item

from the List Box menu will be exported and appear in the

resulting data file.

o Sort Items. Sort the items in the List Box numerically and

alphabetically. If Sort Items is not selected, you can use the

Up/Down buttons to rearrange the items in the list.

o Multiple Selection. Check to allow users to select multiple items

from the list.

o Commit selected value immediately. Select to save the selected

value as soon as you make a selection. If this option is
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deselected, the value will be saved only when you tab out of the

current field or click another form field. For List boxes, this

option is greyed out if Multiple Selection is selected.

Create a text field

Text Field allows recipients to enter their own information that can be alpha

text or numeric values. You can assign actions, define the text format, validate

data, and perform text field calculations on text fields. In addition, since Date

Field is just an extension of Text Field, this guide will not elaborate on it.

Among all field creation tools Right PDF provides, only Combo Box and Text

Box can perform text field values calculation.

For more information, see Calculate field data. To add a text field:

1. Open a PDF and choose Form > Text Field.

2. On the page, drag a rectangle where you want the field to appear. To

call out the Text Field Properties dialog box, do either of the following:

The dialog box appears automatically right after the field is created. Or

on the Sidebar Navigation pane or under the Basic tab, click Select and

use it to double-click the field.

3. In General, name the field and set its text field attributes. To make it a

required item, check Required at the bottom. You can then use

Highlight Fields to outline the required item to draw more attention to

it. See Form preferences.

4. In Options, edit the following settings:

o In Alignment, select one text alignment item among Left, Center,

and Right.

o In Default Value, enter text that will appear in the text field when

the user first opens the file. You can use this to suggest the

format you want (e.g., Last name, First name, SSN) and then set

the default text attributes through the options beneath the

Default Value field.

o Multi-line. Move the text down to the next line when it reaches

the end of the text box.
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Multi-line deselected. (Left) Multi-line and Scroll long text selected. (Right)

o Scroll long text. Allow scrolling text if the entry exceeds the

visible area of the text field.

o Limit of __ characters. Enter the number of characters to limit the

length of entries.

o Password. Make all user-entered text a series of asterisks (*). This

option is not available when Multi-line is selected.

o Comb of ___ characters. Evenly spread all user-entered text

across the width of the text field. For example, if you enter 5, the

field is evenly divided into 5 boxes with only one character

allowed to be entered into each box. This option is available only

when no other checkbox is selected.

Two text fields with comb of 4 characters of each (Left) A text field without the

comb property (Right)

5. In Format, None is set as default so the input does not require any

specific formatting. To constrain input formatting, choose an option

from the list of formats.

6. Click the Validate tab. Restrict entries to specified ranges, characters, or

values.

o Validate field value. Check to turn on validation.

o Field value is From ____ To _____. Set a numeric range for form

fields. This option is available only when you select Number in

Format tab.

o Run custom validation script. Validate using the JavaScript you

create or provide. Click Edit... to create and edit JavaScript.
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7. In Calculate, select a calculation method from the drop-down menu.

Use the selected calculation method to perform mathematical

operations on the existing form field entries and display the result.

See Calculate field data.

Note: Once you have set a default value for the text field, you cannot check

the formats of "Number", "Date", "Time" or "Special" any more.

Create a digital signature field

Digital signature lets you add an empty digital signature field to a PDF

document. Recipients of the form will be prompted to digitally sign the file

with their digital IDs after clicking on this field. However, in order to sign a

digital signature field, the digital ID must contain your unique signature and

other information to identify yourself. See Manage digital IDs for details. To

create a new digital signature form field:

1. Open a PDF file and choose Form > Digital Signature.

2. On the page, drag a rectangle where you want the digital signature

field to appear. To call out the Digital Signature Properties dialog box,

do either of the following: The dialog box appears automatically right

after the field is created. Or on the Sidebar Navigation pane or under

the Basic tab, click Select and use it to double-click the field

3. In General, name the field and set its field attributes. To make it a

required item, check Required at the bottom. You can then use

Highlight Fields to outline the required item to draw more attention to

it. See Form preferences.

4. In Sign, click the drop-down menu and define how the other fields

react when the digital signature field is signed:

o Do nothing when signed. Nothing happens after the field is

signed. All fields are still available.

o Marked "All fields" as read-only. All fields in the current PDF

document become read-only (locked) after the digital signature

field is signed.
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o Marked "All fields except followings" as read-only. Only the

selected fields are available after the digital signature field is

signed.

 (1) Select Marked "All fields except following" as read-

only from the drop-down menu.

 (2) Click the Pick... button.

 (3) In the Field Selection dialog box, select the fields that

will remain available after the digital signature field is

signed. Click OK.

o Marked "Just these fields" as read-only. The selected fields will

be locked. You cannot make any changes to the selected fields

after the digital signature field is signed.

 (1) Select Marked "Just these fields" as read-only.

 (2) Click the Pick... button.

 (3) In the Field Selection dialog box, select the fields that

will be locked after the digital signature field is signed.

Click OK.

o Execute following script when signed. Activate a custom

JavaScript when the form is digitally signed. Click Edit... to edit or

create a new JavaScript action.

5. Click Close.

Barcode Tool

Barcode fields transform data entry of a PDF document into a visual pattern

that can be easily scanned and interpreted for analysis. It eliminates the need

to manually incorporate information into a database, preventing potential

data-entry errors from happening.

Create and edit a barcode field

1. Open a PDF file and choose Form > Barcode Tool.

2. Drag a rectangle to define the size and the location of the barcode

area. Do any of the following to call out the Barcode properties dialog
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box in which you can adjust the barcode properties using the given

tabs: The dialog box pops up upon the creation of a new barcode. Or

using the Select Tool, double-click a barcode field. Or using the Select

tool, right-click a barcode field and select Properties... from the options.

3. The tabs in the Barcode properties dialog box offer the following

settings:

o Options

 Symbology. Select a Symbology option from the drop-

down menu, including PDF417, QR Code, and Data

Matrix.

 Compress Data Before Encoding to barcode. This enables

compressing data before it is encoded into a barcode so

that more user data can be stored. Make sure your

processing device can read compressed data before using

this function.

 Decode Condition. Select the type of hardware to process

the barcode data, including Handheld Barcode Scanner,

Fax Server, Document Scanner and Custom.

 Click Custom to set a custom X Dimension, Y/X Ratio, and

Error Correction Level.

 Manage Barcode Parameters.... In the Manage Barcode

Parameters dialog box, you can add new edit, delete,

import, and export parameters. For more information,

see Manage custom barcode settings.

o Value

 Select Encode using and then select a format, either Tab

Delimited or XML, from the drop-down menu. Then click

Pick... and select the fields you wish to be encoded in the

barcode.

 Select Include field names to include the field names in

the barcode data. If you do not want to include the field

names, uncheck it.

 Select Custom calculation script and then click the Edit...

button. In the JavaScript Editor dialog box, enter your

custom JavaScript code.

 Reference to published form. It shows the path to the PDF

form. You are allowed to edit this by typing information in
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the field. The URL reference is encoded into the barcode

and displayed on the form below the barcode if you

choose to encode the barcode field using XML values.

4. If needed, make changes to the settings in the General and Actions

tabs and then click Close.

Manage custom barcode settings

You can adjust your custom barcode parameters and also edit, delete, and

share a set of customs settings for barcode parameters in the Barcode

properties dialog box.

 Create a new barcode parameters set

1. Open the Barcode properties dialog box by doing either of the

following using the Select Tool:

 Right-click a barcode field and select Properties....

 Double-click a barcode field.

2. In the Options tab of the Barcode properties dialog box, click the

Manage Barcode Parameters... button.

3. In the Manage Barcode Parameters dialog box, select an existing

parameter set you want to use as the basis of the new set and

then click New... or directly click New....

4. In the Barcode Parameters dialog box, enter a name for the new

parameter set in the Name field and a description in the

Description box.

5. Select options for the Symbology, X Dimension, Y/X Ratio, and

Error Correction Level and then click OK.

Note: after the newly defined custom parameter set is created and

appears in the list of parameter sets, all options to the right become

available, by which you can edit, delete, import or export the selected

custom parameter set.
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 Edit or delete a new set of barcode parameters

1. In the Options tab of the Barcode properties dialog box, click the

Manage Barcode Parameters... button.

2. In the Manage Barcode Parameters dialog box, select a custom

barcode parameter from the list and then do the appropriate

action listed below:

 Click Edit... to make adjustments to the settings of the

selected barcode parameter.

 Click Delete to remove the select barcode parameter from

the list.

 Click Close.

 Import or export a set of barcode parameters

1. In the Options tab of the Barcode properties dialog box, click the

Manage Barcode Parameters... button.

2. In the Manage Barcode Parameters dialog box, do the

appropriate action listed below:

 Select a custom barcode parameter set from the list and

then click Export.... In the Save As dialog box, specify a file

name for the file that will end with the extension .bps and

a location to save the file.

 Click Import... and locate a .bps file you want to import

and then click Open.

Set tab order

Set Tab Order Tool allows users to move from one field to another field using

the Tab key. By default, the field tab order is set by the order in which the

fields are created. You can reset the tab order to make it easier for user to

navigate through the form fields.
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Options for tabbing through items on a page

1. Do either of the following to open the Page Thumbnails panel:

o Choose Document > Assemble > Page thumbnails.

o On the Sidebar Navigation pane, click the Page Thumbnails icon.

2. In the Page Thumbnails panel, right-click the page thumbnail on which

you want to set the tabbing order and choose Page Properties... from

the options menu.

3. In the Page Properties dialog box, the Tab Order tab offers the

following settings for you to specify the order users tab through the

fields in a form:

o Use Row Order. Tab through fields from top to bottom, row by

row.

o Use Column Order. Tab through fields from left to right, column-

by-column.

o Use Document Structure. The tabbing follows the order defined

with the "Set Tab Order Tool".

o Unspecified. No tab order has been set. You can manually set

the tab order using Set Tab order Tool.

4. Click Close.

To set the tabbing order using Set Tab Order Tool

You can use Set Tab Order Tool to manually set tabbing order for form field

elements.

1. Open a PDF file that contains form fields or you can create form fields

on a PDF file.

2. In the Page Thumbnails panel, right-click the thumbnail on which you

want to set the tabbing order and then select Page Properties... from

the options menu.

3. In the Page Properties dialog box, click Tab Order and select

Unspecified from the tab order options. Click Close.

4. Choose Form > Set Tab Order Tool. Click OK.
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5. A number appears in the upper-left corner of each form field,

indicating the tabbing order you set. Click the form fields in the order

as desired, and then click anywhere to finish.

6. To test the tab order you set, click on any field on the page with the

Hand tool and press the Tab key.

Note: You are not allowed to use Set Tab Order Tool unless you select

Unspecified in the Tab Order of the Page Properties dialog box.

Convert static form to dynamic form

Interactive forms are designed for users to enter data into the form fields.

However, static forms lack the interactive quality in that they may be scans of

paper forms or non-interactive forms created in Word or other applications.

Due to the complexity of designing a fillable PDF file, most PDF forms are

static, meaning the form fields cannot be filled electronically. Recognize Forms

can detect the static form fields in a PDF document and then convert them to

electronically fillable forms. From this point, information you type into the

fields can be collected and other tasks, such as calculating field values, can be

performed. To convert a static form:

1. Open a static form in Right PDF.

2. Choose Form > Recognize Forms.

3. Recognized form fields are listed in the Fields panel to the left.

4. To edit properties of specified text fields:

o Double-click the field name on the panel.

o Right-click the field and choose Properties….

5. To test the form fields, choose Basic > Hand and click on the

recognized form fields in the document pane. You can type text in it.
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Import and export form data

Using Import and Export commands, data within a PDF form can be moved to

and from other file formats capable of preserving form data. The form data

can be exported and repeatedly used to fill out other forms, which can be

useful for speeding up form filling especially for a large number of forms. The

process includes exporting form data which can be saved in one of the

following file types, FDF, XFDF, XML, or TXT and then importing those to fill

empty forms.

To import data into a PDF document

1. Open a PDF file that contains unfilled forms.

2. Choose Form > Import Data.

3. In the dialog box, specify a file type (FDF, XFDF, XML, TXT) and locate

the file with the form data you need to import into the open form.

4. Click Open. The form data will be inserted into the proper fields as long

as the chosen form contains data that are suitable for the currently

open form.

To export form data from a single filled form

1. Open a PDF file that contains form fields or you can create form fields

on a PDF file.

2. Choose Form > Export Data.

3. Specify a name, location and file format in the dialog box.

4. Click Save. The form data is then stored in the file type and at the

location you defined.

Export data from multiple forms

Form Data can be exported from multiple forms to the file types XML and CSV

(Comma Separated Values). The file types can be opened by Excel or Notepad.
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The field names in the forms become the header texts for the columns. You

can export form data of all field types except for digital signature fields.

1. Open a PDF file.

2. Choose Form > Export Data from Multiple Forms.

3. In the Export Data from Multiple Forms dialog box:

o Click Add Files and choose the files containing form data to be

exported. Click Open.

o Click Remove Files to delete one or more files from the Files to

Export Data Form list.

o Check Include most recent list of files to export data from to add

all recently exported form files to the list.

4. Click Export when the file list is all set.

5. In the dialog box, specify a location to save, a file name, and a file type

(*.csv) or (*.xml). Click Save.

6. After the export is done, click View File Now if you would like to view

the resulting file with your spreadsheet program. Otherwise, click Close

Dialog to finish exporting.

Reset form fields

Reset Form Fields allows users to clear up any data you have already entered

in the form, except for default values of text fields and options within combo

boxes and list boxes. You can also create a Reset form, which lets users clear

only specific fields.

To clear form data using Reset Form Fields command

1. Open a PDF file that contains form fields or you can create form fields

on a PDF file.

2. Choose Form > Reset Form Fields.
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To create a reset form button

1. Open a PDF file and choose Form > Button.

2. On the page, drag a rectangle at where you want the reset form button

to appear. The Button Properties dialog box appears right after the

button is created, or you can double-click the button to open it as well.

In the Button Properties dialog box, set General and Options properties

for button appearance and behavior as needed.

3. In General, name the field and set its box attributes.

4. In Actions, do the following to set a Reset Form Button and then click

Close:

a. Select Trigger. Determine how to initiate resetting. For example,

if you choose Mouse Up, the selected fields are reset upon

releasing the mouse after a click.

b. Select Action. Specify an action that the button performs when it

is triggered.

 Select Reset a form from the drop-down menu

 and click Add....

 In the Reset a Form dialog box, all the fields are selected

by default. Uncheck the fields you do not want to be

reset. You can click on the Deselect All button to uncheck

all the fields at once. Click OK.

c. The Do Actions box shows Reset a form nested under Mouse Up.

5. Click Close.

Hide or show fields

In some cases, you may need to show or hide certain fields in your PDF form.

For example, you want to hide some form fields so that users can focus on the

specific parts of the form they need to fill out. To show/ hide fields:

1. Open a PDF file and go to the Form tab. The button to show or hide

fields can be any type of form fields except barcode. Select one form

creation tool and drag a rectangle at where you want the button to
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appear on the page. For example, select Button and drag a rectangle to

specify its size and location.

2. On the page, drag a rectangle at where you want the reset form button

to appear. The Button Properties dialog box appears right after the

button is created, or you can double-click the button to open it as well.

In the Button Properties dialog box, set General and Options properties

for button appearance and behavior as needed.

3. In the Button Properties dialog box, set General and Options properties

for button appearance and behavior as needed.

4. In Actions, do the following to set a button for showing or hiding fields

and then click Close:

o Select Trigger. Determine how to initiate showing or hiding. For

example, if you select Mouse Up, all selected fields are hidden or

shown upon releasing the mouse after a click.

o Select Action. Specify the action the button performs when

triggered.

 Select Show/Hide field(s) from the drop-down menu.

 Click the Add....

 In the Show/Hide Field(s) dialog box, select to Hide or to

Show the selected fields.

 Click OK.

5. Click Close.

Calculate field data

Calculations are one of the most significant functions of electronic form. For

instance, it can combine values from form fields and present the calculation

results on a Text Field or Combo Box. You can go to the Calculate tab in the

Text Field and Combo Box Properties dialog box, in which you can select a

predefined calculation method and the fields affected thereof. To create a

calculation:

1. Open a PDF file and do one of the following to call out the Text Field

Properties dialog box:
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o Choose Form > Text Field. On the page, drag a rectangle where

you want the text field to appear and the dialog box pops up.

o Using Select tool, double-click on the text field intended to show

calculation result.

o Using Select tool, right-click on the text field intended to show

calculation result and select Properties....

2. Select Options and choose an Alignment type to determine at which

position the result displays in the calculation field. For example, select

Right from the options to align the values to the right.

3. In Format, click Number and then click the Decimal drop-down menu.

Select the number of digits displayed to the right of the decimal point.

4. In Calculate, select a predefined calculation option from the drop-down

menu and then click the Pick to select the fields involved:

o Select as the sum (+) of selected fields to sum a group of data.

o Select as the product (x) of selected fields to multiply values.

o Select as the average of selected fields to average a group of

values.

o Select as the minimum of selected fields to present the

minimum value among a group of fields.

o Select as the maximum of selected fields to present the

maximum value among a group of fields.

5. In the Field Selection dialog box, do one of the following and then click

OK:

6. Select or deselect the checkboxes to decide which field is involved in

calculation. The selected fields are listed in the box beneath the menu

of calculation options.

7. Click Close.
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Chapter 9: Security

 Choosing a security method of PDFs

 Securing PDFs with passwords

 Securing PDFs with certificates

 Security schemes

 Manage Digital IDs

 Signing PDFs

 Validate digital signatures

 Send PDF documents with secure delivery

 Envelope panel

 Removing sensitive data from PDFs
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Choosing a security method of PDFs

Which type of security do you need?

It depends on the protection you need to secure your PDF files.

Examples Protection level Actions

You allow only

certain people

who have the

correct password

to open a PDF, or

copy, print or edit

its content.

Require a

password to

open, copy, or

print its

contents.

Choose Security > Encryption.

1. Open Password. Only people with the

correct password can open and view the

document.

2. Permission Password. You don't need a

password to open the document, but

you need the correct permissions

password to change the restricted

functions.

3. Interactive Password. You can secure a

PDF file with both types of passwords

and further choose which content to

encrypt and which action to restrict. The

PDF secured with both types of

passwords can be opened with either

one. However, only the permissions

password allows users to change the

restricted functions.

See Securing PDFs with passwords.
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You want to allow

specified people

to view the PDF

and apply

different security

schemes to

recipients.

Only the people

you specify can

view and open

the PDF

encrypted with

certificates.

Choose Security > Encryption > Interactive

Certificate. Alternatively, you can open the

Document Properties dialog box and choose

Security > Security Method > Certificate

Security. To specify recipients, you must import

the certificates from intended recipients into

your list of trusted identities.

See Securing PDFs with certificates.

You want

recipients to know

that you have

already approved

the PDF content.

Sign and certify

the PDF with a

digital ID to add

digital

signatures.

Choose Security > Sign/Certify > Sign/Certify.

Select Certify Document to add your digital ID.

Then you can specify which action can be done

by recipients. To perform signing/certifying,

you need a digital ID, which can be either an

existing one or a Self-Signed Digital ID.

See Signing PDFs.

You want to send

the PDF as email

attachment

without having to

encrypt all

contents.

Attach a PDF to

an email.

Choose Security > Secure Delivery. You can send

a protected PDF as email attachment.

Password-/certificate-based security

There are two types of security method that can be used to control who can

access the files and which function they can use once the encrypted file is

opened: password-based security and certificate-based security. If you use

passwords to secure your PDF file, only the people who have the password

can view or make changes to your PDF file. If you use certificate-based
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security, only the people you specify can view the PDF, and passwords are not

needed to open documents.

Password-based security

You can use passwords to restrict access to a PDF document or certain

functions after the PDF is opened. Then, you can specify a desired encryption

type, a PDF version, and other settings for the intended recipients. There are

two types of password-based security:

 Document open password. Only people having the correct open

password can open and view the PDF file.

 Permissions password. Using a permissions password, you can restrict

certain functionalities, including printing, editing and copying. Though

the permissions password doesn't restrict opening the PDF, you need

to enter the correct password to change the security settings.

Certificate-based security

Using a certificate to secure a PDF, you can ensure that only the intended

recipients can view a PDF. Furthermore, the digital signature serving as a

certificate assures recipients that you are the person who distributed the

document. When encrypting a PDF with a certificate, you can specify the

documents to encrypt, the level of encryption, the recipients allowed to open

the document, and further specify different security settings for individual

recipients. For instance, you may allow one person to perform commenting,

filling forms, while others can do anything except for extracting pages.

View the security method applied to a PDF

In the Document Properties dialog box you can view which type of security

method is currently employed and choose a method for the document. You

can also choose No Security from the Security Method menu to directly

remove existing restrictions.
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1. Open a PDF file. If the document is encrypted with password-based

security, you have to type in the document open password to open and

view the PDF.

2. Do one of the following to open the Document Properties dialog box:

o Choose Security > Encryption > Security Properties.

o Press Command + D on your keyboard.

o Choose File > Properties > Security tab.

3. On the Security tab, the Security Method menu shows the security

method applied to the document:

o Click Details... for more security information regarding

encryption level and encrypted content.

o Click Settings... to edit security settings. If the document is

secured with a permissions password, you have to type in the

correct password to unlock restricted functions.

o You can remove the existing encryption by selecting No Security

from the Security Method drop-down menu. If the PDF

document has already been secured by a permissions password,

you will be prompted to enter the correct permissions password

before you can remove permissions settings.

The Document Properties dialog box where you can view and edit the security

method applied to the file.(Left)

Enter the correct permissions password to remove security settings of the document

encrypted with permissions password. (Right)
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Securing PDFs with passwords

Methods to secure a PDF or PDF Portfolio with password security

You can secure a single PDF file or components of a PDF Portfolio with

password-based security through the Password Security dialog box.

 Choose Security > Encryption > Interactive Password, and click Yes in

the ensuing dialog box.

 Choose File > Properties > Security tab, or press Command + D on

your keyboard. Select Password Security from the Security Method

drop-down menu.

In the Password Security dialog box, use Document Open Password to limit

the access to authorized users; use Permissions Password to restrict

permissions for a file.

Managing password security

 In the Password Security dialog box, select a PDF version from the

Compatibility drop-down menu. The PDF version you choose

determines the level of encryption, which should be equal to or lower

than the recipients' version of Right PDF products.

o PDF 1.2 and later secures the document using 40-bit encryption.

o PDF 1.4 and later secures the document using 128-bit

encryption.

o PDF 1.5 and later secures the document using 128-bit

encryption.

o PDF 1.6 and later secures the document using the 128-bit AES

encryption.

o PDF version 1.7 and later (low security) secures the document

using 256-bit AES encryption.

o PDF version 1.7 and later (high security) secures the document

using 256-bit AES encryption.
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Note: be aware that anyone using an earlier version of PDF

application/reader cannot open a PDF document with a higher

compatibility setting.

 Select an encryption option:

o Encrypt all document contents. Select to encrypt the document

and the document metadata.

o Encrypt all document contents except metadata. Select to

encrypt the contents of a document except metadata. This

option is available only when the compatibility is set to PDF 1.5

or later.

o Encrypt only file attachments. This option is available only when

the Compatibility is set to PDF 1.6 or later. It requires users to

type a File Attachment Open Password to open file attachments

and they no longer need a password to open the document.

Select this option and then type a password into the File

Attachment Open Password field. This is mainly used to secure

file attachments attached in a security envelope.

Open Password

1. Select Allow document opening only by password.

2. Enter a password in the Document Open Password box and then click

OK.

3. At the prompt to confirm the Document Open Password, retype the

password in the field and then click OK.

Permissions Password

1. Select Set a permissions password to specify restrictions for printing,

changes, copying of text, images, and text access for screen readers.

2. Enter a password in the Permissions Password box.

3. Specify what the recipient can print from the Printing permitted drop-

down menu:

o None. Select to prevent users from printing the document.



165 / 226

o Low Resolution. It allows users to print at no higher than 150-dpi

resolution. This option is available only when the compatibility is

set to PDF 1.4 and later.

o High Resolution. It allows users to print at any resolutions and

get a clear copy of the PDF file.

4. Select what the recipient can change from the Changes permitted

drop-down menu:

o None. Select to prevent users from making any changes to the

PDF.

o Creating, inserting, deleting, and rotating pages. Select to allow

users to create, insert, delete, and rotate page or page

thumbnails. It also allows creating new bookmarks. This option is

available only when the compatibility is set to PDF 1.4 and later

(128-bit).

o Filling in form fields and signing signature fields. This option

allows users to fill in forms and add digital signatures. However,

they cannot create form fields or add comments. The option is

not available if the compatibility is set to PDF 1.4 and later (128-

bit).

o Commenting, filling in form fields, and signing signature fields.

This option allows users to add comments and digital signatures,

and fill in forms while it doesn't allow creating form fields.

o Any except extracting pages. This option allows users to edit the

document, add comments and digital signatures, and create

form fields. However, extracting pages is not allowed.

5. Choose any of the following and then click OK:

o Enable copying of text, images, and other content. This option

allows users to copy the contents of a PDF. This option is

available only when the compatibility is set to PDF 1.4 and later

(128-bit).

o Allow accessibility (screen readers can access text for the visually

impaired). This option allows visually impaired users to read the

document with screen readers that can access the text of a

document.

6. Click OK.
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7. At the prompt to confirm the password, retype the password in the

Permissions Password field and then click OK.

Note: you are not allowed to change or remove the security settings of a

signed/certified document. To add a password, you have to clear all signature

fields by choosing Form > Reset Form Fields or use a then-created Reset Form

button.

Securing PDFs with certificates

The certificate-based security lets you ensure only the intended recipients

open and view the document. A certificate includes the public key component

of a digital ID that can be shared and added to your list of trusted identities.

See Manage Digital IDs.

Before you distribute a certificate-secured PDF file, you must receive

certificates from those whom you intend to send the file to and add the

certificates to the list of trusted identities, setting them as trusted recipients.

Likewise, to open a certificated-secured PDF file, you need to create your own

digital ID (consisting of a private key and a public key) and share the

certificate (the public key of you digital ID) with the person who distributes the

file encrypted with certificates.

When managing certificate security, you can specify who can view the

document and define permissions for each recipient. For example, you can

grant one person the power to perform any function except extracting pages,

while another is limited to filling in form fields and signing signature fields.

Note: remember to add your own certificate to the list of intended recipients

of the encrypted document when you manage certificate-based security. This

way, you have the access to the PDF file.

Encrypt a PDF or PDF Portfolio with a certificate

To encrypt a PDF or PDF Portfolio, you can use the Certificate Security Settings

dialog box. You can also save your certificate settings, such as the documents
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to encrypt and trusted recipients, as a security scheme and reuse it to encrypt

PDFs.

1. To open the Certificate Security Settings dialog box, choose Security >

Encryption > Interactive Certificate. Or, open the Document Properties

dialog box, click Security, and then select Certificate Security from the

Security Method drop-down menu.

2. At the prompt, click Yes.

3. In the Certificate Security Settings dialog box, decide whether to save

the settings as a scheme. Click Next >. Select the document

components to encrypt, choose a level of encryption from the

Encryption Algorithm drop-down menu, and click Next>. The

encryption algorithm and key length are version-specific. Choose a PDF

version compatible with the recipients' reader or PDF application.

o If you select 128-bit, recipients must have PDF 1.5 and later to

open the document.

o If you select 128-bit AES, recipients must have PDF 1.6 and later

to open the document.

o If you select 256-bit AES, PDF 1.7 and later are required to open

the document.

4. Create a list of recipients for the encrypted PDF and then click Next>.

Remember to always include your own certificate in the recipient list so

that you also have access to the document. Select trusted contacts

from the left and then click Add>> to add them to the list of recipients.

Then, you can change encryption settings as stated below:

o To add more trusted identities, click Import Certificate to trust

list (A) and select a certificate file.

o To check the information of a trusted recipient, select the

recipient and then click Recipient Details (D) to open the

Certificate Attributes dialog box.

o To remove a recipient, select one and then click Remove<<.

Make sure your certificate is still on the recipient list unless you

don't want the access to the encrypted file.

o To individually define permissions for each recipient, select one

recipient and then click Set Permissions (C). In the Recipient

Permission Settings dialog box, make any changes as needed

and then click OK.
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5. Click Finish. Then click Save Now to apply you changes to the document.

Create a list of recipients A. Import Certificate to trust list B. Create Certificate C.

Set Permission D. Recipient Details

Getting certificates from others

When you receive certificates from others, you can add them to your list of

trusted identities and set them as trusted roots. There are two ways to store

certificates in your list of trusted identities: 1) import an existing certificate or

2) add a certificate from a digital signature in a signed PDF document. The list

of trusted identities helps you validate the signatures of the users on any

documents you receive from them.

Import an existing certificate

1. Open a PDF file.

2. Choose Security > Trusted Identities.

3. In the Manage Trusted Identities dialog box, click Add....

4. In the Open dialog box, select the certificate to use and click Open.

5. To set a certificate as a trusted identity in any documents, select a

certificate and click Set as a Trusted Root.

Add a certificate from a digital signature in a signed PDF

You can directly add a certificate from a signed PDF document to your list of

trusted identities.

1. Open a PDF that contains digital signatures.
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2. Do any of the following to open the Signature Properties dialog box:

o In the Signatures panel, right-click on the signature and select

Properties....

o Right-click on a signature field on your page and select

Properties....

o In the Signatures panel, click the Signatures Panel Options

button and select Properties... from the menu.

3. In the Signature Properties dialog box, click the General tab. In the

Additional Information section, click Verify Identity....

4. In the Verify Identity dialog box, click Add as a Trusted Root to store

the certificate of the digital signature in your list of trusted identities,

making signatures of the user valid on any documents.

Remove encryption settings

You can remove security settings from a PDF file that is already opened.

However, it requires the correct permissions password if the PDF file has

already been encrypted with permissions password security.

1. Open the PDF.

2. Do any of the following to remove certificate security:

o Choose Security > Encryption > Remove Security Settings. Click

OK.

o Open the Document Properties dialog box, click the Security tab,

and choose No Security from the Security Method drop-down

menu.

3. Click Save Now to apply the changes to the document. Click OK.

Security schemes

You can save the security settings you often use as a custom security scheme

and use it later. Using security schemes, you do not have to re-enter

passwords or re-add recipients every time you manage document security. If
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you often distribute files to the same recipients whenever you manage

certificate-based security, you can save those recipients in a security scheme

so that you can quickly apply the same security settings with just one click.

Open a PDF file and do any of the following to open the Security panel:

 Choose Security > Security Panel.

 On the Sidebar Navigation pane, click Security.

Create a new security scheme

1. Do the following to open the New Security Scheme dialog box:

o In the Security panel, click the Create Security Scheme button.

o Right-click anywhere inside the Security panel and choose Create

Security Scheme from the menu.

2. In Appearance, you may select Use custom appearance and then click

Select... to open the Select Image dialog box. Click Browse… to choose

a file and then click Open, and then OK. Click Next > when finished.

3. In Appearance, you may select Use custom appearance and then click

Select... to choose a file. Click Next >.

4. In Security Type, specify whether to apply password-based security or

certificate-based security and then click Next >:

o Use password. You need to enter the correct password to open

the document or change permissions settings.

Save password with scheme. Check to store a password with the

security scheme you are creating. You need to enter either an

Open Password or a Permissions password, or both to finish

creating this scheme. If not selected, you will be prompted to

specify passwords and permissions whenever you apply this

security scheme.

o Use public key certificates. It lets specified users access

documents secured with certificates.

Ask for recipients when applying this scheme. To create a

scheme that is associated with individual documents, select this

option and you will be prompted to specify trusted identities
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when you attempt to apply this scheme. On the other hand, for a

scheme that is associated with individual recipients, don't select

this option and you need to specify the trusted recipients to be

saved to the scheme.

5. This step varies depending on the type of security you choose:

o If you choose Use password (password-based security), follow

the instructions to restrict access and usage of certain functions.

o If you choose Use public key certificates (certificate-based

security), select document components to encrypt and a type of

algorithm, and click Next >. If Ask for recipients when applying

this scheme is not selected, please select recipients from the

Trusted Contacts box and click Add>> to add them to the

Recipients box. Click Next >.

6. The Scheme Details area shows information of the security scheme you

set. Click Finish to close the dialog.

Apply a custom security scheme

1. On the Security panel do any of the following to apply the scheme to

the document:

o Right-click on an existing security scheme you want to apply to

the document and select Apply Security Scheme.

o Click the scheme and choose Security Scheme Option > Apply

Security Scheme.

o Double-click the scheme.

2. Click Yes to change the security settings of the document.

3. Click Save Now to apply the new security settings.

Edit a security scheme

You can edit the security settings of a security scheme using the Editing a

Security Scheme dialog. However, you cannot change the security type of the

scheme after it has already been placed under either password security or

certificate security in the Security panel.

1. In the Security panel, do any of the following to edit a security scheme:
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o Right-click a scheme and select Edit Security Scheme from the

options.

o Click to select a scheme and then choose Security Scheme

Option > Edit Security Scheme.

2. In the Editing a Security Scheme dialog box, make changes to general

settings and other security settings.

3. Click Finish to close the dialog box.

Copy a security scheme

You can also make a copy of an existing scheme and its scheme name will

start with the phrase Copy of, e.g. [Copy of _(name of the scheme__)]. It copies

all the settings and you are free to make any changes to the security settings

of the copied version.

1. In the Security panel, select a scheme to copy and do any of the

following:

o Right-click the selected scheme and select Copy Security

Scheme from the options.

o Click the selected scheme and choose Security Scheme Option >

Copy Security Scheme.

2. In the Editing a Security Scheme dialog box, Right PDF has already set a

scheme name for the copied scheme, but you can still edit it at will.

Then, click Next > to make any changes if needed. View details in the

Scheme Details area.

3. Click Finish to close the dialog.

4. The copy of the scheme is placed under the same security type in the

Security panel.

Delete a security scheme

1. In the Security panel, do any of the following to remove a scheme from

the panel:

o Click to select a scheme you want to delete and press Delete on

your keyboard.
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o Right-click a scheme and select Delete Security Scheme from the

options.

o Click to select a scheme and then choose Security Scheme

Option > Delete Security Scheme.

2. Click OK to confirm you want to delete the security scheme.

Manage digital ID

What is a digital ID?

What is a digital ID?

A Digital ID is like your passport or ID card that can prove who you are and

contains important information, such as name, email address and expiration

date.

A Digital ID consists of the public key used to encrypt documents and the

private key used to decrypt data and apply your digital signature when

signing. The public key is in a certificate which can be transferred and used to

encrypt documents to prevent unauthorized access. Once you have your own

Digital IDs, you can distribute the certificate to those who want to validate

your digital signature or identity. Make sure you store your private key in a

safe place to prevent others from using it to decrypt your information.
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Digital IDs contain two keys: the private key and the public key. You use the private

key (A) to unlock data and the public key (B) to encrypt data.

What can certificate IDs do?

 Sign documents. You can certify a document using certificate IDs so

that recipients can make sure whether you are the person who signs

the document.

 Validate documents. After receiving the signed document, you can

validate all signatures to confirm the identity of each person who signs

the document. To see if the document has been altered in transit, you

can track all previously signed versions of a document to check for any

changes made to the document.

 Set permissions for recipients. You can certify a document and make

certain functions available to the recipients. Also, using certificates, you

can encrypt documents and restrict the use of certain functions, such as

printing, copying, and editing.

Manage Digital IDs

Create a self-signed digital ID

You may wonder how you can get a certificate. There are two ways to get one:

create a self-signed digital ID or get one from a third-party provider. Once
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you create a self-signed digital ID, it will be automatically added to the list of

digital identities in Security Settings dialog box under Manage Digital IDs.

1. In Right PDF, do any of the following:

o Choose Security > Sign/Certify > Sign Document. Click-drag to

mark a rectangle area anywhere on the page. In the Sign

Document dialog box, click Add....

o Choose Security > Sign/Certify > Certify Document. Click-drag

to mark a rectangle area anywhere on the page. In the Certify

Document dialog box, click Add....

o Choose Security > Manage Digital IDs. In the left panel of the

Security Settings dialog box, click Digital IDs and click Add ID....

2. In the Add Digital ID dialog box, select Create a Self-Signed Digital ID

and then click Next.

3. Determine where to store your self-signed Digital ID and then click

Next:

o New Digital ID File (PKCS#12 Format). Select this to store the

digital ID in a new file with password protection. The digital IDF

file has the extension .pfx in Windows and .p12 in Mac OS. Either

file format is supported by most security applications, including

major web browsers.

o Keychain Access. Store the Digital ID in the Keychain Access

where it will also be available to other Windows applications.

The Digital ID will be protected by your Windows login.

4. In the Create a Self-Signed Digital ID dialog box, type a name, email

address, and other personal information for your digital ID. The name

you specify will appear in the Signatures panel and also in the

Signature field when you certify or sign a document. The options vary

depending on the type of digital ID you choose.

5. From the Use digital ID for menu, specify if you want to use the digital

ID for signing digital signatures, data encryption, or both.

6. If you chose New Digital ID File at step 3, type a password for the

digital ID file with a minimum of 6 characters, and then click Save.

7. Choose a location to save your digital ID, give it a file name, and then

click Save to finish. The newly-created digital ID is automatically added

to the list of digital identities. You can further click Export Certificate...

to export a selected digital ID and then send your certificate file out to
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contacts who need to use it to validate your signature or encrypt

documents with certificate-based security.

Note: make sure you always have a backup copy of your digital ID file. You

cannot use the profile to add signatures if you don't have the correct

password, or your digital ID file is damaged or lost.

Add a digital ID

You can choose to add an already existing digital ID from a file or create a

self-signed digital ID that will be automatically added to your list of digital IDs.

1. In Right PDF, choose Security > Manage Digital IDs.

2. In the Security Settings dialog box, select Digital IDs from the panel to

the left and click on Add ID....

3. In the Add Digital ID dialog box, select Find an existing Digital ID from

and then choose either A file or A device connected to this computer.

4. Click Next and follow the instructions to add Digital IDs.

Remove your digital ID

You can simply delete a digital ID in the Security Settings dialog box. When

you delete a digital ID, you delete the actual PKCS #12 file (*.pfx or *.p12) that

contains both the public key and the private key. However, the exported

certificate remains unaffected.

1. IIn Right PDF, choose Security > Manage Digital IDs.

2. In the Security Settings dialog box, select Digital IDs from panel to the

left and select the ID you want to remove from the list. Click Remove

ID.

3. At the prompt, click OK to confirm you want to permanently remove

the select digital ID.

Note: you can delete only self-signed IDs you created in Right PDF. The digital

IDs obtained from other providers cannot be deleted.
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Export a digital ID

1. In Right PDF, choose Security > Manage Digital IDs.

2. In the Security Settings dialog box, select a digital ID from the list and

click Export Certificate....

3. In the Export Data dialog box, select an export option and then click

Next:

o Email the data to someone. Select to send the Personal X.509

Certification File exported from the selected Digital ID to your

email address. The certification file attached contains a copy of a

certificate that you can use to verify signature and encrypt

documents for the selected digital ID.

o Save the data to a file. Select to save the exported certificate to a

specified location as a PKCS #7 Certificate File (*.p7b).

4. Your options vary depending on the export option you choose:

o If you choose to email the exported certificate, in the Email

Certificate dialog box, type your email address and click Email.

o If you choose to Save the data to a file, name the Certificate file,

specify a location, and then click Save.

Note: (1) the exported Certificates are usually used for verifying signatures and

encrypting documents to limit access to the person who has the

corresponding private key (the digital ID). (2) you can click Certificate Details...

to view the certificate attributes of each digital ID.

Manage trusted identities

A Digital ID consists of the certificate that includes public key and other

content, used to lock or encrypt documents, and the private key used to

unlock or decrypt data. The public key is in a certificate which can be

transferred and used to encrypt documents to prevent unauthorized access.

When you sign, you use the private key to apply your digital signature.

You can get digital ID certificates from other people, signature validation

process as well as certificate-based security workflows to build a list of trusted

identities. During the signature validation process, you verify the identity and
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add it as a trusted root. For certificate-based security workflows, you need to

get certificates in advance for document encryption. Once you receive public

key certificates from others, add them to your list of trusted identities so that

you can encrypt documents for them. You also need the certificates to

validate any PDF file they have digitally signed.

Add trusted contacts

You can import certificates to the list of trusted identities so that they can be

used to implement certificate-based security and signature validation

workflows.

1. In Right PDF, choose Security > Trusted Identities.

2. In the Manage Trusted Identities dialog box, click Add....

3. In the Open dialog box, locate and select the certificate file you already

obtained from a trusted person and then click Open.

Note: you can click Details to view detailed information of a selected

certificate, such as its serial number, the expiration date, fingerprints, and

more.

Export a certificate

You can export a selected certificate and contact data via email or save as a

certificate file so that other users can add the data to their list of trusted

identities.

1. In Right PDF, choose Security > Trusted Identities.

2. In the Manage Trusted Identities dialog box, select a trusted identity

from the list and then click Export.

3. In the Export Data dialog box, determine whether you want to save the

contact data to a file or share it via email and then click Next:

o Email the data to someone. Select to send the Personal X.509

Certification File exported from the selected Digital ID to your

email address. The certification file attached contains a copy of a

certificate that you can use to verify signature and encrypt

documents for the selected digital ID.
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o Save the data to a file. Select to save the exported certificate to a

specified location as a PKCS #7 Certificate File (*.p7b).

4. Your options vary depending on the export option you choose:

o If you choose to email the exported certificate, in the Email

Certificate dialog box, enter an email address for the recipient of

the certificate, review the message, and then click Email. Then,

an email client, such as Outlook or Windows Live Mail, appears

with the public key certificate ready as an attachment. Click

Send.

o If you choose to Save the data to a file, name the Certificate file,

specify a location, and then click Save.

Note: to delete a certificate, select a trusted identity from the list and click

Delete to remove it from the list of trusted identities.

Signing PDFs

Signing a PDF

You can apply different types of signatures based on the intent. There are two

types of signatures you can apply to PDF files, depending on the intent of the

signer and the author. You can have approval signatures, certification

signatures, or both on your document.

 Approval signature. An approval signature is a digital signature which

indicates your approval. You can use digital signatures to sign a PDF file

multiple times and by different persons.

 Certification signature. A certification signature must be the first

signature applied to a document. You can no longer certify the

document once there is an existing certification signature. You can also

restrict the types of changes other people can make to the document.
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Sign a PDF

You can sign a PDF using either a digital signature or a handwritten signature

to indicate your approval. A PDF can be signed with digital signatures multiple

times and by different individuals. Your digital signature appears in the

signature field when you sign a document and the appearance depends on

the options you select through the Configure Signature Appearance dialog of

the Preferences dialog box.

 Sign with an existing digital ID

1. Open a PDF file and choose Security > Sign/Certify > Sign

Document.

2. Drag your pointer to specify an area for the digital signature, or

click an existing digital signature field.

3. In the Sign Document dialog box, select a digital ID from the

Name drop-down menu and type the correct password

associated with the selected digital ID in the Confirm Password

field. You can click Details... to view the detailed certificate

attributes.

4. Click Next.

5. Select the appearance of your signature. To create a new look,

click New and select options as needed.

6. Click Save.

 Sign with a new digital ID

1. Open a PDF file. Choose Security > Sign/Certify > Sign

Document.

2. Drag your pointer to specify an area for the digital signature. Or,

click an existing digital signature field.

3. In the Sign Document dialog box, click Add....

4. In the Add Digital ID dialog box, select Create a Self-Signed

Digital ID and then click Next.

5. Then, in the Add Digital ID dialog box, click Create a Self-signed

Digital ID and click Next.

6. In the Create a Self-signed Digital ID dialog box, type a name,

organization information, email address, and other information

for your digital ID. The name you specify appears in the digital

signature field when you sign or certify a document. As an
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option, if you want to use Unicode values for extended

characters, select Enable Unicode Support and then define

Unicode values in the appropriate boxes. Type a password for

the digital ID file and click OK.

7. Save the Digital ID and in the Sign Document dialog box, type

the correct password associated with the digital ID into the

Confirm Password field and then click Next.

8. Select the appearance of your signature or click New to

configure the signature appearance.Click Sign and save the file.

 Sign with a handwritten signature

You can sign a PDF document by typing, drawing, or importing an

image of your preferred handwritten signature. You can add a new

signature, delete or rename existing ones, set default, or get a preview

in the Manage All Signatures dialog box.

Create a new handwritten signature

Create a new handwritten signature

Open a PDF file or form you want to sign and choose Security > Handwritten

Signature > Manage All Signatures.

 Add: Click the Add icon to add a signature. In the Add a Signature

dialog box, choose a way to create a signature from the drop-down

menu. When finished, enter a name in the Save the signature as field,

and click OK:

o Draw my signature. Draw your signature in the Draw it below

field. The default color is black but you can click the Color

palette to choose the color you want and define the Weight.

o Type my signature. Type your signature in the Type the

signature field. You can further adjust the text attributes.

o Import an image as my signature. Click Browse to locate and

select an image of your signature.

 Delete a signature: select a signature in the list and press Delete to

delete it.
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 Rename a signature: select a signature in the list, click Rename and

type a new name, and click Save.

 Set a signature as default: set the signature you want to use as

default.

Sign with a handwritten signature

1. Set the signature you want to use as default before you actually apply

one to your PDF file.

2. Choose Security > Handwritten Signature > Place a Handwritten

Signature.

3. Drag your pointer to specify an area where the selected handwritten

signature appears and save the file.

Customize the appearance of a certificate-based

signature

You can determine the look of your certificate-based signature by specifying

graphic, text configuration, and text properties. For example, you can make

the information visible and decide whether to include an image of your

handwritten signature or your company logo. You can create looks for

different purposes and select a look for a specified digital ID.

1. Choose Right PDF > Preferences…. Or press Command + K on your

keyboard.

2. In the Preferences dialog box, click Signatures and in the Creation &

Appearance section, click More....

3. In the Creation and Appearance Preferences dialog box, click New.... to

create one or more signature appearances and store them for later use.

Available appearances are listed in the Select drop-down menu under

the Appearance section when you attempt to sign.

o Creation. Decide whether to make it compatible with Adobe

Acrobat and then set the text fields to display when signing. The
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selected fields are displayed in the Sign Document dialog box

when attempting to sign.

o Appearance. Set the graphic options and the text fields to

display in the appearance. Click New... and name the appearance

by adding a title used to identify the appearance.

 And then set graphic options, text fields to display and

text direction in the following sections:

 Configure Graphic. Choose to show nothing, an image, or

the signer's name from the certificate. If you want to

display nothing in your signature, select No graphic;

otherwise, select Imported graphic to show an image in

the appearance. Click File... and browse to a file to be

used as the image and click OK.

 Configure Text. Decide what to display in the appearance:

a. Name. The name associated with the certificate

used to sign it.

b. Location. The location associated with the identity

configured in Right PDF.

c. Distinguishing Name. A name with identifiable

information such as country, organization,

organization unit, and so on.

d. Labels. A label for each of the items above. For

example, Digitally signed by, Location, Date, etc.

e. Date. The date the file is signed. It displays local

computer time.

f. Reason. Reasons for signing.
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g. Logo. Display the logo or graphic on the

background of the signature. The default logo is

the Right PDF logo.

 Text Properties. Choose a direction (Left to right/Right to

left) that is appropriate for the signer's language.

4. Click OK.

Certify Document

You, as the author of the document, certify it to indicate you attest to its

content and can also control the types of changes other people can make

while retaining its certified status. For example, if you want to ensure the

integrity of a completed report, you can certify the document before

distribution, allowing recipients to fill out form fields and add comments only.

Then, whoever receives the reports can do nothing but fill the form and add

comments, or the document loses its certified status.

If there is a certification signature, it must be before all approval signatures. If

there are other signatures in a document, you cannot add a certification

signature. In addition, you can certify document with visible or invisible

signature. As long as the signature is effective, you can see a ribbon icon

in the top left corner and on the Signature panel.

To certify a document:

1. Open a PDF file and choose Security > Sign/Certify > Sign/Certify

Document.

2. Select one of the following as needed:

o Select Certify Document to apply a visible certifying signature.

o Select Certify Document Invisibly to apply an invisible certifying

signature. If you choose this option, your signature appears only

in the Signatures panel with details of allowed actions. (Security

> Signatures Panel).

3. If you are certifying with a visible signature, you can either drag to

create a signature field or place the signature in an existing signature
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field. To place a signature in an existing signature field, right-click on

the field with the Hand tool and select Certify Document.

4. In the Certify Document dialog box, select a digital ID from the Name

drop-down menu or click Add... to create a new digital ID. Then type

the correct password in the Confirm Password field (if required), and

specify the permitted changes others can make from the Allowed

Actions drop-down menu. Click Next.

o Allow no changes. Select this to disable all tools that can be

used to change the document, such as editing, form filling,

commenting, signing, and more.

o Allow form filling only. All tools that can be used to change the

document are unavailable except for form filling. It is helpful

when you want to collect information without getting unwanted

changes.

o Allow comments and form filling. It allows only commenting and

form filling (including digital signature field filling). For example,

other users might need to apply their digital signatures or leave

comments during a document review.

5. Select a desired appearance for the signature and then click Save.

6. Save the PDF using a different file name to avoid signing the original

document.

A visible certifying signature with details including allowed actions and

other details listed in the Signatures panel



186 / 226

Validate digital signatures

Validate digital signatures

You can validate a signature to verify the signer and the signed content when

you receive a signed document. It helps ensure that the signer's certificate

exists in your list of trusted identities and confirm if the signed content has

been modified after it was initially signed. See Set signature verification

preferences.

When the certifying signature is valid, an orange ribbon icon appears at the

upper-left corner of the digital signature field as well as in the Signatures

panel. See View verification details in signatures panel for details. By

configuring verification preferences in the Preferences dialog box, you may

enable automatic validation when the document is opened. See Set signature

verification preferences. for details.

Setting up digital signature validation

Digital signature validation helps you verify the authenticity of the signature's

digital ID certificate status and document integrity. The validity of signatures

depends on whether the signer's certificate exists in the validator's list of

trusted identities (Security > Trusted Identities) and whether the signed

content has already been changed since it was signed. You can configure the

preferences in advance to decide whether signature validation occurs

automatically when the signed document is opened.

Set signature verification preferences

1. Do any of the following to open the Preferences dialog box:

o Press Command + K on your keyboard.

o Choose Right PDF > Preferences….
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2. Under the categories, select Signatures on the left. Under Verification,

click More... and in the Signature Verification dialog box, check Verify

signatures when the document is opened to enable automatically

validating all signatures in a PDF document when it is opened. Select

the following options as needed and then click OK:

Verification Behavior.

o When Verifying. This allows you to choose a method to use for

verifying signatures.

o Require certificate revocation checking to succeed whenever

possible during signature verification. This checks certificates

against a list of excluded certificates during validation. If this

option is deselected, the revocation status for approval signature

is ignored. This option is selected by default.

Verification Time.

o Verify Signature Using. Decide how to check the digital signature

for validity. Time at which the signature was created is selected

by default, meaning you can check the time based on when the

signature was created. You can also choose to check based on

the current time or the time set by a timestamp server when the

document was signed.

o Use expired timestamps. It allows using the secure time provided

by the timestamp or embedded in the signature even though

the signature's certificate has already expired.

macOS Integration

o Specify whether to trust all root certificates in the Windows

Certificate Store when validating signatures or certified

documents. Note that selecting either of these options may

result in arbitrary material being treated as trusted content. We

suggest you don't trust all root certificates since some of the

certificates from the Windows Certificate Store were not

designed to be used for building trusted identities.
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View verification details in signatures panel

The Signatures panel shows information about every single digital signature in

the current PDF document as well as the change history of the document.

Each digital signature has an icon representing its validation status in the

Signatures panel. You can expand each signature to check its detailed

verification information.

Verification details listed in the Signatures panel

To open the Signatures panel, choose Security > Signatures panel or click on

the Signatures panel icon in the Sidebar Navigation pane. In the Signatures

panel, do the following to get more information about verification:

 Click Click to view this version to view the version of the document

signed by the selected signature.

 View the time the document was signed, the signing method, the

validation status, and the name.

 Right-click a signature to do the following tasks: verify the signature,

clear the signature field, view the signed version, and compare the

signed version to the current version.

 Click on the signature to jump to its location in the document. A dotted

line appears around the selected signature.

Status icons for PDF documents

Do any of the following to view the validity status and other verification

details of the signature:
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 Using the Hand tool, click on the signature field on the page to display

the Validation Status dialog which shows signature validity and other

verification details.

 Using either the Hand tool or Select tool, right-click on the signature

field and select Properties.....

 The Signatures panel displays signature validation status and other

verification details. You can click the Click to view this version link to

open versions of signed documents.

Validation

Status
Icon Meaning

Valid
The document is certified and the document has not

changed in a way not permitted by the certificate.

Valid

The identity of the signer was successfully verified as a

trusted identity, and the document hasn't been changed

since this signature was added.

Valid

The identity of the signer was successfully verified. The

revision of the document covered by this signature has

not been altered, but there have been subsequent

changes to the document. The current view of the

document is not the same as when it was signed.

Invalid

The signature has been corrupted. The revision of the

document covered by this signature has not been

modified, but there have been subsequent changes to the

document.
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Validity

Unknown

The identity of the signer was not yet able to be verified.

The revision of the document that was covered by this

signature has not been modified, but there have been

subsequent changes to the document. The current view

of the document is not the same as when it was signed.

Validity

Unknown

The identity of the signer was not able to be verified. The

revision of the document that was covered by this

signature has not been verified, but there have been

subsequent changes to the document.

Validate a digital signature

By configuring digital signatures validation preferences, you can enable

validating signatures automatically when the document is opened. See Status

icons for PDF documents for details. You may also manually validate the

signature if it is unverified or of unknown origin. If the signature status shows

validity unknown, you need to contact the signer about the problem.

1. Open a PDF document that contains a signature.

2. The signature validation occurs automatically if you have already

enabled verifying the signature at startup. Otherwise, do the following

to manually verify signatures:

o Click on the signature field to validate the signature.

o Right-click on the signature field and select Verify Signature.

o Right-click on the signature you intend to validate in the

Signatures panel and select Verify Signature from the menu.

3. The Validation Status dialog box appears, describing the validity of the

signature. For more information about the signature, right-click on it

and select Properties....

4. Check the signed versions of the document if the document has been

modified after the signature was applied. Also, you may compare the

signed version to the current version of the document to see the
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differences between the two versions. See View previous versions of a

digitally-signed document for details.

Configure Directory Servers

Directory Servers can be used to search for contact information and

certificates when managing your list of Trusted Certificates and when

encrypting documents using Certificate Security. You can configure a public

directory server or obtain configuration information from your computer

administrator for directory servers within your organization.

1. Open a PDF document and select Security > Manage Digital IDs.

2. In the Security Settings dialog box, select Directory Servers from the

panel to the left. Then click on Add ... to create and set up a Directory

Server, or directly select one from the list and click on Edit to view and

change settings.

3. In the Edit Directory Server dialog box, edit the name the directory and

server settings. If required, check the This server requires a log on

option and enter a username and a password. Click OK.

Timestamp a document

By default, a digital signature contains a date and time. The digitally-

authorized time stamp indicates the contents of the document existed at that

time and have not been changed since then. You can configure a new time

stamp authority and add it to the list of time stamp servers. The time stamp

will show on the Date/Time tab in the Signature Properties dialog box.

Otherwise, the current date and time of your computer will be used instead.

Set up time stamp servers

1. Open a PDF and choose Security > Manage Digital IDs.
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2. In the Security Settings dialog box, select Time Stamp Server in the left-

side window and then click Add....

3. In the Add Time Stamp Server dialog box, name the time stamp

authority and enter its URL. Check The server requires you to log in if

needed and then enter the user name and password. Click OK.

Add a document timestamp

1. Open a PDF you want to add a timestamp to and choose Security >

Sign/Certify > Time Stamp Document.

2. In the Time Stamp Service dialog box, select an existing time stamp

service from the list and click Next. If there isn't any existing one, click

Add to add a new time stamp server.

3. In the Save as dialog box, choose a location to save the document with

the timestamp and click Save.

Versions of the signed document

Each time you sign a PDF document using a certificate, the signed version of

the document is saved with the PDF. You can access the signed version via the

link in the Signatures panel or in the Signature Properties dialog box. The

selected signed version of the document then opens in a new PDF document.

You can also compare the selected signed version with the current version. It

marks the differences for you and generates a summary of comparison results

in a new PDF document.

View previous versions of a digitally-signed document

1. Open a signed document with multiple digital signatures.

2. Do any of the following to view signed versions:

o In the Signatures panel, expand the signature and click Click to

view this version (B) to view its signed version. Or, you can click

on the signature, and select View Signed Version from

Signatures Panel Option menu.
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o Right-click on the signature and select View Signed Version from

the menu.

o Right-click on the signature field and select Properties.... In the

Signature Properties dialog box, click the General tab and click

View Version (A) in the Document Versioning section.

Compare the previous signed version to the current version

You can view what changes have been made after the selected signature was

applied to the document. It marks all differences between the current version

and the signed version of the document covered by the selected signature.

1. Open a PDF file.

2. Choose Security > Signatures panel.

3. In the Signatures panel, right-click the signature used to compare to

the current version of the document and select Compare Signed

Version to Current Version.

4. A page-by-page comparison opens in a new PDF document.
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Compare the previous signed version (Right) to the current version (Left).

Send PDF documents with secure

delivery

Security is always a concern when you need to send sensitive files to the

recipients on the outside. Secure Delivery is a convenient wizard which helps

protect a set of files to be delivered with passwords or signatures sending

them out via email. Both PDF and non-PDF files can be protected using secure

delivery.

1. Open a PDF and choose Security > Secure Delivery .

2. In the Secure Delivery dialog box, go through the following four steps:

o Select Envelope. Click to open the Envelope panel. Double-

click the desired envelope or right-click and choose Apply to

open it. You can use Add Text to add extra information onto the

selected envelope.

o Add Attachments. Click to add file attachments. In the dialog

box, individually select one or multiple files and then click Open.

All the selected files (both PDF files and non-PDF files) are

displayed in the Attachments panel to the left in the envelope

file. You can also attach a PDF portfolio that contains a collection

of files.
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o Encrypt Files. Click to open the Security To apply the security

scheme, directly click-drag an appropriate one to the document

pane, or right-click and choose Apply Security Scheme. If there

is no a security scheme yet that can be used, create one and

apply it to the file.

o Sign Document. Click to open the Sign/Certify panel, and

select an appropriate signature scheme from Sign Document.

Remember to save the document in order to apply the digital

signature. If there is no a signature scheme yet, create one and

then apply it to the file.

3. Click Send when the document is ready. Your default email application

opens with the envelope file attached to a new message that contains

instructions of accessing the secured attachment. Then, fill in the

required fields, such as recipients and subjects, and click Send.

Envelope panel

The Envelope panel displays all envelopes available for secure deliveries via

email. All types of envelopes are single-page PDF files with interactive form

fields in which you can enter information related to the email package. You

can also create a custom envelope template for secure deliveries.

Creating custom envelopes

You can create custom envelope templates that store specified security and

signature schemes, and are displayed with the appearance you specify. First

you need to prepare a PDF file to be used as an envelope. Then, you can add

interactive form fields in which you can type information each time you apply

the envelope. Alternatively, you can use the Add Text tool to do this as well.

1. Do any of the following to open the Envelope panel:

o Choose Security > Envelop

o Click the Envelope icon in the navigation sidebar
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2. In the Envelope panel, do one of the following:

o Click Create .

o Right-click anywhere on the Envelope panel and

select Create from the menu.

o Click Options and select Create from the menu.

3. In the Create Envelope dialog box, give the envelope a name and then

click Browse… to navigate to the PDF file intended to be used as the

envelope. You can see how the envelope looks in the Preview area.

4. In the Properties section, select a Security Scheme and a Signature

Scheme from their respective drop-down menu and then click OK.

Use Options to manage envelopes

Apply. Choose this to open the selected envelope. Do any of the following:

 Double-click an envelope.

 Right-click on it and choose Apply from the menu.

 Select an envelope, click Options and then choose Apply from the

menu.

Edit. Choose this to make changes to the selected envelope in the Create

Envelope dialog box. Do the following:

 Right-click an envelope and choose Edit from the menu.

 Select an envelope, click Options and then choose Edit from the menu.

Reduce/Enlarge Envelope Thumbnails. Choose to fit the thumbnail sizes for

the panel.

Reset Envelope. Choose to restore the default envelopes by either replacing

the current envelopes or appending system default envelopes to the current

envelopes.
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Removing sensitive data from PDFs

Removing sensitive data from PDFs

Before distributing documents, it’s considerate to redact certain document

contents to avoid possible legal consequences of exposing such sensitive

information. The redaction tool lets you permanently black out a specified

area or certain text, such as name, dates, or numbers, or images. You may

further use the Search and Redact tool to search and remove specified words

or phrases in one or multiple PDF documents.

The text or images you mark for redaction, by default, are outlined with red

lines and will be blacked out when the cursor moves over the redacted areas.

To change the default look of the redaction marks, you can change the

settings in the Redaction properties dialog box before you use the tool.

Optionally, you may set redaction code to overprint an overlay text on the

redacted area. Then you use Apply Redaction to permanently make all

redacted contents unreadable. Since this command cannot be undone, make

sure you save a copy of the document in case you need to access the original

content of the document.

In addition, Whiteout can be used to remove contents permanently and

backfill it with the color white.

If you do not want others to learn certain information when they receive the

file, you can use the Inspect Document tool to permanently remove the

selected types of contents from a PDF document or hidden content.

Redact sensitive content

Mark for redaction

Redaction tools are able to remove visible sensitive contents from a PDF file.
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1. Choose Security > Mark Redaction. The pointer changes into I-beam

over text and cross over images.

2. Do any of the following to mark redaction:

o To mark text for redaction

 With the I-beam pointer, click-drag to mark the words to

remove.

 Double-click to mark a single word.

 With the cross pointer, click-drag to mark a rectangle area

that includes the content you want to remove from the

PDF file.

o To mark an image for redaction

 With the cross pointer, double-click on an image to mark

an entire image for redaction.

 With the cross pointer, click-drag to mark a rectangle area

that covers the entire image or just a part of it.

3. To permanently remove all marked content, choose Security > Apply

Redaction.

4. At the prompt, check Apply marks visually only, preserving marked

content to black out only the marked text, without erasing the marked

content. Click Apply.

Note: after redaction is applied, all marked contents will be permanently

removed and the operations cannot be undone.

Search and remove text

The Search and Redact tool searches multiple documents that contain

searchable text for certain keywords or phrases and marks the matched results

for redaction.

1. Open a PDF file that contains searchable text.

2. Choose Security > Search and Redact.

3. In the Search dialog box, specify whether you want to search the

current document, portfolio, or all documents in another folder.

4. Next, select one of the following from the Search For options to define

the scope.
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o Select Single word or phrase to search for only one word or

phrase. Type the word or phrase in the What word or phrase

would you like to search for text field and then click Search and

Redact.

o Select Multiple words or phrase to search for multiple words and

then click Select Words.... In the Words and Phrases to Search

dialog box, do any of the following to add the words or phrases

to the Word and phrase list box and then click OK. Enter each

word in the New word or phrase text field and then click Add. Or

click import... to import a text file that contains a list of words or

phrases.

o Select Patterns to search for a pattern, such as SSN, phone

numbers, credit card numbers, email address, and date. Select

one from the drop-down menu and then click Search and

Redact.

o Select Arbitrary mask to change the format category to custom

and make another text field available, in which you can type a

custom format.

5. Click Search and Redact.

6. All occurrences are listed in the search results dialog. If you search

documents in a specified folder, you can click the plus sign next to each

document name to see all occurrences within each document. Then do

any of the following to select the occurrences you want to mark for

redaction and click Mark Selected Results for Redaction.

o Individually check the box for each occurrence you want to mark

for redaction. You can click the text next to the checkbox to view

the occurrence on the page.

o Click Select All to select all occurrences in the list.

o Click New Search to start over.

7. The selected items are shown marked for redaction in the PDF file they

belong to. If you search documents in a specified folder, you will enter

the Output Options dialog box, in which you can set the destination

folder, file naming and output format options, enabling you to keep the

original files redaction-free.

8. To permanently remove the selected items, choose Security > Apply

Redaction and then click Apply and OK. The items are not permanently

removed from the document until you save it.
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9. Choose File > Save and specify a file name and location. If you do not

want to overwrite the original file, give it a new name, location, or both

and then click Save.

Whiteout

The Whiteout tool is like an eraser that can wipe out contents quickly and

permanently, leaving only blank white behind.

1. Choose Security > Whiteout .

2. A pop-up dialog box will show. Click Yes to proceed. The pointer

changes into cross.

Click-drag to mark a rectangle area that includes the content you want to

erase from the PDF file. The whiteout effect will be applied immediately and

cannot be restored by the Undo function. Don’t save the document if you

have applied whiteout by mistake.

Change the look of the redaction marks

Open a PDF file and choose Security > Redaction Tool Properties to set the

default look of all marks before applying redactions.

In the Redaction Tool Properties dialog box, on the Display tab, select the

options you want to change and then click OK:

1. To change the color of the marks that cover the redacted contents,

click the Mark Color colored square and then select a predefined color

from the color palette.

2. (Optional) Select Use Overlay Text to overprint custom text or redaction

code on the redacted items.

o Font: click Edit... to edit font, size, color, and alignment, and

determine whether to auto-size text to fit redaction area in the

Font Editor dialog.

o Repeat Overlay Text: select Repeat Overlay Text to fill the

redacted area with as many instances of the custom text as

possible.
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o Custom Text: select Custom Text and then specify the text to

appear in the redacted area.

o Redaction Code: select Redaction Code to overprint a type of

code entry on redacted areas from a collection of entries called

code set.

 Use default code sets and code entries: Right PDF

provides two predefined code sets, U.S. FOIA and U.S.

Privacy Act you can use. Each code set has a collection of

code entries you can choose one from.

 Custom code sets and code entries: click Edit… to show

the Redaction Code Editor dialog box, in which you can

add, rename, delete code sets and code entries, and

import or export a code set (.xml).

Inspect Document

The Inspect Document tool permanently removes the specified contents from

the document, including hidden data, bookmarks, comments, attachments,

deleted content, destinations, embedded thumbnails, form fields and actions,

JavaScript, links, and metadata. To keep the original copy of the document,

click Save As and specify a new name.

Note: you can determine whether to use the Inspect Document tool before

you close or email a PDF using the Preferences dialog box (choose Right PDF>

Preferences… > Document > Inspect Document.)

To permanently remove certain contents from a PDF

1. Open a PDF file and choose Security > Inspect Document to open the

Inspect Document dialog box.

2. In the Inspect Document dialog box, select the items you want to

remove from the document:

o Bookmarks. Select to remove all bookmarks serving as links that

lead you to specific pages in the PDF document. Choose

Document > Bookmarks to open the Bookmarks panel.
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o Comments. Select to remove all comments added to the PDF

document using markup tools, drawing tools, and basic tools

such as text box, typewriter, and more. Click on the Comments

icon on the Sidebar Navigation pane to open the Comment

panel that displays all comments added to the document.

o Document Attachments. Select to remove all files attached to

the document. Click on the Attachments icon on the Sidebar

Navigation pane to open the Attachments panel and view all

attachments added to the document.

o Deleted content. PDFs sometimes retain deleted pages or

images that are no longer visible in a document. Select this

option to permanently remove content that has already been

deleted.

o Destinations. A destination is a link to a certain location in the

same or another document, represented by text in the

Destinations panel. Select to remove all destinations from the

document.

o Embedded thumbnails. Select to remove embedded page

thumbnails from the document.

o Form fields and actions. This item includes all form fields and

any other actions associated with form fields. Select to make all

form fields within the PDF flattened, meaning they can no longer

be filled out, edited, or signed.

o All JavaScripts. JavaScripts are interactive components that lead

to commands or actions under specific conditions. Select to

remove all JavaScripts throughout the document.

o Links. Select to remove all links associated with any actions from

the document.

o Metadata. Metadata includes information about the document,

such as author, keywords, date created and modified, and more.

You can access it by choosing File > Properties or pressing

Command + K on your keyboard. All information except for file

name is removed if you use the Inspect Document tool to

remove metadata from the document.

o Embedded non-display data. Select to remove invisible content

visually blocked by other items, for example, removing invisible

embedded text underneath an image.
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3. Click Remove to remove the selected items from the document and

then click OK.

4. You have to save the document to make the changes permanent. If you

do not want to overwrite the original file, give it a new name, location,

or both and then click Save.

Note: make sure to save the document to put the changes in effect.

Select the items to permanently remove corresponding information.
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Chapter 10: Saving and exporting

PDFs

 Save a PDF file

 Export PDFs to other formats

 Reduce PDF file size

 Flatten documents
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Save a PDF file

It is so important to save PDF files and retain all contents you add. You have

to frequently save the PDF document to prevent losing any changes. You can

choose to save the changes to the original document instead of creating a

new file or a new version that contains all changes you have made.

Save the original PDF document or Save As a new copy

Save is used to store any modifications you made to the original document

without creating a new copy, while Save as creates a new copy that contains

any modifications made to the original document. You can choose to save the

file using either Save or Save As when saving a newly-created PDF for the first

time. Both of them open the Save As dialog box. On the other hand, you can

save a new version of an existing document under a new name, creating a new

file that includes any changes you have made to the original document. This

way, you save the changes to the new file while keeping the original

unchanged.

1. Open or create a PDF file and start making any changes to it.

2. Do any of the following to save the PDF document:

o On the Quick Access Toolbar, click Save.

o Press Command + S, or Shift + Command + S on your keyboard

to save the file.

o Choose File > Save.

o Choose File > Save As. Decide where to save the file. In the Save

As dialog box, rename it to avoid overwriting the original one

and then click Save.

Save the PDF document to 3rd party cloud storage services

Right PDF enables you to save PDF documents to 3rd party cloud storage

services, such as Dropbox, OneDrive and Google Drive. You can access the

files through their own web interface or within Right PDF.

1. Open or create a PDF document.
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2. Choose File > Save as.

3. In the Save as dialog box, choose an account t under Location and click

Save. To add a new account, click Add Location.

Export PDFs to other formats

Using either Save As or the Export function in Right PDF, you are able to

export the currently open PDF document to Text, Word, Excel, PowerPoint,

and other image formats.

Export using Save As command

1. Open a PDF file and choose File > Save As. Choose My Computer >

Save in Recent Folder…, and select a recent folder or click Choose

Other…. If you want to save it to a cloud storage service, add an

account and choose it.

2. In the Save As dialog box, select a file format from the Save as type

drop-down menu. Click Settings to change format-specific conversion

settings and then click OK to apply the settings.

3. Click Save to export the PDF file to the selected file format.

Export using Export functionality

1. Open a PDF file and select File > Export.

2. Select the file format and version for the output file.

o Export to MS Office. You can choose to export PDF to Word

(.doc/.docx), Excel (.xls/.xlsx), or PowerPoint.

o Export to Image. Select to export the PDF file to one of the four

image formats. Each page of the PDF document will be saved as

a separate file.

Note: when exporting a multi-page document with multiple

pictures, select the "Pictures", "Downloads", "Music" and
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"Movies" folders; other folders do not support storing multiple

pictures.

o Export to Text . Select to export the PDF file to text in either

Simple (*.txt) or Unicode (*.txt) encoding.

3. In the Save As dialog box, select a location where you want to save the

file.

4. Click "Settings" and adjust the conversion settings in the pop-up dialog

box, and click "OK". See Conversion settings for details.

5. Click Save to convert.

Advanced Conversion settings

Before you click the start converting button, you may go to Convert Settings

to change settings related to the output format.

Image settings

In the JPEG/JPEG2000/PNG/TIFF Settings dialog box, set up File Settings and

Compression Settings and then click OK, or you can click Default to restore

default settings:

 JPEG and JPEG 2000

a. File Settings. Specify a color space and resolution for the output file.

You can select Determine Automatically to let Right PDF automatically

determine these settings for you.

o Colorspace. Specify the type of color management applied to

the output file. To convert color images in the file to shades of

gray, choose Grayscale.

o Resolution. Specify the resolution for the output file.

b. Compression Settings. From Grayscale and Color, specify

compression settings that balance file size with image quality. The

smaller the file, the lesser the image quality.

 PNG
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a. File Settings. Specify a color space and resolution for the output file.

You can select Determine Automatically to let Right PDF automatically

determine these settings for you.

o Colorspace. Specify the type of color management applied to

the output file. To convert color images in the file to shades of

gray, choose Grayscale.

o Resolution. Specify the resolution for the output file.

b. Compression Settings. Configure compression settings using the

Interlace and Filter menus.

o Interlace. Specify if the image is interlaced. If you select None, an

image displays in a web browser only when downloading is

complete. The other option, Adam7, creates an image that

displays low-resolution versions in a browser while the full image

is still downloading. Adam7 seems to shorten the download time

yet it increases file size.

o Filter. It lets you select a filtering algorithm.

 None. Compress the image without a filter.

 Sub. Optimize the compression of images with even

horizontal patterns or blends.

 Up. Optimize the compression of images with even

vertical patterns.

 Average. Optimize the compression of low-level noise by

averaging the color values of adjacent pixels.

 Paeth. Optimize the compression of low-level noise by

reassigning adjacent color values.

 TIFF

a. File Settings. Specify a color space and resolution for the output file.

You can select Determine Automatically to let Right PDF automatically

determine these settings for you.

o Colorspace. Select the type of color management applied to the

output file among RGB, CMYK, Grayscale, or Monochrome. To

convert color images in the file to shades of gray, choose

Grayscale.
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o Resolution. Specify the resolution for the output file.

b. Compression Settings. Configure the compression settings using the

Monochrome, Grayscale and Color settings.

Word settings

In the Doc/Docx Settings dialog box, select options as needed and then click

OK or click Default to restore options to default settings:

 Image Settings

o Convert Images. It converts images within the file to a specific

image type.

o Clip Images so they look the same as in PDF. Convert files

without changing the position of each image.

 Path Settings

o Convert path objects to Drawing Objects. Check this box to

convert path objects (e.g. Clip Art images) to corresponding

image objects.

o Group huge numbers of path objects together and convert to

images to reduce file size. To reduce files size, check this box to

group huge numbers of path objects together and convert those

to images.

 Font Settings

o Use similar fonts to replace fonts not installed on your system.

Check this box to allow Converter to replace fonts not installed

in your system with other similar fonts.

 Layout Settings

o Identify Tables In PDF. Check this box to ensure the tables in the

PDF file will also show up in Word.

o Use Textboxes to keep layout consistent. Inaccuracies may occur

during the conversion process. Check this box to let Converter

create text boxes for you to keep all the words and images in the

intended places in Word.

o Identify Paragraphs In PDF. Check this box to ensure paragraphs

in PDF files will also show up in Word.
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o Apply vertical text flow to all texts regardless of vertical font in

the document. Check this box to apply vertical text flow to all

text in Word.

Excel settings

In the Excel Settings dialog box, select options as needed and then click OK, or

you can click Default to restore options to default settings:

 Page Handling

o Convert all pages on a sheet. Convert all pages and merge them

into one Excel worksheet.

o Split each page on a sheet. Convert each PDF page into separate

Excel worksheet.

 Image Settings

o Convert without images. If you check this box, images in the PDF

file will not be converted into the Excel document.

o Turn white background transparent. Convert images with white

background made transparent.

 Border

o Split sparse cell. Check this box to keep sparse text in the same

format as in a PDF file. If this box is not checked, words in cells

may be misaligned based on settings, such as aligning to top,

center, left, right, and bottom.

 Try building border-less table. Check to better recognize

tables with no borders in PDF.

Export images from PDF

Besides exporting every page to an image format, you can also extract images

from a PDF document and save them as separate image files.

1. Open a PDF file that contains images.

2. Do either of the following:

o Use the Select tool to click on the image and on the toolbar that

pops up, select Save all image(s) to file(s)....
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o To export a part of an image, using the Select tool, hover the

cursor over the image and the cross-hair icon appears. Drag

an area, right-click on it, and select Save Image As... from the

options.

3. In the Save As dialog box, select an image type and a location to save

the file. Click Save.

Types of image formats to choose from for export

Reduce PDF file size

Right PDF provides various ways for you to reduce the size of PDF files. You

can choose to remove unwanted data from a PDF file or shrink the images the

file contains.
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Using the slider bar in the Reduce File Size dialog box, you can choose a predefined

size/quality ratio.

1. Open a PDF document and choose Advanced > Reduce File Size.

2. Reduce File Size provides five predefined ratios you can choose from to

decide the most ideal outcome. If you choose to go for higher

compression, you get smaller file size with less image quality, whereas

you can use lower compression for higher image quality.

o Level 100 (least compression, highest quality)

o Level 75

o Level 50 (the default ratio, Medium compression, medium

quality)

o Level 25

o Level 0

3. Specify where to save the result file and name it, then click Save.

4. To apply the ratio to multiple documents, click Apply to multiple, add

the files you want to compress and then click OK:

o Click Add Files... to add multiple files to the list. Select one or

more files and then click Open. Click Add Open Files... to add

currently open files to the list. Command-click to select multiple

files and then click Add Files.

o In the Output Options dialog box, follow the on-screen

instructions to specify Target Folder and File Naming for the

output files as needed and then click OK.

Note: the slider bar affects only images within a document.
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Flatten documents

The Flatten feature merges interactive forms and any other comments in a

PDF document. It is especially useful at the end of a review because you can

be assured the information would not be edited, moved, or deleted by others.

Note: flattening cannot be undone and all the undo operations are removed.

Upon flatting, annotations and other items are removed from the panels they

used to be displayed in and fused with the document so that no one will be

able to select or modify them.

1. Open a PDF file and choose Advanced > Flatten.

2. In the Flatten dialog box, select the types of annotation and other items

you wish to flatten and click OK:

o Draw. It indicates the annotations placed by drawing tools. Once

the document is flattened, all the drawing objects are removed

from the Comment panel and can no longer be selected or

modified.

o Attach. All the attachments in the document are displayed in the

Comment panel. Once the document is flattened, they are

removed from the Comment panel and can no longer be

opened. Meanwhile, the file attachment icons remain at where

they were but lose their availability. Note that files attached by

Document > Attachments are not affected.

o Textbox. All textbox annotations created by the Text Box tool are

displayed in the Comment panel. Once the document is

flattened, they are removed from the Comment panel and can

no longer be modified, resized, or moved. The text previously

entered in the textbox can still be read but cannot be edited.

o Note. Notes placed by the Note tool are displayed in the

Comment panel. Once the document is flattened, they are

removed from the Comment panel and can no longer be

opened and edited. The sticky note icons remain at where they

were but lose their availability.

o Stamp. Stamps are placed by the Stamps tool and can be moved

and resized with the Select tool. All stamps in the document are
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displayed in the Comment panel. Once the document is

flattened, they are removed from the Comment panel. The

stamps remain visible but can no longer be modified or moved.

o Layer. Layers are created in Layer panel. Once the document is

flattened, all layers are transformed as document objects and

merged into the document. In the Layers panel, you can also

choose Options > Merge Layers to flatten only layers.

o Text Markup. Once the document is flattened, highlights, cross-

out, underline and other text markups remain visible but can no

longer be deleted or selected.

o Form. All form fields are no longer interactive.

o 3D. All 3D models created by Multimedia are shown in

document pane and displayed in the Model Tree panel. After

you add a 3D object, click on it or right-click and choose

Activate 3D with the Hand tool to activate it. However, once the

document is flattened, they are removed from the Model Tree

panel. The 3D objects remain visible but can no longer be

activated and edited.

o Movie. Movie clips are placed by Multimedia. Once the

document is flattened, all movie clips in your document cannot

be run or edited anymore.

o Redaction. Flattening the file preserves the completed redaction

(redacted content is permanently removed), while the content

only marked for redaction remains viable and searchable.
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Chapter 11: Searching and indexing

 Searching PDFs

 Indexing PDFs
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Searching PDFs

Find text in PDFs

Right PDF provides a powerful search engine that helps you run fast and

effective searches. You can search the currently open document, documents in

an external folder, Portfolio documents and any location on your hard drive.

To incrementally speed up searching large numbers of related PDF

documents, define a catalog of PDFs to create a full-text index and then

choose to search the PDF index instead of the documents themselves.

Find text in PDFs

Find text in the currently open PDF

The Find feature searches the currently open PDF document and enables

searching bookmarks labels and comment text.

1. Open a PDF file and do either of the following to call out the Find

window:

o Choose Basic > Find.

o On Menu Bar, Choose Edit > Find.

o Press Command + F on your keyboard.
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The Find window: A. Find field B. Find Previous C. Find Next

2. In the Find window, enter the text you would like to search for in the

Find box.

3. Select the options listed below if needed:

o In the Find window, enter the text you would like to search for in

the Find box and then select the options listed below if needed:

o Match whole word only. It finds only the instances that match the

complete word you type in the text box. For example, if you search

for background, the word backgrounds will not be included in the

results.

o Include Bookmarks. Select to allow searching the text in the

Bookmark panel and also the document.

o Include Comments. Select to allow searching the text of any

comments and also the document. If you would like to search

comments only, open the Comments panel and click the Search

comments button. Type in the text you want to search for and click

Search Comments.

4. Press Return on your keyboard to go to the first instance of the search

term.

5. Press Return again to jump to the next instance. You can use the

Previous and Next buttons to go back to the previous instance or the

next instance at will.
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Find text in multiple PDFs

You can look for search terms across multiple PDF documents in the Search

window. The search engine can let you search the current document, across all

PDFs in a specified folder, or all files in an open PDF Portfolio.

1. Open a PDF file and do either of the following to call out the Search

window:

o Choose Basic > Search.

o On Menu Bar, choose Edit > Search.

o Press Command + Shift + F on your keyboard.

2. In the Search window, select the following options:

o Look in: restrict the search to the current PDF document,

selected Portfolio documents, the entire PDF Portfolio, an index,

or a location on your computer. If you choose to search an

external folder or indexes, click on Advanced and specify the

Additional Criteria that follows.

 If you choose to search External Folder, specify a folder to

look into from the Specify a folder drop-down menu.

 If you choose to search Currently Selected Indexes, you

must have selected indexes files in Index Manager.

Otherwise, you have to select Select Index... to add Index

files (*.zpi).

Note: you can only add index files from the "Pictures",

"Downloads", "Music" and "Videos" folders.

o What word or phrase would you like to search for?

 Single word or phrase. Enter the word or phrase you

would like to search for and define its searching options:

 Match Case. It searches for the entire string of

characters that matches the capitalization you type

in the text box. For example, if you search for Each

of, only Each of will be included in the results and

Each Of or Each OF are not included in the results.

 Match whole word only. It searches for the entire

string of characters, including spaces, in the same

order in which they appear in the text box. For
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example, if you search for Each of, then Each Of,

Each OF, and Each of are included in the results.

You can check this option to filter out other words

that contain the letter combination of the word

you specify in the text box. For example, if you are

searching for all and would like to filter out other

words like small or usually, check this option to

refine the results.

 Include Comments. It also searches the text of any

comments added to the PDF.

 Include Bookmarks. It also searches the text of any

bookmarks.

 Include Subfolders. It also searches subfolders of

the specified folder or computer disk. This option

is available only when you look in a specified

folder.

 Stemming. Find words that contain part (the stem)

of the keyword. For example, a search for control

will find instances of controlling, controls, and

controlled.

 Multiple words or phrase. You can search for more than

one words or phrases. Click Select Words... and add new

words or phrases. In the Words and Phrases to Search

dialog box, type the word or phrase to search for in the

New word or phrase field and click Add to add it to the

Word and phrase list box below. You can repeat the steps

to add more. At the bottom there are checkboxes which

serves to refine your search results. Click OK to finish.

 Select a type of information you would like to search for

from the drop-down menu. Click Search.

 Arbitrary mask. It changes the format category to custom

and makes another text field available, in which you can

type a custom format. Use this option to specify which

types of characters the user can enter in any given

position, and how the data displays in the field.

 A accepts only letters (A-Z. a-z).
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 X accepts spaces and most printable characters,

including all characters available on a standard

keyboard and ANSI characters in the ranges of 32-

126 and 128-255.

 O. The letter "O" accepts alphanumeric characters

(A-Z. a-z, and 0-9)

 9 accepts only numeric characters (0-9).

For example, a mask setting of AAA--p#999

accepts the input BOE--p#767.

3. Click Search to display a list of results in page order.

Review PDF search results

You will have a list of results displaying any instance that matches the search

criteria you set. The results are listed in page order with the search term

highlighted in blue. The total number of words found appears at the bottom-

right corner.

View a specific instance in the search results

You can directly view an instance in the PDF by clicking it in the search results.

1. The search results appear after you run a search in the Search window.

Click an instance in the list of results and jump to the place in the PDF

document where the instance appears.

2. You can then click another instance in the results to view it in the PDF

document.

Search index files of cataloged PDFs

You can speed up the search by searching the index of a catalog of PDFs

rather than running a full-text search of each individual PDF document in the

catalog.
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1. Open a PDF file and choose Basic > Search, or press Command + Shift

+ F on your keyboard.

2. In the Search window, select Select Index... from the Look In drop-down

menu.

3. In the Index Manager dialog box, select an index from the list, or click

Add and locate an index file (.zpi).

4. Repeat as needed and then click OK. The path of the selected index is

displayed in the setting box beneath the Look In field in which

Currently Selected Indexes is automatically chosen.

5. Enter in words you search for and proceed with your search as usual.

6. Click >>Advanced to adjust advanced search options and then click

Search.

Advanced search options

 Match

o Match exact word or phrase. It searches for the entire string of

characters, including spaces, in the same order in which they

appear in the text box.

o Match any of the words. It searches for any instances that

contain at least one of the words typed. For example, if you

search for at all, the words at, all, at all, and all at, are included in

the results.

o Match all of the words. It searches for any instances that contain

all the words you type but not necessarily in the order you type.

o Boolean query. It searches using the Boolean operators that you

type with the search word into the What word or phrase would

you like to search for text field. For more information,

see Boolean operators.

 Additional Criteria You can restrict results to certain keys by setting

additional criteria for searching multiple documents. Additional criteria

appear only when you search multiple PDF files or indexes.

o Key. Select a field type to be a criterion. Click [New Criteria] to

show the down-pointing arrow next to it and then select a field

type from the drop-down menu. Repeat the steps to add more if

needed.
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o Operation. Select an operation for the key you selected. If

Modified/Created Date option is selected for Key, then the

available options will be "Is Before", "Equal To", "Not Equal To",

and "Is After". Otherwise, they are "Includes" and "Excludes".

o Value. Click inside the field and then enter a value. If you select

either Modified Date or Created Date for Key, choose a date

from the expanded calendar.

Boolean operators

Use the following Boolean operators to either narrow or broaden your set of

results.

 AND: Use AND between two words to find documents that contain

both terms. For example, type New York AND Philadelphia. All

documents that contain both words will be found.

 NOT: Use NOT before a search term to exclude any documents that

contain that term. For example, type NOT New York. All documents

that do not contain the word New York will be found. Or, type New

York NOT Philadelphia to find all documents that contain the word

New York but not the word Philadelphia.

 OR: Use OR to search for all instances of either term you enter. For

example, type beside OR besides to fine all documents with

occurrences of either word.

 ^: Use ^ (exclusive OR) to search for all instances that contain either

term, but not both. For example, type day ^ night and all documents

that contain either day or night will be found but not both day and

night.

 ( ): Use ( ) to specify the order of evaluation of terms. For example, type

yellow & (beans | tails) and all documents containing either yellow and

beans or yellow and tails will be found. The query processor performs

an OR query on beans and tails, and then performs an AND query on

those results with yellow.
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Operator Symbol Examples Diagram

AND &
A & B

A AND B

OR |
A | B

A OR B

EXCLUSIVE OR ^
A ^ B

A EXCLUSIVE OR B

NOT (Single) ~
~ A

NOT A
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NOT (Multiple) ~
A ~ B

A NOT B

Note: you can refer to web sources for more information on Boolean queries,

syntax and other operators you can use in you searches.

Indexing PDFs

Create and manage an index in PDF

You can create an Index that consists of a catalog of PDF documents to speed

up searching across a large volume of documents. It's faster and more

efficient to search the index than to search the document. Before indexing

PDF documents, you have to collect all PDF documents to be indexed into one

or more folders. Make sure that the existing folder you choose contains only

the PDF files to be indexed. The way you search documents without

embedded indexes is exactly the same as how your search those with indexes.

Add an index to a PDF

1. Open a PDF file in Right PDF.

2. Choose Basic > Index, and then select Embedded Index... from the

menu.

3. In the Embedded Index dialog box, click Create to add an index to the

PDF document that currently has no embedded index. Read the

message that follows and click OK.
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Update or remove the embedded index in a PDF

1. Open a PDF file in Right PDF.

2. Choose Basic > Index and then select Embedded Index... from the

menu.

3. In the Embedded Index dialog box, do an appropriate action as needed

and then click OK.

o Click Delete to delete current index in the PDF.

o If the PDF file has been modified, click Update will result in

updating the index.

Create a full text index for multiple PDF documents

Using Create Full Text Indexes, you can create an index that contains a catalog

of PDF documents. An index is especially useful when you want to search

cataloged PDF documents for certain information. The search engine searches

the selected index rather than the documents themselves, making the search

process much faster.

To create an index

When you create a new index, an index file (*.zpi) is created along with a

support index file that contains one or more files.

1. Open a PDF file and choose Basic > Index. Click the down-pointing

arrow to the right of Index and select Create Full Text indexes... from

the menu.

2. In the Catalog dialog box, type a name for the new index.

3. In Description, enter a few words to describe the purposes or the type

of the index.

4. In Stop Words, enter words you want to ignore during the index search

process and click Add. Repeat it to add more words. To remove an item

from the list, click to highlight one and click Del.

5. In Custom Field, type a field name, select a type for the index and then

click Add.

6. Under Include Directory, click Add and locate a folder containing some

or all of the PDF files to be indexed and then click OK. Repeat this step
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to add more folders. To remove a folder from the list, select one and

click Del.

7. Under Exclude Directory, click Add and select any nested folder that

contains PDF files you do not want to be indexed and then click OK.

Repeat this step to add more folders. To remove a folder from the list,

select one and click Del.

8. Click Build, give the (*.zpi) file a name, and specify a location for it. Click

Save.

o The Building dialog box shows the progress of indexing. You can

click Stop to cancel the indexing process or click Close when the

indexing process finishes.

o Note that if canceling the indexing, you cannot resume the same

indexing session anymore but you don't have to redo the work.

All the settings and folders chosen remain intact. You can simply

click Open, select the partially finished index and revise it.

To revise an index

You can rebuild, purge an existing index folder, or create a new index with the

existing information.

1. Open a PDF file and choose Basic > Index. Click the down-pointing

arrow to the right of Index and select Create Full Text indexes... from

the menu.

2. In the Catalog dialog box, click the Open button located next to the File

field. Locate and select an existing Index File (*.zpi) and then click Open.

3. Make changes to the selected index as needed. Click Close:

o Build. Create a new index file with the existing information, and

update it by adding new entries and marking changed entries as

invalid. If you make a large number of changes or use this

option repeatedly instead of creating a new index, the time

needed for searching may increase.

o Rebuild. Create a new index by overwriting the existing index

folder and its contents.

o Purge. Delete the index contents (all files in the index folder)

without deleting the index file (*.zpi) itself.
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